gnu: synfigstudio: Update to 1.2.0.
* gnu/packages/patches/synfig-build-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/animation.scm (etl): Update to 0.04.22. (synfig): Update to 1.2.0. [source]: Remove patch. [arguments]: Remove obsolete build phases. [propagated-inputs]: Add fftw. (synfigstudio): Update to 1.2.0. [source]: Remove unnecessary snippet. [arguments]: Remove.
This commit is contained in:
parent
65e7d52a0c
commit
21fea1d1a9
|
@ -992,7 +992,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/superlu-dist-scotchmetis.patch \
|
||||
%D%/packages/patches/swish-e-search.patch \
|
||||
%D%/packages/patches/swish-e-format-security.patch \
|
||||
%D%/packages/patches/synfig-build-fix.patch \
|
||||
%D%/packages/patches/t1lib-CVE-2010-2642.patch \
|
||||
%D%/packages/patches/t1lib-CVE-2011-0764.patch \
|
||||
%D%/packages/patches/t1lib-CVE-2011-1552+CVE-2011-1553+CVE-2011-1554.patch \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2015, 2017 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;;
|
||||
;;; This file is part of GNU Guix.
|
||||
;;;
|
||||
|
@ -23,6 +23,7 @@
|
|||
#:use-module ((guix licenses) #:prefix license:)
|
||||
#:use-module (guix build-system gnu)
|
||||
#:use-module (gnu packages)
|
||||
#:use-module (gnu packages algebra)
|
||||
#:use-module (gnu packages boost)
|
||||
#:use-module (gnu packages compression)
|
||||
#:use-module (gnu packages fontutils)
|
||||
|
@ -38,15 +39,15 @@
|
|||
(define-public etl
|
||||
(package
|
||||
(name "etl")
|
||||
(version "0.04.19")
|
||||
(version "0.04.22")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
;; Keep this synchronized with the synfig release version.
|
||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||
"1.0.2/source/ETL-" version ".tar.gz"))
|
||||
"1.2.0/source/ETL-" version ".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"070c70slizrklq1gbgja8m49xfmq65wlcd6hz6418cpx0wd4r55s"))))
|
||||
"0ii73nsd3xzkhz6w1rnxwphl637j9w82xiy6apa9vin2isdynnmc"))))
|
||||
(build-system gnu-build-system)
|
||||
(home-page "http://www.synfig.org")
|
||||
(synopsis "Extended C++ template library")
|
||||
|
@ -59,7 +60,7 @@ C++ @dfn{Standard Template Library} (STL).")
|
|||
(define-public synfig
|
||||
(package
|
||||
(name "synfig")
|
||||
(version "1.0.2")
|
||||
(version "1.2.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||
|
@ -67,8 +68,7 @@ C++ @dfn{Standard Template Library} (STL).")
|
|||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1d3z2r78j3rkff47q3wl0ami69y3l4nyi5r9zclymb8ar7mgkk9l"))
|
||||
(patches (search-patches "synfig-build-fix.patch"))))
|
||||
"1gqx4gn4c73rqwhsgzx0a460gr9hadmi28csp75rx30qavqsj7k1"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
|
@ -90,16 +90,6 @@ C++ @dfn{Standard Template Library} (STL).")
|
|||
(("remove_child\\(") "remove_node("))
|
||||
(substitute* "src/modules/mod_svg/svg_parser.cpp"
|
||||
(("xmlpp::Node::NodeList") "xmlpp::Node::const_NodeList"))
|
||||
#t))
|
||||
(add-after 'unpack 'fix-isnan-error
|
||||
(lambda _
|
||||
(substitute* "src/synfig/time.cpp"
|
||||
(("return !::isnan") "return !std::isnan"))
|
||||
#t))
|
||||
(add-before 'configure 'set-flags
|
||||
(lambda _
|
||||
;; Compile with C++11, required by libsigc++.
|
||||
(setenv "CXXFLAGS" "-D__STDC_CONSTANT_MACROS -std=gnu++11")
|
||||
#t)))))
|
||||
(inputs
|
||||
`(("boost" ,boost)
|
||||
|
@ -110,11 +100,12 @@ C++ @dfn{Standard Template Library} (STL).")
|
|||
("libmng" ,libmng)
|
||||
("zlib" ,zlib)))
|
||||
;; synfig.pc lists the following as required: Magick++ freetype2
|
||||
;; fontconfig OpenEXR ETL glibmm-2.4 giomm-2.4 libxml++-3.0 sigc++-2.0
|
||||
;; fontconfig fftw OpenEXR ETL glibmm-2.4 giomm-2.4 libxml++-3.0 sigc++-2.0
|
||||
;; cairo pango pangocairo mlt++
|
||||
(propagated-inputs
|
||||
`(("cairo" ,cairo)
|
||||
("etl" ,etl)
|
||||
("fftw" ,fftw)
|
||||
("fontconfig" ,fontconfig)
|
||||
("freetype" ,freetype)
|
||||
("glibmm" ,glibmm)
|
||||
|
@ -137,7 +128,7 @@ for tweening, preventing the need to hand-draw each frame.")
|
|||
(define-public synfigstudio
|
||||
(package
|
||||
(name "synfigstudio")
|
||||
(version "1.0.2")
|
||||
(version "1.2.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "mirror://sourceforge/synfig/releases/"
|
||||
|
@ -145,27 +136,15 @@ for tweening, preventing the need to hand-draw each frame.")
|
|||
".tar.gz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1xa74dlgkpjn0gzdcs0x25z7wg0806v2wygvvi73f7sn1fm88ig4"))
|
||||
"0fbckfbw8dzf0m2wv7vlmw492k1dqa3zf510z019d0as3zpnp6qm"))
|
||||
(modules '((guix build utils)))
|
||||
(snippet
|
||||
'(begin
|
||||
(substitute* "src/synfigapp/pluginmanager.cpp"
|
||||
(("xmlpp::Node\\* n =") "const xmlpp::Node* n =")
|
||||
(("xmlpp::Node::NodeList") "xmlpp::Node::const_NodeList"))
|
||||
;; Some files are ISO-8859-1 encoded.
|
||||
(with-fluids ((%default-port-encoding #f))
|
||||
(substitute* (find-files "src/" "\\.(cpp|h)$")
|
||||
(("#include <sigc\\+\\+/retype\\.h>")
|
||||
"#include <sigc++/adaptors/retype.h>")
|
||||
(("#include <sigc\\+\\+/hide\\.h>")
|
||||
"#include <sigc++/adaptors/hide.h>")
|
||||
(("#include <sigc\\+\\+/object\\.h>")
|
||||
"#include <sigc++/trackable.h>")))
|
||||
#t))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:configure-flags
|
||||
(list "CXXFLAGS=-std=gnu++11")))
|
||||
(inputs
|
||||
`(("gtkmm" ,gtkmm)
|
||||
("libsigc++" ,libsigc++)
|
||||
|
|
|
@ -1,61 +0,0 @@
|
|||
Allow Synfig to build in C++11 mode.
|
||||
|
||||
Taken from here:
|
||||
https://projects.archlinux.org/svntogit/community.git/plain/trunk/build-fix.patch?h=packages/synfig
|
||||
|
||||
diff -wbBur synfig-1.0-RC5/src/modules/mod_libavcodec/mptr.cpp synfig-1.0-RC5.my/src/modules/mod_libavcodec/mptr.cpp
|
||||
--- synfig-1.0-RC5/src/modules/mod_libavcodec/mptr.cpp 2015-03-28 13:15:00.000000000 +0300
|
||||
+++ synfig-1.0-RC5.my/src/modules/mod_libavcodec/mptr.cpp 2015-04-28 16:56:11.568749053 +0300
|
||||
@@ -56,8 +56,8 @@
|
||||
/* === M E T H O D S ======================================================= */
|
||||
|
||||
|
||||
-Importer_LibAVCodec::Importer_LibAVCodec(const char *file):
|
||||
- filename(file)
|
||||
+Importer_LibAVCodec::Importer_LibAVCodec(const synfig::FileSystem::Identifier &identifier):
|
||||
+ Importer(identifier)
|
||||
{
|
||||
}
|
||||
|
||||
diff -wbBur synfig-1.0-RC5/src/modules/mod_libavcodec/mptr.h synfig-1.0-RC5.my/src/modules/mod_libavcodec/mptr.h
|
||||
--- synfig-1.0-RC5/src/modules/mod_libavcodec/mptr.h 2015-03-28 13:15:00.000000000 +0300
|
||||
+++ synfig-1.0-RC5.my/src/modules/mod_libavcodec/mptr.h 2015-04-28 16:55:18.699192946 +0300
|
||||
@@ -46,7 +46,7 @@
|
||||
synfig::String filename;
|
||||
|
||||
public:
|
||||
- Importer_LibAVCodec(const char *filename);
|
||||
+ Importer_LibAVCodec(const synfig::FileSystem::Identifier &identifier);
|
||||
~Importer_LibAVCodec();
|
||||
|
||||
virtual bool get_frame(synfig::Surface &surface, const synfig::RendDesc &renddesc, synfig::Time time, synfig::ProgressCallback *callback);
|
||||
diff -wbBur synfig-1.0-RC5/src/modules/mod_libavcodec/trgt_av.cpp synfig-1.0-RC5.my/src/modules/mod_libavcodec/trgt_av.cpp
|
||||
--- synfig-1.0-RC5/src/modules/mod_libavcodec/trgt_av.cpp 2015-03-28 13:15:00.000000000 +0300
|
||||
+++ synfig-1.0-RC5.my/src/modules/mod_libavcodec/trgt_av.cpp 2015-04-28 16:46:54.720091106 +0300
|
||||
@@ -121,14 +121,14 @@
|
||||
picture = avcodec_alloc_frame();
|
||||
if (!picture)
|
||||
return NULL;
|
||||
- size = avpicture_get_size(pix_fmt, width, height);
|
||||
+ size = avpicture_get_size((::PixelFormat)pix_fmt, width, height);
|
||||
picture_buf = (uint8_t *)malloc(size);
|
||||
if (!picture_buf) {
|
||||
av_free(picture);
|
||||
return NULL;
|
||||
}
|
||||
avpicture_fill((AVPicture *)picture, picture_buf,
|
||||
- pix_fmt, width, height);
|
||||
+ (::PixelFormat)pix_fmt, width, height);
|
||||
return picture;
|
||||
}
|
||||
|
||||
diff -wbBur synfig-1.0.2/src/synfig/time.cpp synfig-1.0.2.my/src/synfig/time.cpp
|
||||
--- synfig-1.0.2/src/synfig/time.cpp 2015-07-09 10:33:03.000000000 +0300
|
||||
+++ synfig-1.0.2.my/src/synfig/time.cpp 2015-10-12 13:54:58.382313903 +0300
|
||||
@@ -319,5 +319,5 @@
|
||||
bool
|
||||
Time::is_valid()const
|
||||
{
|
||||
- return !isnan(value_);
|
||||
+ return !::isnan(value_);
|
||||
}
|
Loading…
Reference in New Issue