gnu: Resurrect xf86-video-geode and update to 2.11.16.

* gnu/packages/patches/xf86-video-geode-glibc-2.20.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/xorg.scm (xf86-video-geode): Uncomment it.  Update
  to 2.11.16.  Add patch.
master
Mark H Weaver 2014-12-19 15:45:59 -05:00
parent 2c0a2d7a4f
commit 232af79efb
3 changed files with 38 additions and 22 deletions

View File

@ -459,6 +459,7 @@ dist_patch_DATA = \
gnu/packages/patches/w3m-fix-compile.patch \
gnu/packages/patches/wmctrl-64-fix.patch \
gnu/packages/patches/xf86-video-ark-remove-mibstore.patch \
gnu/packages/patches/xf86-video-geode-glibc-2.20.patch \
gnu/packages/patches/xf86-video-openchrome-includes.patch \
gnu/packages/patches/xfce4-panel-plugins.patch \
gnu/packages/patches/xmodmap-asprintf.patch

View File

@ -0,0 +1,15 @@
Allow builds with glibc 2.20.
Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
--- xf86-video-geode-2.11.16/src/lx_memory.c.~1~ 2014-07-16 16:59:37.000000000 -0400
+++ xf86-video-geode-2.11.16/src/lx_memory.c 2014-12-19 00:38:11.753388268 -0500
@@ -23,6 +23,8 @@
* software without specific prior written permission.
*/
+#include <xorg-server.h>
+
#include "xf86.h"
#include "geode.h"
#include "cim/cim_regs.h"

View File

@ -2480,28 +2480,28 @@ devices, thus making direct access unnecessary.")
(license license:x11)))
;; Compilation errors: Assembler messages operand size mismatch etc.
;; (define-public xf86-video-geode
;; (package
;; (name "xf86-video-geode")
;; (version "2.11.13")
;; (source
;; (origin
;; (method url-fetch)
;; (uri (string-append
;; "mirror://xorg/X11R7.7/src/everything/xf86-video-geode-"
;; version
;; ".tar.bz2"))
;; (sha256
;; (base32
;; "09p2cjd2fb7h32k9qs4wp7qvhfn2zv454spv5mfplv7w2jis4863"))))
;; (build-system gnu-build-system)
;; (inputs `(("pkg-config" ,pkg-config)
;; ("xorg-server" ,xorg-server)))
;; (home-page "http://www.x.org/wiki/")
;; (synopsis "Xorg implementation of the X Window System")
;; (description "X.org provides an implementation of the X Window System")
;; (license license:x11)))
(define-public xf86-video-geode
(package
(name "xf86-video-geode")
(version "2.11.16")
(source
(origin
(method url-fetch)
(uri (string-append
"mirror://xorg/individual/driver/xf86-video-geode-"
version
".tar.bz2"))
(sha256
(base32
"19y13xl7yfrgyis92rmxi0ld95ajgr5il0n9j1dridwzw9aizz1q"))
(patches (list (search-patch "xf86-video-geode-glibc-2.20.patch")))))
(build-system gnu-build-system)
(inputs `(("pkg-config" ,pkg-config)
("xorg-server" ,xorg-server)))
(home-page "http://www.x.org/wiki/")
(synopsis "Xorg implementation of the X Window System")
(description "X.org provides an implementation of the X Window System")
(license license:x11)))
;; Driver for obsolete graphics cards, depends on libglide: