gnu: bowtie: fix build errors

* gnu/packages/bioinformatics.scm (bowtie): Add 'supported-systems' field and
  add Makefile patch.
* gnu/packages/patches/bowtie-fix-makefile.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
master
Ricardo Wurmus 2015-01-29 10:35:52 +01:00
parent e89fa047f7
commit 241e122193
3 changed files with 36 additions and 2 deletions

View File

@ -346,6 +346,7 @@ dist_patch_DATA = \
gnu/packages/patches/automake-skip-amhello-tests.patch \
gnu/packages/patches/avahi-localstatedir.patch \
gnu/packages/patches/avrdude-fix-libusb.patch \
gnu/packages/patches/bowtie-fix-makefile.patch \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \
gnu/packages/patches/binutils-loongson-workaround.patch \

View File

@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2014, 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@ -95,7 +95,8 @@ BED, GFF/GTF, VCF.")
(("^CPP = .*$") "CPP = g++")
;; replace BUILD_HOST and BUILD_TIME for deterministic build
(("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))))
(("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\"")))
(patches (list (search-patch "bowtie-fix-makefile.patch")))))
(build-system gnu-build-system)
(inputs `(("perl" ,perl)
("perl-clone" ,perl-clone)
@ -133,6 +134,7 @@ aligning to relatively long (e.g. mammalian) genomes. Bowtie 2 indexes the
genome with an FM Index to keep its memory footprint small: for the human
genome, its memory footprint is typically around 3.2 GB. Bowtie 2 supports
gapped, local, and paired-end alignment modes.")
(supported-systems '("x86_64-linux"))
(license license:gpl3+)))
(define-public samtools

View File

@ -0,0 +1,31 @@
From 4a99b0023bdfbbe486b9649489a32ea184c18c9a Mon Sep 17 00:00:00 2001
From: Valentin Antonescu <valentin@jhu.edu>
Date: Tue, 2 Dec 2014 11:19:13 -0500
Subject: [PATCH] Make sure the Mavericks test happens only under Darwin.
---
Makefile | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/Makefile b/Makefile
index d74f7c8..a4cdfa7 100644
--- a/Makefile
+++ b/Makefile
@@ -54,12 +54,11 @@ endif
MACOS = 0
ifneq (,$(findstring Darwin,$(shell uname)))
MACOS = 1
-endif
-
-ifneq (,$(findstring 13,$(shell uname -r)))
- CPP = clang++
- CC = clang
- EXTRA_FLAGS += -stdlib=libstdc++
+ ifneq (,$(findstring 13,$(shell uname -r)))
+ CPP = clang++
+ CC = clang
+ EXTRA_FLAGS += -stdlib=libstdc++
+ endif
endif
POPCNT_CAPABILITY ?= 1