gnu: borg: The backup client cannot override the server-side storage quota.
* gnu/packages/patches/borg-respect-storage-quota.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/backup.scm (borg)[source]: Use it.
This commit is contained in:
parent
236fadf528
commit
247537da81
|
@ -599,6 +599,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/binutils-loongson-workaround.patch \
|
%D%/packages/patches/binutils-loongson-workaround.patch \
|
||||||
%D%/packages/patches/blast+-fix-makefile.patch \
|
%D%/packages/patches/blast+-fix-makefile.patch \
|
||||||
%D%/packages/patches/boost-fix-icu-build.patch \
|
%D%/packages/patches/boost-fix-icu-build.patch \
|
||||||
|
%D%/packages/patches/borg-respect-storage-quota.patch \
|
||||||
%D%/packages/patches/byobu-writable-status.patch \
|
%D%/packages/patches/byobu-writable-status.patch \
|
||||||
%D%/packages/patches/cairo-CVE-2016-9082.patch \
|
%D%/packages/patches/cairo-CVE-2016-9082.patch \
|
||||||
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
%D%/packages/patches/calibre-no-updates-dialog.patch \
|
||||||
|
|
|
@ -498,6 +498,7 @@ detection, and lossless compression.")
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (pypi-uri "borgbackup" version))
|
(uri (pypi-uri "borgbackup" version))
|
||||||
|
(patches (search-patches "borg-respect-storage-quota.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1p3zia62vyg9vadkdjzzkzbj4dmgijr7ix5lmhfbxpwy5q9imdgp"))
|
"1p3zia62vyg9vadkdjzzkzbj4dmgijr7ix5lmhfbxpwy5q9imdgp"))
|
||||||
|
|
|
@ -0,0 +1,32 @@
|
||||||
|
Make sure the client respects the storage quota set by the server:
|
||||||
|
|
||||||
|
https://github.com/borgbackup/borg/issues/4093
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://github.com/borgbackup/borg/commit/975cc33206e0e3644626fb7204c34d2157715b61
|
||||||
|
|
||||||
|
From 975cc33206e0e3644626fb7204c34d2157715b61 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Manu <manu@snapdragon.cc>
|
||||||
|
Date: Wed, 3 Oct 2018 23:47:36 +0800
|
||||||
|
Subject: [PATCH] Add storage_quota for forced_result if set by serve command.
|
||||||
|
|
||||||
|
---
|
||||||
|
src/borg/archiver.py | 1 +
|
||||||
|
1 file changed, 1 insertion(+)
|
||||||
|
|
||||||
|
diff --git a/src/borg/archiver.py b/src/borg/archiver.py
|
||||||
|
index 916725e7..279194c1 100644
|
||||||
|
--- a/src/borg/archiver.py
|
||||||
|
+++ b/src/borg/archiver.py
|
||||||
|
@@ -4276,6 +4276,7 @@ def get_args(self, argv, cmd):
|
||||||
|
result.restrict_to_paths = forced_result.restrict_to_paths
|
||||||
|
result.restrict_to_repositories = forced_result.restrict_to_repositories
|
||||||
|
result.append_only = forced_result.append_only
|
||||||
|
+ result.storage_quota = forced_result.storage_quota
|
||||||
|
return result
|
||||||
|
|
||||||
|
def parse_args(self, args=None):
|
||||||
|
--
|
||||||
|
2.19.1
|
||||||
|
|
Loading…
Reference in New Issue