gnu: python-dendropy: Update to 4.2.0.

* gnu/packages/bioinformatics.scm (python-dendropy): Update to 4.2.0.
[source]: Remove patch.
(python2-dendropy)[source]: Use the same source as python-dendropy.
* gnu/packages/patches/python-dendropy-exclude-failing-tests.patch: Remove
file.
* gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
Ben Woodcroft 2017-01-01 16:37:08 +10:00
parent 322a583fcf
commit 25d84d3122
No known key found for this signature in database
GPG Key ID: 2A6AD9F4AAC20DF6
3 changed files with 2 additions and 38 deletions

View File

@ -814,7 +814,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-3-search-paths.patch \
%D%/packages/patches/python-3.4-fix-tests.patch \
%D%/packages/patches/python-3.5-fix-tests.patch \
%D%/packages/patches/python-dendropy-exclude-failing-tests.patch \
%D%/packages/patches/python-file-double-encoding-bug.patch \
%D%/packages/patches/python-fix-tests.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \

View File

@ -1930,19 +1930,14 @@ accessing bigWig files.")
(define-public python-dendropy
(package
(name "python-dendropy")
(version "4.1.0")
(version "4.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "DendroPy" version))
(sha256
(base32
"1jfz7gp18wph311w1yygbvjanb3n5mdqal439bb6myw41dwb5m63"))
;; There are two known test failures that will be fixed in the next
;; release after 4.1.0.
;; https://github.com/jeetsukumaran/DendroPy/issues/48
(patches (search-patches
"python-dendropy-exclude-failing-tests.patch"))))
"15c7s3d5gf19ljsxvq5advaa752wfi7pwrdjyhzmg85hccyvp47p"))))
(build-system python-build-system)
(home-page "http://packages.python.org/DendroPy/")
(synopsis "Library for phylogenetics and phylogenetic computing")
@ -1957,15 +1952,6 @@ trees (phylogenies) and characters.")
(let ((base (package-with-python2 (strip-python2-variant python-dendropy))))
(package
(inherit base)
;; Do not use same source as 'python-dendropy' because the patched
;; failing tests do not occur on Python 2.
(source
(origin
(method url-fetch)
(uri (pypi-uri "DendroPy" (package-version base)))
(sha256
(base32
"1jfz7gp18wph311w1yygbvjanb3n5mdqal439bb6myw41dwb5m63"))))
(arguments
`(#:python ,python-2
#:phases

View File

@ -1,21 +0,0 @@
diff --git a/dendropy/test/test_phylogenetic_distance_matrix.py b/dendropy/test/test_phylogenetic_distance_matrix.py
index 10c05f5..a18ba52 100644
--- a/dendropy/test/test_phylogenetic_distance_matrix.py
+++ b/dendropy/test/test_phylogenetic_distance_matrix.py
@@ -793,7 +793,7 @@ class PdmUpgmaTree(PdmTreeChecker, unittest.TestCase):
expected_tree=expected_tree)
class NodeToNodeDistancesTest(unittest.TestCase):
-
+ @unittest.expectedFailure
def test_distances(self):
## get distances from ape
# library(ape)
@@ -825,6 +825,7 @@ class NodeToNodeDistancesTest(unittest.TestCase):
e = reference_table[nd1.label, nd2.label]
self.assertAlmostEqual(d, e)
+ @unittest.expectedFailure
def test_mrca(self):
test_runs = [
"hiv1.newick",