gnu: python-pbr-minimal: Update to 3.0.1
* gnu/packages/python.scm (python-pbr-minimal): Update to 3.0.1 [source]: Update hash and remove patch. * gnu/packages/patches/python-pbr-fix-man-page-support.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
This commit is contained in:
parent
3d0fbd3c2f
commit
269504a797
|
@ -971,7 +971,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-pandas-skip-failing-tests.patch \
|
||||
%D%/packages/patches/python-paste-remove-website-test.patch \
|
||||
%D%/packages/patches/python-paste-remove-timing-test.patch \
|
||||
%D%/packages/patches/python-pbr-fix-man-page-support.patch \
|
||||
%D%/packages/patches/python-pillow-freetype-2.7-test-failure.patch \
|
||||
%D%/packages/patches/python-pygit2-disable-network-tests.patch \
|
||||
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
See: https://bugs.launchpad.net/oslosphinx/+bug/1661861
|
||||
diff -ur orig/pbr-1.10.0/pbr/builddoc.py pbr-1.10.0/pbr/builddoc.py
|
||||
--- orig/pbr-1.10.0/pbr/builddoc.py 2016-05-23 21:38:18.000000000 +0200
|
||||
+++ pbr-1.10.0/pbr/builddoc.py 2017-02-18 14:01:37.424434317 +0100
|
||||
@@ -138,7 +138,8 @@
|
||||
sphinx_config.init_values(warnings.warn)
|
||||
else:
|
||||
sphinx_config.init_values()
|
||||
- if self.builder == 'man' and len(sphinx_config.man_pages) == 0:
|
||||
+ if self.builder == 'man' and len(
|
||||
+ getattr(sphinx_config, 'man_pages', '')) == 0:
|
||||
return
|
||||
app = application.Sphinx(
|
||||
self.source_dir, self.config_dir,
|
||||
diff -ur orig/pbr-1.10.0/pbr/util.py pbr-1.10.0/pbr/util.py
|
||||
--- orig/pbr-1.10.0/pbr/util.py 2016-05-23 21:38:18.000000000 +0200
|
||||
+++ pbr-1.10.0/pbr/util.py 2017-02-18 15:36:32.951196795 +0100
|
||||
@@ -211,7 +211,9 @@
|
||||
parser.read(path)
|
||||
config = {}
|
||||
for section in parser.sections():
|
||||
- config[section] = dict(parser.items(section))
|
||||
+ config[section] = dict()
|
||||
+ for k, value in parser.items(section):
|
||||
+ config[section][k.replace('-', '_')] = value
|
||||
|
||||
# Run setup_hooks, if configured
|
||||
setup_hooks = has_get_option(config, 'global', 'setup_hooks')
|
|
@ -2276,15 +2276,14 @@ protocol.")
|
|||
(define python-pbr-minimal
|
||||
(package
|
||||
(name "python-pbr-minimal")
|
||||
(version "1.10.0")
|
||||
(version "3.0.1")
|
||||
(source
|
||||
(origin
|
||||
(method url-fetch)
|
||||
(uri (pypi-uri "pbr" version))
|
||||
(sha256
|
||||
(base32
|
||||
"177kd9kbv1hvf2ban7l3x9ymzbi1md4hkaymwbgnz7ihf312hr0q"))
|
||||
(patches (search-patches "python-pbr-fix-man-page-support.patch"))))
|
||||
"14fs5acnalnb3h62s7q7av239j541fk0n0z0lawh4h09b1s93s6p"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f))
|
||||
|
|
Loading…
Reference in New Issue