gnu: qtbase: Fix build with glibc >= 2.28.
* gnu/packages/patches/qtbase-glibc-compat.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/qt.scm (qtbase)[source](patches): Use it. [arguments]: Remove "--no-feature-renameat2" from #:configure-flags.
This commit is contained in:
parent
53b7c9716e
commit
279ed3efee
|
@ -1097,6 +1097,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python-waitress-fix-tests.patch \
|
%D%/packages/patches/python-waitress-fix-tests.patch \
|
||||||
%D%/packages/patches/qemu-glibc-2.27.patch \
|
%D%/packages/patches/qemu-glibc-2.27.patch \
|
||||||
%D%/packages/patches/qt4-ldflags.patch \
|
%D%/packages/patches/qt4-ldflags.patch \
|
||||||
|
%D%/packages/patches/qtbase-glibc-compat.patch \
|
||||||
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
%D%/packages/patches/qtbase-use-TZDIR.patch \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||||
|
|
|
@ -0,0 +1,50 @@
|
||||||
|
Fix qmake build with glibc 2.28.
|
||||||
|
|
||||||
|
Taken from upstream:
|
||||||
|
https://code.qt.io/cgit/qt/qtbase.git/commit/?id=25feee4e061b99edab79503d81f5bd045c6c8e3d
|
||||||
|
|
||||||
|
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
|
||||||
|
index 3469ebe5e6..c5585ea32a 100644
|
||||||
|
--- a/src/corelib/global/qconfig-bootstrapped.h
|
||||||
|
+++ b/src/corelib/global/qconfig-bootstrapped.h
|
||||||
|
@@ -98,10 +98,18 @@
|
||||||
|
#define QT_NO_QOBJECT
|
||||||
|
#define QT_FEATURE_process -1
|
||||||
|
#define QT_FEATURE_regularexpression -1
|
||||||
|
-#define QT_FEATURE_renameat2 -1
|
||||||
|
+#ifdef __GLIBC_PREREQ
|
||||||
|
+# define QT_FEATURE_renameat2 (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
||||||
|
+#else
|
||||||
|
+# define QT_FEATURE_renameat2 -1
|
||||||
|
+#endif
|
||||||
|
#define QT_FEATURE_sharedmemory -1
|
||||||
|
#define QT_FEATURE_slog2 -1
|
||||||
|
-#define QT_FEATURE_statx -1
|
||||||
|
+#ifdef __GLIBC_PREREQ
|
||||||
|
+# define QT_FEATURE_statx (__GLIBC_PREREQ(2, 28) ? 1 : -1)
|
||||||
|
+#else
|
||||||
|
+# define QT_FEATURE_statx -1
|
||||||
|
+#endif
|
||||||
|
#define QT_FEATURE_syslog -1
|
||||||
|
#define QT_NO_SYSTEMLOCALE
|
||||||
|
#define QT_FEATURE_systemsemaphore -1
|
||||||
|
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
index 0c9cdb8667..deb4a9f220 100644
|
||||||
|
--- a/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
|
||||||
|
@@ -91,7 +91,6 @@ extern "C" NSString *NSTemporaryDirectory();
|
||||||
|
# include <sys/syscall.h>
|
||||||
|
# include <sys/sendfile.h>
|
||||||
|
# include <linux/fs.h>
|
||||||
|
-# include <linux/stat.h>
|
||||||
|
|
||||||
|
// in case linux/fs.h is too old and doesn't define it:
|
||||||
|
#ifndef FICLONE
|
||||||
|
@@ -112,6 +111,7 @@ static int renameat2(int oldfd, const char *oldpath, int newfd, const char *newp
|
||||||
|
# endif
|
||||||
|
|
||||||
|
# if !QT_CONFIG(statx) && defined(SYS_statx)
|
||||||
|
+# include <linux/stat.h>
|
||||||
|
static int statx(int dirfd, const char *pathname, int flag, unsigned mask, struct statx *statxbuf)
|
||||||
|
{ return syscall(SYS_statx, dirfd, pathname, flag, mask, statxbuf); }
|
||||||
|
# elif !QT_CONFIG(statx) && !defined(SYS_statx)
|
|
@ -494,7 +494,8 @@ system, and the core design of Django is reused in Grantlee.")
|
||||||
(base32
|
(base32
|
||||||
"0ipv18ypbgpxhh49rfplqmflskmnhhwj1bjr5hrwi0jpvar4gl50"))
|
"0ipv18ypbgpxhh49rfplqmflskmnhhwj1bjr5hrwi0jpvar4gl50"))
|
||||||
;; Use TZDIR to avoid depending on package "tzdata".
|
;; Use TZDIR to avoid depending on package "tzdata".
|
||||||
(patches (search-patches "qtbase-use-TZDIR.patch"))
|
(patches (search-patches "qtbase-use-TZDIR.patch"
|
||||||
|
"qtbase-glibc-compat.patch"))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
;; corelib uses bundled harfbuzz, md4, md5, sha3
|
;; corelib uses bundled harfbuzz, md4, md5, sha3
|
||||||
|
@ -608,7 +609,6 @@ system, and the core design of Django is reused in Grantlee.")
|
||||||
;; kernels that the glibc supports, including the RHEL6
|
;; kernels that the glibc supports, including the RHEL6
|
||||||
;; (2.6.32) and RHEL7 (3.10) kernels.
|
;; (2.6.32) and RHEL7 (3.10) kernels.
|
||||||
"-no-feature-getentropy" ; requires Linux 3.17
|
"-no-feature-getentropy" ; requires Linux 3.17
|
||||||
"-no-feature-renameat2" ; requires Linux 3.16
|
|
||||||
|
|
||||||
;; Do not build examples; if desired, these could go
|
;; Do not build examples; if desired, these could go
|
||||||
;; into a separate output, but for the time being, we
|
;; into a separate output, but for the time being, we
|
||||||
|
|
Loading…
Reference in New Issue