gnu: automake: Adjust test to ignore new gzip warnings.

* gnu/packages/patches/automake-test-gzip-warning.patch: New file.
* gnu/packages/autotools.scm (automake)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Ludovic Courtès 2016-06-14 09:41:38 +02:00
parent 9f44dfc077
commit 28206a8ebf
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
3 changed files with 20 additions and 1 deletions

View File

@ -435,6 +435,7 @@ dist_patch_DATA = \
%D%/packages/patches/audacity-fix-ffmpeg-binding.patch \
%D%/packages/patches/automake-skip-amhello-tests.patch \
%D%/packages/patches/automake-regexp-syntax.patch \
%D%/packages/patches/automake-test-gzip-warning.patch \
%D%/packages/patches/avahi-localstatedir.patch \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/avrdude-fix-libusb.patch \

View File

@ -218,7 +218,8 @@ output is indexed in many ways to simplify browsing.")
"0dl6vfi2lzz8alnklwxzfz624b95hb1ipjvd3mk177flmddcf24r"))
(patches
(search-patches "automake-regexp-syntax.patch"
"automake-skip-amhello-tests.patch"))))
"automake-skip-amhello-tests.patch"
"automake-test-gzip-warning.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,(autoconf-wrapper))

View File

@ -0,0 +1,17 @@
Adjust test to ignore gzip 1.8+ warnings.
--- automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:36:26.554218552 +0200
+++ automake-1.15/t/distcheck-no-prefix-or-srcdir-override.sh 2016-06-14 00:37:52.903157770 +0200
@@ -49,7 +49,11 @@ grep "cannot find sources.* in foobar" s
./configure
run_make -E -O distcheck
-test ! -s stderr
+
+# Gzip 1.8+ emits warnings like "gzip: warning: GZIP environment
+# variable is deprecated"; filter them out.
+test `grep -v '^gzip: warning' stderr | wc -l` -eq 0
+
# Sanity check: the flags have been actually seen.
$PERL -e 'undef $/; $_ = <>; s/ \\\n/ /g; print;' <stdout >t
grep '/configure .* --srcdir am-src' t || exit 99