gnu: gtk+-2: Add patch to support GUIX_GTK2_PATH.
* gnu/packages/patches/gtk2-respect-GUIX_GTK2_PATH: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gtk.scm (gtk+-2) [source]: Add patch. [native-search-paths]: Add search path for GUIX_GTK2_PATH.
This commit is contained in:
parent
c2e87caaa6
commit
2a6afac905
|
@ -506,6 +506,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/guile-present-coding.patch \
|
||||
gnu/packages/patches/guile-relocatable.patch \
|
||||
gnu/packages/patches/guile-rsvg-pkgconfig.patch \
|
||||
gnu/packages/patches/gtk2-respect-GUIX_GTK2_PATH.patch \
|
||||
gnu/packages/patches/gtkglext-disable-disable-deprecated.patch \
|
||||
gnu/packages/patches/hop-bigloo-4.0b.patch \
|
||||
gnu/packages/patches/hop-linker-flags.patch \
|
||||
|
|
|
@ -522,7 +522,8 @@ is part of the GNOME accessibility project.")
|
|||
name "-" version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"0mj6xn40py9r9lvzg633fal81xfwfm89d9mvz7jk4lmwk0g49imj"))))
|
||||
"0mj6xn40py9r9lvzg633fal81xfwfm89d9mvz7jk4lmwk0g49imj"))
|
||||
(patches (list (search-patch "gtk2-respect-GUIX_GTK2_PATH.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(outputs '("out" "doc"))
|
||||
(propagated-inputs
|
||||
|
@ -557,7 +558,11 @@ is part of the GNOME accessibility project.")
|
|||
;; FIXME: re-enable tests requiring an X server
|
||||
(substitute* "gtk/Makefile.in"
|
||||
(("SUBDIRS = theme-bits . tests") "SUBDIRS = theme-bits .")))
|
||||
%standard-phases)))
|
||||
%standard-phases)))
|
||||
(native-search-paths
|
||||
(list (search-path-specification
|
||||
(variable "GUIX_GTK2_PATH")
|
||||
(files '("lib/gtk-2.0")))))
|
||||
(synopsis "Cross-platform toolkit for creating graphical user interfaces")
|
||||
(description
|
||||
"GTK+, or the GIMP Toolkit, is a multi-platform toolkit for creating
|
||||
|
|
|
@ -0,0 +1,46 @@
|
|||
This patch makes GTK+ look for additional modules in a list of directories
|
||||
specified by the environment variable "GUIX_GTK2_PATH". This can be used
|
||||
instead of "GTK_PATH" to make GTK+ find modules that are incompatible with
|
||||
other major versions of GTK+.
|
||||
|
||||
--- a/gtk/gtkmodules.c 2014-09-29 22:02:17.000000000 +0200
|
||||
+++ b/gtk/gtkmodules.c 2015-12-02 18:41:53.306396938 +0100
|
||||
@@ -55,6 +55,7 @@
|
||||
get_module_path (void)
|
||||
{
|
||||
const gchar *module_path_env;
|
||||
+ const gchar *module_guix_gtk2_path_env;
|
||||
const gchar *exe_prefix;
|
||||
const gchar *home_dir;
|
||||
gchar *home_gtk_dir = NULL;
|
||||
@@ -70,6 +71,7 @@
|
||||
home_gtk_dir = g_build_filename (home_dir, ".gtk-2.0", NULL);
|
||||
|
||||
module_path_env = g_getenv ("GTK_PATH");
|
||||
+ module_guix_gtk2_path_env = g_getenv ("GUIX_GTK2_PATH");
|
||||
exe_prefix = g_getenv ("GTK_EXE_PREFIX");
|
||||
|
||||
if (exe_prefix)
|
||||
@@ -77,9 +79,21 @@
|
||||
else
|
||||
default_dir = g_build_filename (GTK_LIBDIR, "gtk-2.0", NULL);
|
||||
|
||||
- if (module_path_env && home_gtk_dir)
|
||||
+ if (module_guix_gtk2_path_env && module_path_env && home_gtk_dir)
|
||||
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
+ module_guix_gtk2_path_env, module_path_env, home_gtk_dir, default_dir, NULL);
|
||||
+ else if (module_guix_gtk2_path_env && home_gtk_dir)
|
||||
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
+ module_guix_gtk2_path_env, home_gtk_dir, default_dir, NULL);
|
||||
+ else if (module_guix_gtk2_path_env && module_path_env)
|
||||
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
+ module_guix_gtk2_path_env, module_path_env, default_dir, NULL);
|
||||
+ else if (module_path_env && home_gtk_dir)
|
||||
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
module_path_env, home_gtk_dir, default_dir, NULL);
|
||||
+ else if (module_guix_gtk2_path_env)
|
||||
+ module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
+ module_guix_gtk2_path_env, default_dir, NULL);
|
||||
else if (module_path_env)
|
||||
module_path = g_build_path (G_SEARCHPATH_SEPARATOR_S,
|
||||
module_path_env, default_dir, NULL);
|
Loading…
Reference in New Issue