gnu: OpenSSH: Fix CVE-2018-20685.
* gnu/packages/patches/openssh-CVE-2018-20685.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/ssh.scm (openssh)[source]: Use it.
This commit is contained in:
parent
65cd70ce42
commit
2b65a9e6d1
|
@ -1088,6 +1088,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
%D%/packages/patches/openldap-CVE-2017-9287.patch \
|
||||||
%D%/packages/patches/openocd-nrf52.patch \
|
%D%/packages/patches/openocd-nrf52.patch \
|
||||||
%D%/packages/patches/opensmtpd-fix-crash.patch \
|
%D%/packages/patches/opensmtpd-fix-crash.patch \
|
||||||
|
%D%/packages/patches/openssh-CVE-2018-20685.patch \
|
||||||
%D%/packages/patches/openssl-runpath.patch \
|
%D%/packages/patches/openssl-runpath.patch \
|
||||||
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
|
%D%/packages/patches/openssl-1.1-c-rehash-in.patch \
|
||||||
%D%/packages/patches/openssl-c-rehash-in.patch \
|
%D%/packages/patches/openssl-c-rehash-in.patch \
|
||||||
|
|
|
@ -0,0 +1,44 @@
|
||||||
|
Fix CVE-2018-20685:
|
||||||
|
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-20685
|
||||||
|
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://github.com/openssh/openssh-portable/commit/6010c0303a422a9c5fa8860c061bf7105eb7f8b2
|
||||||
|
|
||||||
|
From 6010c0303a422a9c5fa8860c061bf7105eb7f8b2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: "djm@openbsd.org" <djm@openbsd.org>
|
||||||
|
Date: Fri, 16 Nov 2018 03:03:10 +0000
|
||||||
|
Subject: [PATCH] upstream: disallow empty incoming filename or ones that refer
|
||||||
|
to the
|
||||||
|
|
||||||
|
current directory; based on report/patch from Harry Sintonen
|
||||||
|
|
||||||
|
OpenBSD-Commit-ID: f27651b30eaee2df49540ab68d030865c04f6de9
|
||||||
|
---
|
||||||
|
scp.c | 5 +++--
|
||||||
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/scp.c b/scp.c
|
||||||
|
index 60682c68..4f3fdcd3 100644
|
||||||
|
--- a/scp.c
|
||||||
|
+++ b/scp.c
|
||||||
|
#@@ -1,4 +1,4 @@
|
||||||
|
#-/* $OpenBSD: scp.c,v 1.197 2018/06/01 04:31:48 dtucker Exp $ */
|
||||||
|
#+/* $OpenBSD: scp.c,v 1.198 2018/11/16 03:03:10 djm Exp $ */
|
||||||
|
# /*
|
||||||
|
# * scp - secure remote copy. This is basically patched BSD rcp which
|
||||||
|
# * uses ssh to do the data transfer (instead of using rcmd).
|
||||||
|
@@ -1106,7 +1106,8 @@ sink(int argc, char **argv)
|
||||||
|
SCREWUP("size out of range");
|
||||||
|
size = (off_t)ull;
|
||||||
|
|
||||||
|
- if ((strchr(cp, '/') != NULL) || (strcmp(cp, "..") == 0)) {
|
||||||
|
+ if (*cp == '\0' || strchr(cp, '/') != NULL ||
|
||||||
|
+ strcmp(cp, ".") == 0 || strcmp(cp, "..") == 0) {
|
||||||
|
run_err("error: unexpected filename: %s", cp);
|
||||||
|
exit(1);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.20.1
|
||||||
|
|
|
@ -149,6 +149,7 @@ a server that supports the SSH-2 protocol.")
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
|
(uri (string-append "mirror://openbsd/OpenSSH/portable/"
|
||||||
name "-" version ".tar.gz"))
|
name "-" version ".tar.gz"))
|
||||||
|
(patches (search-patches "openssh-CVE-2018-20685.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1b8sy6v0b8v4ggmknwcqx3y1rjcpsll0f1f8f4vyv11x4ni3njvb"))))
|
"1b8sy6v0b8v4ggmknwcqx3y1rjcpsll0f1f8f4vyv11x4ni3njvb"))))
|
||||||
|
|
Loading…
Reference in New Issue