gnu: nvi: Fix Berkely DB compatability issues.
* gnu/packages/patches/nvi-db4.patch: New file. * gnu/packages/patches/nvi-dbpagesize-binpower.patch: New file. * gnu/packages/nvi.scm (nvi): Make use of them. * gnu-system.am (dist_patch_DATA): Add them. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
e1626e3b3a
commit
2baf46348f
|
@ -444,6 +444,8 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/ninja-tests.patch \
|
||||
gnu/packages/patches/nss-pkgconfig.patch \
|
||||
gnu/packages/patches/nvi-assume-preserve-path.patch \
|
||||
gnu/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||
gnu/packages/patches/nvi-db4.patch \
|
||||
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
|
||||
gnu/packages/patches/ots-no-include-missing-file.patch \
|
||||
gnu/packages/patches/patchelf-page-size.patch \
|
||||
|
|
|
@ -37,7 +37,9 @@
|
|||
".tar.bz2"))
|
||||
(sha256
|
||||
(base32 "0nbbs1inyrqds0ywn3ln5slv54v5zraq7lszkg8nsavv4kivhh9l"))
|
||||
(patches (list (search-patch "nvi-assume-preserve-path.patch")))
|
||||
(patches (list (search-patch "nvi-assume-preserve-path.patch")
|
||||
(search-patch "nvi-dbpagesize-binpower.patch")
|
||||
(search-patch "nvi-db4.patch")))
|
||||
(snippet
|
||||
;; Create a wrapper for the configure script, make it executable.
|
||||
'(let ((conf-wrap (open-output-file "configure")))
|
||||
|
|
|
@ -0,0 +1,35 @@
|
|||
This patch originates from the Debian project, see https://www.debian.org/
|
||||
|
||||
03db4.dpatch by <hesso@pool.math.tu-berlin.de>
|
||||
|
||||
|
||||
libdb4 compatibility adjustments.
|
||||
|
||||
In particular, this patch adds extra file permission checking and passes the
|
||||
DB_CREATE flag to the first invocation of db_open on the file's database
|
||||
structure, which rids us of the following message:
|
||||
|
||||
BDB0635 DB_CREATE must be specified to create databases.
|
||||
|
||||
--- nvi-1.81.6.orig/common/msg.c 2009-02-26 14:26:58.350336128 +0100
|
||||
+++ nvi-1.81.6/common/msg.c 2009-02-26 14:29:05.235335829 +0100
|
||||
@@ -724,9 +724,18 @@
|
||||
p = buf;
|
||||
} else
|
||||
p = file;
|
||||
+ if (access(p, F_OK) != 0) {
|
||||
+ if (first) {
|
||||
+ first = 0;
|
||||
+ return (1);
|
||||
+ }
|
||||
+ sp->db_error = ENOENT;
|
||||
+ msgq_str(sp, M_DBERR, p, "%s");
|
||||
+ return (1);
|
||||
+ }
|
||||
if ((sp->db_error = db_create(&db, 0, 0)) != 0 ||
|
||||
(sp->db_error = db->set_re_source(db, p)) != 0 ||
|
||||
- (sp->db_error = db_open(db, NULL, DB_RECNO, 0, 0)) != 0) {
|
||||
+ (sp->db_error = db_open(db, NULL, DB_RECNO, DB_CREATE, 0)) != 0) {
|
||||
if (first) {
|
||||
first = 0;
|
||||
return (1);
|
|
@ -0,0 +1,35 @@
|
|||
This patch originates from the Debian project, see https://www.debian.org/
|
||||
|
||||
18dbpagesize_binpower.dpatch by <hesso@pool.math.tu-berlin.de>
|
||||
|
||||
|
||||
Make sure that the pagesize passed to db__set_pagesize() is a power of two.
|
||||
|
||||
nvi stores the content of files in BDB database structures. When initiating a
|
||||
file, it picks a page size for the database to fit the file within 15 pages,
|
||||
with a minimal page size of 1K and maximal of 10K.
|
||||
|
||||
In vanilla nvi, this size is calculated as a multiple of 1024. Modern versions
|
||||
of BDB, however, require the page size of a database to be a power of two, which
|
||||
this patch addresses, ridding us of the following message:
|
||||
|
||||
BDB0511 page sizes must be a power-of-2
|
||||
|
||||
--- nvi-1.81.6.orig/common/exf.c 2009-03-09 01:48:01.695862889 +0100
|
||||
+++ nvi-1.81.6/common/exf.c 2009-03-09 10:42:41.147866272 +0100
|
||||
@@ -249,11 +249,10 @@
|
||||
* (vi should have good locality) or smaller than 1K.
|
||||
*/
|
||||
psize = ((sb.st_size / 15) + 1023) / 1024;
|
||||
- if (psize > 10)
|
||||
- psize = 10;
|
||||
- if (psize == 0)
|
||||
- psize = 1;
|
||||
- psize *= 1024;
|
||||
+ if (psize >= 8) psize=8<<10;
|
||||
+ else if (psize >= 4) psize=4<<10;
|
||||
+ else if (psize >= 2) psize=2<<10;
|
||||
+ else psize=1<<10;
|
||||
|
||||
F_SET(ep, F_DEVSET);
|
||||
ep->mdev = sb.st_dev;
|
Loading…
Reference in New Issue