gnu: ath9k-htc-firmware: Adjust Binutils patch to 2.28.

* gnu/packages/patches/ath9k-htc-firmware-binutils.patch: Remove last
hunk, which is now in Binutils 2.28.
This commit is contained in:
Ludovic Courtès 2017-07-12 23:48:20 +02:00
parent 49d035ff96
commit 2f0d1b9dd2
No known key found for this signature in database
GPG Key ID: 090B11993D9AEBB5
1 changed files with 0 additions and 20 deletions

View File

@ -5,9 +5,6 @@ Not applying the first patch (apparently) leads to miscompiled firmware,
and loading it fails with a "Target is unresponsive" message from the
'ath9k_htc' module.
The final hunk, applied to 'gas/config/tc-xtensa.c', is copied from the
upstream file 'local/patches/binutils-2.27_fixup.patch'.
From dbca73446265ce01b8e11462c3346b25953e3399 Mon Sep 17 00:00:00 2001
From: Sujith Manoharan <c_manoha@qca.qualcomm.com>
Date: Mon, 7 Jan 2013 15:59:53 +0530
@ -28969,20 +28966,3 @@ index 30f4f41..fe9b051 100644
#define XCHAL_MAX_INSTRUCTION_SIZE 3
--
1.8.1
diff --git a/gas/config/tc-xtensa.c b/gas/config/tc-xtensa.c
index d062044..ca261ae 100644
--- a/gas/config/tc-xtensa.c
+++ b/gas/config/tc-xtensa.c
@@ -2228,7 +2228,7 @@ xg_reverse_shift_count (char **cnt_argp)
cnt_arg = *cnt_argp;
/* replace the argument with "31-(argument)" */
- new_arg = concat ("31-(", cnt_argp, ")", (char *) NULL);
+ new_arg = concat ("31-(", cnt_arg, ")", (char *) NULL);
free (cnt_arg);
*cnt_argp = new_arg;
--
2.10.1