gnu: libtiff: Fix CVE-2016-9448.
* gnu/packages/patches/libtiff-CVE-2016-9448.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/image.scm (libtiff/fixed)[source]: Use it.
This commit is contained in:
parent
b7e0f65b40
commit
2fedcd1895
|
@ -671,6 +671,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-5652.patch \
|
%D%/packages/patches/libtiff-CVE-2016-5652.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-9273.patch \
|
%D%/packages/patches/libtiff-CVE-2016-9273.patch \
|
||||||
%D%/packages/patches/libtiff-CVE-2016-9297.patch \
|
%D%/packages/patches/libtiff-CVE-2016-9297.patch \
|
||||||
|
%D%/packages/patches/libtiff-CVE-2016-9448.patch \
|
||||||
%D%/packages/patches/libtiff-oob-accesses-in-decode.patch \
|
%D%/packages/patches/libtiff-oob-accesses-in-decode.patch \
|
||||||
%D%/packages/patches/libtiff-oob-write-in-nextdecode.patch \
|
%D%/packages/patches/libtiff-oob-write-in-nextdecode.patch \
|
||||||
%D%/packages/patches/libtiff-uint32-overflow.patch \
|
%D%/packages/patches/libtiff-uint32-overflow.patch \
|
||||||
|
|
|
@ -302,7 +302,8 @@ collection of tools for doing simple manipulations of TIFF images.")
|
||||||
"libtiff-CVE-2016-5323.patch"
|
"libtiff-CVE-2016-5323.patch"
|
||||||
"libtiff-CVE-2016-5652.patch"
|
"libtiff-CVE-2016-5652.patch"
|
||||||
"libtiff-CVE-2016-9273.patch"
|
"libtiff-CVE-2016-9273.patch"
|
||||||
"libtiff-CVE-2016-9297.patch"))))))
|
"libtiff-CVE-2016-9297.patch"
|
||||||
|
"libtiff-CVE-2016-9448.patch"))))))
|
||||||
|
|
||||||
(define-public libwmf
|
(define-public libwmf
|
||||||
(package
|
(package
|
||||||
|
|
|
@ -0,0 +1,34 @@
|
||||||
|
Fix CVE-2016-9448 (regression caused by fix for CVE-2016-9297).
|
||||||
|
|
||||||
|
http://bugzilla.maptools.org/show_bug.cgi?id=2593
|
||||||
|
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2016-9448
|
||||||
|
|
||||||
|
Patch copied from upstream source repository with:
|
||||||
|
$ cvs diff -u -r 1.203 -r 1.204 libtiff/libtiff/tif_dirread.c
|
||||||
|
|
||||||
|
Index: libtiff/libtiff/tif_dirread.c
|
||||||
|
===================================================================
|
||||||
|
RCS file: /cvs/maptools/cvsroot/libtiff/libtiff/tif_dirread.c,v
|
||||||
|
retrieving revision 1.203
|
||||||
|
retrieving revision 1.204
|
||||||
|
diff -u -r1.203 -r1.204
|
||||||
|
--- libtiff/libtiff/tif_dirread.c 11 Nov 2016 20:22:01 -0000 1.203
|
||||||
|
+++ libtiff/libtiff/tif_dirread.c 16 Nov 2016 15:14:15 -0000 1.204
|
||||||
|
@@ -5000,7 +5000,7 @@
|
||||||
|
if (err==TIFFReadDirEntryErrOk)
|
||||||
|
{
|
||||||
|
int m;
|
||||||
|
- if( data[dp->tdir_count-1] != '\0' )
|
||||||
|
+ if( dp->tdir_count > 0 && data[dp->tdir_count-1] != '\0' )
|
||||||
|
{
|
||||||
|
TIFFWarningExt(tif->tif_clientdata,module,"ASCII value for tag \"%s\" does not end in null byte. Forcing it to be null",fip->field_name);
|
||||||
|
data[dp->tdir_count-1] = '\0';
|
||||||
|
@@ -5177,7 +5177,7 @@
|
||||||
|
if (err==TIFFReadDirEntryErrOk)
|
||||||
|
{
|
||||||
|
int m;
|
||||||
|
- if( data[dp->tdir_count-1] != '\0' )
|
||||||
|
+ if( dp->tdir_count > 0 && data[dp->tdir_count-1] != '\0' )
|
||||||
|
{
|
||||||
|
TIFFWarningExt(tif->tif_clientdata,module,"ASCII value for tag \"%s\" does not end in null byte. Forcing it to be null",fip->field_name);
|
||||||
|
data[dp->tdir_count-1] = '\0';
|
Loading…
Reference in New Issue