gnu: mdadm: Update to 3.4.
* gnu/packages/linux.scm (mdadm): Update to 3.4. [source]: Remove patch. * gnu/packages/patches/mdadm-gcc-4.9-fix.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
e9eb24b1b2
commit
30897c60a4
|
@ -620,7 +620,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/matplotlib-setupext-tk.patch \
|
||||
gnu/packages/patches/maxima-defsystem-mkdir.patch \
|
||||
gnu/packages/patches/mcron-install.patch \
|
||||
gnu/packages/patches/mdadm-gcc-4.9-fix.patch \
|
||||
gnu/packages/patches/mhash-keygen-test-segfault.patch \
|
||||
gnu/packages/patches/mit-krb5-CVE-2015-8629.patch \
|
||||
gnu/packages/patches/mit-krb5-CVE-2015-8630.patch \
|
||||
|
|
|
@ -2318,7 +2318,7 @@ MPEG-2 and audio over Linux IEEE 1394.")
|
|||
(define-public mdadm
|
||||
(package
|
||||
(name "mdadm")
|
||||
(version "3.3.2")
|
||||
(version "3.4")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -2326,8 +2326,7 @@ MPEG-2 and audio over Linux IEEE 1394.")
|
|||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"132vdvh3myjgcjn6i9w90ck16ddjxjcszklzkyvr4f5ifqd7wfhg"))
|
||||
(patches (search-patches "mdadm-gcc-4.9-fix.patch"))))
|
||||
"0248v9f28mrbwabl94ck22gfim29sqhkf70wrpfi52nk4x3bxl17"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("udev" ,eudev)))
|
||||
|
|
|
@ -1,38 +0,0 @@
|
|||
From 68641cdb646eaa15099c1d6cfff1eaa5dd2ac841 Mon Sep 17 00:00:00 2001
|
||||
From: Jes Sorensen <Jes.Sorensen@redhat.com>
|
||||
Date: Tue, 24 Feb 2015 16:00:40 -0500
|
||||
Subject: [PATCH] write_super_imsm_spares(): C statements are terminated by ;
|
||||
|
||||
Signed-off-by: Jes Sorensen <Jes.Sorensen@redhat.com>
|
||||
Signed-off-by: NeilBrown <neilb@suse.de>
|
||||
---
|
||||
super-intel.c | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/super-intel.c b/super-intel.c
|
||||
index 819e0da..7f75b53 100644
|
||||
--- a/super-intel.c
|
||||
+++ b/super-intel.c
|
||||
@@ -5115,13 +5115,13 @@ static int write_super_imsm_spares(struct intel_super *super, int doclose)
|
||||
__u32 sum;
|
||||
struct dl *d;
|
||||
|
||||
- spare->mpb_size = __cpu_to_le32(sizeof(struct imsm_super)),
|
||||
- spare->generation_num = __cpu_to_le32(1UL),
|
||||
+ spare->mpb_size = __cpu_to_le32(sizeof(struct imsm_super));
|
||||
+ spare->generation_num = __cpu_to_le32(1UL);
|
||||
spare->attributes = MPB_ATTRIB_CHECKSUM_VERIFY;
|
||||
- spare->num_disks = 1,
|
||||
- spare->num_raid_devs = 0,
|
||||
- spare->cache_size = mpb->cache_size,
|
||||
- spare->pwr_cycle_count = __cpu_to_le32(1),
|
||||
+ spare->num_disks = 1;
|
||||
+ spare->num_raid_devs = 0;
|
||||
+ spare->cache_size = mpb->cache_size;
|
||||
+ spare->pwr_cycle_count = __cpu_to_le32(1);
|
||||
|
||||
snprintf((char *) spare->sig, MAX_SIGNATURE_LENGTH,
|
||||
MPB_SIGNATURE MPB_VERSION_RAID0);
|
||||
--
|
||||
2.4.3
|
||||
|
Loading…
Reference in New Issue