gnu: gcc: Fix mingw cross compiler.
* gnu/packages/patches/gcc-7-cross-mingw.patch: New file. * gnu/packages/cross-base.scm (cross-gcc-patches): Add XGCC parameter; update caller. Use it for target mingw and gcc >= 7. * gnu/local.mk (dist_patch_DATA): Add it.
This commit is contained in:
parent
fc16ef9d90
commit
308eb5c11a
|
@ -853,6 +853,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-6-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
|
%D%/packages/patches/gcc-6-source-date-epoch-1.patch \
|
||||||
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
|
%D%/packages/patches/gcc-6-source-date-epoch-2.patch \
|
||||||
|
%D%/packages/patches/gcc-7-cross-mingw.patch \
|
||||||
%D%/packages/patches/gcc-8-cross-environment-variables.patch \
|
%D%/packages/patches/gcc-8-cross-environment-variables.patch \
|
||||||
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
|
%D%/packages/patches/gcc-8-strmov-store-file-names.patch \
|
||||||
%D%/packages/patches/gcc-9-asan-fix-limits-include.patch \
|
%D%/packages/patches/gcc-9-asan-fix-limits-include.patch \
|
||||||
|
|
|
@ -1,7 +1,7 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
|
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
|
||||||
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
|
;;; Copyright © 2016, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
|
||||||
;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
;;; Copyright © 2016 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
|
||||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||||
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
|
;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
|
||||||
|
@ -190,13 +190,16 @@ base compiler and using LIBC (which may be either a libc package or #f.)"
|
||||||
'("CROSS_C_INCLUDE_PATH" "CROSS_CPLUS_INCLUDE_PATH")))
|
'("CROSS_C_INCLUDE_PATH" "CROSS_CPLUS_INCLUDE_PATH")))
|
||||||
#t))))))))))
|
#t))))))))))
|
||||||
|
|
||||||
(define (cross-gcc-patches target)
|
(define (cross-gcc-patches xgcc target)
|
||||||
"Return GCC patches needed for TARGET."
|
"Return GCC patches needed for XGCC and TARGET."
|
||||||
(cond ((string-prefix? "xtensa-" target)
|
(cond ((string-prefix? "xtensa-" target)
|
||||||
;; Patch by Qualcomm needed to build the ath9k-htc firmware.
|
;; Patch by Qualcomm needed to build the ath9k-htc firmware.
|
||||||
(search-patches "ath9k-htc-firmware-gcc.patch"))
|
(search-patches "ath9k-htc-firmware-gcc.patch"))
|
||||||
((target-mingw? target)
|
((target-mingw? target)
|
||||||
(search-patches "gcc-4.9.3-mingw-gthr-default.patch"))
|
(append (search-patches "gcc-4.9.3-mingw-gthr-default.patch")
|
||||||
|
(if (version>=? (package-version xgcc) "7.0")
|
||||||
|
(search-patches "gcc-7-cross-mingw.patch")
|
||||||
|
'())))
|
||||||
(else '())))
|
(else '())))
|
||||||
|
|
||||||
(define (cross-gcc-snippet target)
|
(define (cross-gcc-snippet target)
|
||||||
|
@ -229,7 +232,7 @@ target that libc."
|
||||||
((version>=? (package-version xgcc) "8.0") (search-patch "gcc-8-cross-environment-variables.patch"))
|
((version>=? (package-version xgcc) "8.0") (search-patch "gcc-8-cross-environment-variables.patch"))
|
||||||
((version>=? (package-version xgcc) "6.0") (search-patch "gcc-6-cross-environment-variables.patch"))
|
((version>=? (package-version xgcc) "6.0") (search-patch "gcc-6-cross-environment-variables.patch"))
|
||||||
(else (search-patch "gcc-cross-environment-variables.patch")))
|
(else (search-patch "gcc-cross-environment-variables.patch")))
|
||||||
(cross-gcc-patches target))))
|
(cross-gcc-patches xgcc target))))
|
||||||
(modules '((guix build utils)))
|
(modules '((guix build utils)))
|
||||||
(snippet
|
(snippet
|
||||||
(cross-gcc-snippet target))))
|
(cross-gcc-snippet target))))
|
||||||
|
|
|
@ -0,0 +1,24 @@
|
||||||
|
This fixes
|
||||||
|
|
||||||
|
../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc: In function ‘void* __gnu_cxx::aligned_alloc(std::size_t, std::size_t)’:
|
||||||
|
../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: error: ‘memalign’ was not declared in this scope
|
||||||
|
return memalign (al, sz);
|
||||||
|
^~~~~~~~
|
||||||
|
../../../../gcc-7.4.0/libstdc++-v3/libsupc++/new_opa.cc:78:10: note: suggested alternative: ‘max_align_t’
|
||||||
|
return memalign (al, sz);
|
||||||
|
^~~~~~~~
|
||||||
|
max_align_t
|
||||||
|
|
||||||
|
diff --git a/libstdc++-v3/libsupc++/new_opa.cc b/libstdc++-v3/libsupc++/new_opa.cc
|
||||||
|
index 94e79cadb0e..084900e0daf 100644
|
||||||
|
--- a/libstdc++-v3/libsupc++/new_opa.cc
|
||||||
|
+++ b/libstdc++-v3/libsupc++/new_opa.cc
|
||||||
|
@@ -39,6 +39,8 @@ extern "C" void *memalign(std::size_t boundary, std::size_t size);
|
||||||
|
# endif
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#define memalign _aligned_malloc
|
||||||
|
+
|
||||||
|
using std::new_handler;
|
||||||
|
using std::bad_alloc;
|
||||||
|
|
Loading…
Reference in New Issue