gnu: ffmpeg: Check via "make fate".

* gnu/packages/patches/ffmpeg-check.patch: Drop patch.
* gnu-system.am (dist_patch_DATA): Unregister patch.
* gnu/packages/video.scm (ffmpeg): Drop patch and use "fate" as test target
    as recommended at http://trac.ffmpeg.org/ticket/3177#comment:11 .
* gnu/packages/video.scm
master
Andreas Enge 2013-12-13 11:32:25 +01:00
parent a31f4d3557
commit 31f9322e6f
3 changed files with 3 additions and 21 deletions

View File

@ -230,7 +230,6 @@ dist_patch_DATA = \
gnu/packages/patches/diffutils-gets-undeclared.patch \
gnu/packages/patches/dmd-getpw.patch \
gnu/packages/patches/emacs-configure-sh.patch \
gnu/packages/patches/ffmpeg-check.patch \
gnu/packages/patches/findutils-absolute-paths.patch \
gnu/packages/patches/flac-fix-memcmp-not-declared.patch \
gnu/packages/patches/flex-bison-tests.patch \

View File

@ -1,15 +0,0 @@
See https://trac.ffmpeg.org/ticket/3177 .
diff --git a/libavcodec/cabac.c b/libavcodec/cabac.c
index 29b188b..dff0a91 100644
--- a/libavcodec/cabac.c
+++ b/libavcodec/cabac.c
@@ -301,7 +301,7 @@ STOP_TIMER("get_cabac_bypass")
for(i=0; i<SIZE; i++){
START_TIMER
- if( (r[i]&1) != get_cabac(&c, state) )
+ if( (r[i]&1) != get_cabac_noinline(&c, state) )
av_log(NULL, AV_LOG_ERROR, "CABAC failure at %d\n", i);
STOP_TIMER("get_cabac")
}

View File

@ -21,7 +21,6 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
@ -42,9 +41,7 @@
version ".tar.bz2"))
(sha256
(base32
"1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))
;; from upstream, drop with next release
(patches (list (search-patch "ffmpeg-check.patch")))))
"1qnspbpwa6cflsb6mkm84ay4nfx60ism6d7lgvnasidck9dmxydy"))))
(build-system gnu-build-system)
(inputs
`(("bc" ,bc)
@ -60,7 +57,8 @@
("yasm" ,yasm)
("zlib", zlib)))
(arguments
`(#:phases
`(#:test-target "fate"
#:phases
(alist-replace
'configure
;; configure does not work followed by "SHELL=..." and