gnu: mcrypt: Fix patches for CVE-2012-{4409,4527}.
This fixes CVE-2012-{4409,4527}.
This is a followup to commit fd1461879c
.
* gnu/packages/patches/mcrypt-CVE-2012-4409.patch,
gnu/packages/patches/mcrypt-CVE-2012-4527.patch: Apply the patches to the mcrypt
source code.
This commit is contained in:
parent
37e8a2e219
commit
324f4fc559
|
@ -3,30 +3,17 @@ From: Tom Callaway <spot@fedoraproject.org>
|
|||
Date: Fri, 7 Sep 2012 11:39:29 -0400
|
||||
Subject: apply fix for CVE-2012-4409 (thanks to Raphael Geissert)
|
||||
|
||||
---
|
||||
mcrypt-CVE-2012-4409.patch | 12 ++++++++++++
|
||||
mcrypt.spec | 10 +++++++++-
|
||||
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||
create mode 100644 mcrypt-CVE-2012-4409.patch
|
||||
|
||||
diff --git a/mcrypt-CVE-2012-4409.patch b/mcrypt-CVE-2012-4409.patch
|
||||
new file mode 100644
|
||||
index 0000000..747f428
|
||||
--- /dev/null
|
||||
+++ b/mcrypt-CVE-2012-4409.patch
|
||||
@@ -0,0 +1,12 @@
|
||||
+diff -up mcrypt-2.6.8/src/extra.c.CVE-2012-4409 mcrypt-2.6.8/src/extra.c
|
||||
+--- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400
|
||||
++++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400
|
||||
+@@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char
|
||||
+ if (m_getbit(0, sflag) != 0) { /* if the first bit is set */
|
||||
+ *salt_size = m_setbit(0, sflag, 0);
|
||||
+ if (*salt_size > 0) {
|
||||
++ if (*salt_size > sizeof(tmp_buf))
|
||||
++ err_quit(_("Salt is too long\n"));
|
||||
+ fread(tmp_buf, 1, *salt_size,
|
||||
+ fstream);
|
||||
+ memmove(salt, tmp_buf, *salt_size);
|
||||
--- mcrypt-2.6.8/src/extra.c.CVE-2012-4409 2012-09-07 11:00:55.906870746 -0400
|
||||
+++ mcrypt-2.6.8/src/extra.c 2012-09-07 11:00:27.967858365 -0400
|
||||
@@ -242,6 +242,8 @@ int check_file_head(FILE * fstream, char
|
||||
if (m_getbit(0, sflag) != 0) { /* if the first bit is set */
|
||||
*salt_size = m_setbit(0, sflag, 0);
|
||||
if (*salt_size > 0) {
|
||||
+ if (*salt_size > sizeof(tmp_buf))
|
||||
+ err_quit(_("Salt is too long\n"));
|
||||
fread(tmp_buf, 1, *salt_size,
|
||||
fstream);
|
||||
memmove(salt, tmp_buf, *salt_size);
|
||||
|
||||
--
|
||||
cgit v0.12
|
||||
|
|
|
@ -3,109 +3,97 @@ From: Tom Callaway <spot@fedoraproject.org>
|
|||
Date: Tue, 30 Oct 2012 15:39:24 -0400
|
||||
Subject: apply workaround to CVE-2012-4527
|
||||
|
||||
---
|
||||
mcrypt-CVE-2012-4527-80-width-patch | 91 +++++++++++++++++++++++++++++++++++++
|
||||
mcrypt.spec | 10 +++-
|
||||
2 files changed, 100 insertions(+), 1 deletion(-)
|
||||
create mode 100644 mcrypt-CVE-2012-4527-80-width-patch
|
||||
--- mcrypt-2.6.8.orig/src/mcrypt.c
|
||||
+++ mcrypt-2.6.8/src/mcrypt.c
|
||||
@@ -41,6 +41,8 @@
|
||||
# include <time.h>
|
||||
#endif
|
||||
|
||||
diff --git a/mcrypt-CVE-2012-4527-80-width-patch b/mcrypt-CVE-2012-4527-80-width-patch
|
||||
new file mode 100644
|
||||
index 0000000..0eb94d8
|
||||
--- /dev/null
|
||||
+++ b/mcrypt-CVE-2012-4527-80-width-patch
|
||||
@@ -0,0 +1,91 @@
|
||||
+--- mcrypt-2.6.8.orig/src/mcrypt.c
|
||||
++++ mcrypt-2.6.8/src/mcrypt.c
|
||||
+@@ -41,6 +41,8 @@
|
||||
+ # include <time.h>
|
||||
+ #endif
|
||||
+#define WIDTH 80
|
||||
+
|
||||
++#define WIDTH 80
|
||||
++
|
||||
+ static char rcsid[] =
|
||||
+ "$Id: mcrypt.c,v 1.2 2007/11/07 17:10:21 nmav Exp $";
|
||||
+
|
||||
+@@ -482,7 +484,7 @@
|
||||
+ #ifdef HAVE_STAT
|
||||
+ if (stream_flag == FALSE) {
|
||||
+ if (is_normal_file(file[i]) == FALSE) {
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("%s: %s is not a regular file. Skipping...\n"),
|
||||
+ program_name, file[i]);
|
||||
+@@ -501,7 +503,7 @@
|
||||
+ dinfile = file[i];
|
||||
+ if ((isatty(fileno((FILE *) (stdin))) == 1)
|
||||
+ && (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("%s: Encrypted data will not be read from a terminal.\n"),
|
||||
+ program_name);
|
||||
+@@ -520,7 +522,7 @@
|
||||
+ einfile = file[i];
|
||||
+ if ((isatty(fileno((FILE *) (stdout))) == 1)
|
||||
+ && (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("%s: Encrypted data will not be written to a terminal.\n"),
|
||||
+ program_name);
|
||||
+@@ -544,7 +546,7 @@
|
||||
+ strcpy(outfile, einfile);
|
||||
+ /* if file has already the .nc ignore it */
|
||||
+ if (strstr(outfile, ".nc") != NULL) {
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("%s: file %s has the .nc suffix... skipping...\n"),
|
||||
+ program_name, outfile);
|
||||
+@@ -590,10 +592,10 @@
|
||||
+
|
||||
+ if (x == 0) {
|
||||
+ if (stream_flag == FALSE) {
|
||||
+- sprintf(tmperr, _("File %s was decrypted.\n"), dinfile);
|
||||
++ snprintf(tmperr, WIDTH, _("File %s was decrypted.\n"), dinfile);
|
||||
+ err_warn(tmperr);
|
||||
+ } else {
|
||||
+- sprintf(tmperr, _("Stdin was decrypted.\n"));
|
||||
++ snprintf(tmperr, WIDTH, _("Stdin was decrypted.\n"));
|
||||
+ err_warn(tmperr);
|
||||
+ }
|
||||
+ #ifdef HAVE_STAT
|
||||
+@@ -610,7 +612,7 @@
|
||||
+
|
||||
+ } else {
|
||||
+ if (stream_flag == FALSE) {
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("File %s was NOT decrypted successfully.\n"),
|
||||
+ dinfile);
|
||||
+@@ -636,10 +638,10 @@
|
||||
+
|
||||
+ if (x == 0) {
|
||||
+ if (stream_flag == FALSE) {
|
||||
+- sprintf(tmperr, _("File %s was encrypted.\n"), einfile);
|
||||
++ snprintf(tmperr, WIDTH, _("File %s was encrypted.\n"), einfile);
|
||||
+ err_warn(tmperr);
|
||||
+ } else {
|
||||
+- sprintf(tmperr, _("Stdin was encrypted.\n"));
|
||||
++ snprintf(tmperr, WIDTH, _("Stdin was encrypted.\n"));
|
||||
+ err_warn(tmperr);
|
||||
+ }
|
||||
+ #ifdef HAVE_STAT
|
||||
+@@ -655,7 +657,7 @@
|
||||
+
|
||||
+ } else {
|
||||
+ if (stream_flag == FALSE) {
|
||||
+- sprintf(tmperr,
|
||||
++ snprintf(tmperr, WIDTH,
|
||||
+ _
|
||||
+ ("File %s was NOT encrypted successfully.\n"),
|
||||
+ einfile);
|
||||
--
|
||||
cgit v0.12
|
||||
static char rcsid[] =
|
||||
"$Id: mcrypt.c,v 1.2 2007/11/07 17:10:21 nmav Exp $";
|
||||
|
||||
@@ -482,7 +484,7 @@
|
||||
#ifdef HAVE_STAT
|
||||
if (stream_flag == FALSE) {
|
||||
if (is_normal_file(file[i]) == FALSE) {
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("%s: %s is not a regular file. Skipping...\n"),
|
||||
program_name, file[i]);
|
||||
@@ -501,7 +503,7 @@
|
||||
dinfile = file[i];
|
||||
if ((isatty(fileno((FILE *) (stdin))) == 1)
|
||||
&& (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("%s: Encrypted data will not be read from a terminal.\n"),
|
||||
program_name);
|
||||
@@ -520,7 +522,7 @@
|
||||
einfile = file[i];
|
||||
if ((isatty(fileno((FILE *) (stdout))) == 1)
|
||||
&& (stream_flag == TRUE) && (force == 0)) { /* not a tty */
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("%s: Encrypted data will not be written to a terminal.\n"),
|
||||
program_name);
|
||||
@@ -544,7 +546,7 @@
|
||||
strcpy(outfile, einfile);
|
||||
/* if file has already the .nc ignore it */
|
||||
if (strstr(outfile, ".nc") != NULL) {
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("%s: file %s has the .nc suffix... skipping...\n"),
|
||||
program_name, outfile);
|
||||
@@ -590,10 +592,10 @@
|
||||
|
||||
if (x == 0) {
|
||||
if (stream_flag == FALSE) {
|
||||
- sprintf(tmperr, _("File %s was decrypted.\n"), dinfile);
|
||||
+ snprintf(tmperr, WIDTH, _("File %s was decrypted.\n"), dinfile);
|
||||
err_warn(tmperr);
|
||||
} else {
|
||||
- sprintf(tmperr, _("Stdin was decrypted.\n"));
|
||||
+ snprintf(tmperr, WIDTH, _("Stdin was decrypted.\n"));
|
||||
err_warn(tmperr);
|
||||
}
|
||||
#ifdef HAVE_STAT
|
||||
@@ -610,7 +612,7 @@
|
||||
|
||||
} else {
|
||||
if (stream_flag == FALSE) {
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("File %s was NOT decrypted successfully.\n"),
|
||||
dinfile);
|
||||
@@ -636,10 +638,10 @@
|
||||
|
||||
if (x == 0) {
|
||||
if (stream_flag == FALSE) {
|
||||
- sprintf(tmperr, _("File %s was encrypted.\n"), einfile);
|
||||
+ snprintf(tmperr, WIDTH, _("File %s was encrypted.\n"), einfile);
|
||||
err_warn(tmperr);
|
||||
} else {
|
||||
- sprintf(tmperr, _("Stdin was encrypted.\n"));
|
||||
+ snprintf(tmperr, WIDTH, _("Stdin was encrypted.\n"));
|
||||
err_warn(tmperr);
|
||||
}
|
||||
#ifdef HAVE_STAT
|
||||
@@ -655,7 +657,7 @@
|
||||
|
||||
} else {
|
||||
if (stream_flag == FALSE) {
|
||||
- sprintf(tmperr,
|
||||
+ snprintf(tmperr, WIDTH,
|
||||
_
|
||||
("File %s was NOT encrypted successfully.\n"),
|
||||
einfile);
|
||||
-
|
||||
git v0.12
|
||||
|
||||
|
|
Loading…
Reference in New Issue