gnu: cssc: Update to 1.4.0.
* gnu/packages/version-control.scm (cssc): Update to 1.4.0. [source]: Remove unneeded patches (i.e. all of them). * gnu/packages/patches/cssc-gets-undeclared.patch: Delete file. * gnu/packages/patches/cssc-missing-include.patch: Likewise. * gnu/local.mk (dist_patch_DATA): Remove deleted patches.
This commit is contained in:
parent
bea3cf4b90
commit
32fd260076
|
@ -508,8 +508,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/crda-optional-gcrypt.patch \
|
%D%/packages/patches/crda-optional-gcrypt.patch \
|
||||||
%D%/packages/patches/crossmap-allow-system-pysam.patch \
|
%D%/packages/patches/crossmap-allow-system-pysam.patch \
|
||||||
%D%/packages/patches/csound-header-ordering.patch \
|
%D%/packages/patches/csound-header-ordering.patch \
|
||||||
%D%/packages/patches/cssc-gets-undeclared.patch \
|
|
||||||
%D%/packages/patches/cssc-missing-include.patch \
|
|
||||||
%D%/packages/patches/clucene-contribs-lib.patch \
|
%D%/packages/patches/clucene-contribs-lib.patch \
|
||||||
%D%/packages/patches/cursynth-wave-rand.patch \
|
%D%/packages/patches/cursynth-wave-rand.patch \
|
||||||
%D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch \
|
%D%/packages/patches/cyrus-sasl-CVE-2013-4122.patch \
|
||||||
|
|
|
@ -1,17 +0,0 @@
|
||||||
CSSC uses a gets in a couple of places. For security reasons, modern gnulib
|
|
||||||
does not allow this. This patch allows it again.
|
|
||||||
--- CSSC-1.3.0/gl/lib/stdio.in.h 2010-05-15 00:15:35.000000000 +0200
|
|
||||||
+++ CSSC-1.3.0/gl/lib/stdio.in.h 2014-02-03 21:27:10.000000000 +0100
|
|
||||||
@@ -135,12 +135,6 @@
|
|
||||||
"use gnulib module fflush for portable POSIX compliance");
|
|
||||||
#endif
|
|
||||||
|
|
||||||
-/* It is very rare that the developer ever has full control of stdin,
|
|
||||||
- so any use of gets warrants an unconditional warning. Assume it is
|
|
||||||
- always declared, since it is required by C89. */
|
|
||||||
-#undef gets
|
|
||||||
-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
|
|
||||||
-
|
|
||||||
#if @GNULIB_FOPEN@
|
|
||||||
# if @REPLACE_FOPEN@
|
|
||||||
# if !(defined __cplusplus && defined GNULIB_NAMESPACE)
|
|
|
@ -1,12 +0,0 @@
|
||||||
Added a missing include file (necessary for gid_t and others).
|
|
||||||
So far as I am aware, this has not been added upstream yet.
|
|
||||||
--- CSSC-1.3.0/src/file.h 2010-05-16 19:31:33.000000000 +0200
|
|
||||||
+++ CSSC-1.3.0/src/file.h 2014-02-03 21:48:30.000000000 +0100
|
|
||||||
@@ -30,6 +30,7 @@
|
|
||||||
#ifndef CSSC__FILE_H__
|
|
||||||
#define CSSC__FILE_H__
|
|
||||||
|
|
||||||
+#include <sys/types.h>
|
|
||||||
#include "filelock.h"
|
|
||||||
|
|
||||||
enum create_mode {
|
|
|
@ -889,16 +889,14 @@ large, complex patch files.")
|
||||||
(define-public cssc
|
(define-public cssc
|
||||||
(package
|
(package
|
||||||
(name "cssc")
|
(name "cssc")
|
||||||
(version "1.3.0")
|
(version "1.4.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/" name "/CSSC-"
|
(uri (string-append "mirror://gnu/" name "/CSSC-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0bkw6fjh20ppvn54smv05461lm1vcwvn02avx941c4acafmkl1cm"))
|
"15191dh8hr46cvssmv4v52gymiiyk6ca9j1bfimlqakcqab6y51h"))))
|
||||||
(patches (search-patches "cssc-gets-undeclared.patch"
|
|
||||||
"cssc-missing-include.patch"))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
|
|
Loading…
Reference in New Issue