gnu: sssd: Fix build with cURL >= 7.62.0.

* gnu/packages/patches/sssd-curl-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/sssd.scm (sssd)[source](patches): Use it.
master
Marius Bakke 2018-12-26 12:25:29 +01:00
parent 215a51e441
commit 33eb63da64
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 20 additions and 0 deletions

View File

@ -1156,6 +1156,7 @@ dist_patch_DATA = \
%D%/packages/patches/soundconverter-remove-gconf-dependency.patch \
%D%/packages/patches/soundtouch-CVE-2018-14044-14045.patch \
%D%/packages/patches/soundtouch-CVE-2018-1000223.patch \
%D%/packages/patches/sssd-curl-compat.patch \
%D%/packages/patches/steghide-fixes.patch \
%D%/packages/patches/superlu-dist-scotchmetis.patch \
%D%/packages/patches/swig-guile-gc.patch \

View File

@ -0,0 +1,18 @@
Fix build with curl >= 7.62. Patch taken from upstream:
https://pagure.io/SSSD/sssd/c/4d3841ca379afc01184453ba45ab3e75ffec60da?branch=sssd-1-16
diff --git a/src/util/tev_curl.c b/src/util/tev_curl.c
index 6a7a580..d70a429 100644
--- a/src/util/tev_curl.c
+++ b/src/util/tev_curl.c
@@ -97,7 +97,9 @@ static errno_t curl_code2errno(CURLcode crv)
return ETIMEDOUT;
case CURLE_SSL_ISSUER_ERROR:
case CURLE_SSL_CACERT_BADFILE:
+#if LIBCURL_VERSION_NUM < 0x073e00
case CURLE_SSL_CACERT:
+#endif
case CURLE_SSL_CERTPROBLEM:
return ERR_INVALID_CERT;

View File

@ -86,6 +86,7 @@ fundamental object types for C.")
(method url-fetch)
(uri (string-append "http://releases.pagure.org/SSSD/sssd/"
"sssd-" version ".tar.gz"))
(patches (search-patches "sssd-curl-compat.patch"))
(sha256
(base32
"032ppk57qs1lnvz7pb7lw9ldwm9i1yagh9fzgqgn6na3bg61ynzy"))))