gnu: libtorrent-rasterbar: Update to 1.1.4.
* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.1.4. [source]: Remove 'libtorrent-rasterbar-boost-compat.patch'. * gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
d2bdee8a69
commit
3519f2841d
|
@ -835,7 +835,6 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/libtiff-tiffycbcrtorgb-integer-overflow.patch \
|
%D%/packages/patches/libtiff-tiffycbcrtorgb-integer-overflow.patch \
|
||||||
%D%/packages/patches/libtiff-tiffycbcrtorgbinit-integer-overflow.patch \
|
%D%/packages/patches/libtiff-tiffycbcrtorgbinit-integer-overflow.patch \
|
||||||
%D%/packages/patches/libtirpc-CVE-2017-8779.patch \
|
%D%/packages/patches/libtirpc-CVE-2017-8779.patch \
|
||||||
%D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
|
|
||||||
%D%/packages/patches/libtool-skip-tests2.patch \
|
%D%/packages/patches/libtool-skip-tests2.patch \
|
||||||
%D%/packages/patches/libunistring-gnulib-multi-core.patch \
|
%D%/packages/patches/libunistring-gnulib-multi-core.patch \
|
||||||
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
%D%/packages/patches/libusb-0.1-disable-tests.patch \
|
||||||
|
|
|
@ -382,7 +382,7 @@ and will take advantage of multiple processor cores where possible.")
|
||||||
(define-public libtorrent-rasterbar
|
(define-public libtorrent-rasterbar
|
||||||
(package
|
(package
|
||||||
(name "libtorrent-rasterbar")
|
(name "libtorrent-rasterbar")
|
||||||
(version "1.1.2")
|
(version "1.1.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri
|
(uri
|
||||||
|
@ -390,11 +390,9 @@ and will take advantage of multiple processor cores where possible.")
|
||||||
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
|
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
|
||||||
(string-join (string-split version #\.) "_")
|
(string-join (string-split version #\.) "_")
|
||||||
"/libtorrent-rasterbar-" version ".tar.gz"))
|
"/libtorrent-rasterbar-" version ".tar.gz"))
|
||||||
(patches
|
|
||||||
(search-patches "libtorrent-rasterbar-boost-compat.patch"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"16im9qsmfrmmkhfjpij9739nqpn4s6wgc9cikdxbcyshfhimzra5"))))
|
"19pb9sn71m4gnnrm3f1kxic63km9s3vx2mj7rznzfv9sh1kj7x6c"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:configure-flags
|
`(#:configure-flags
|
||||||
|
|
|
@ -1,27 +0,0 @@
|
||||||
Fix compatibility with Boost 1.63.
|
|
||||||
|
|
||||||
Patch copied from upstream source repository:
|
|
||||||
|
|
||||||
https://github.com/arvidn/libtorrent/commit/6d2d736cecce0af274dd651dd1f562716b625d92
|
|
||||||
|
|
||||||
From 6d2d736cecce0af274dd651dd1f562716b625d92 Mon Sep 17 00:00:00 2001
|
|
||||||
From: arvidn <arvid@cs.umu.se>
|
|
||||||
Date: Sun, 12 Mar 2017 13:03:26 -0400
|
|
||||||
Subject: [PATCH] fix test_ssl.cpp build with newer versions of boost
|
|
||||||
|
|
||||||
---
|
|
||||||
test/test_ssl.cpp | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
|
|
||||||
index 01c5bc7..2903332 100644
|
|
||||||
--- a/test/test_ssl.cpp
|
|
||||||
+++ b/test/test_ssl.cpp
|
|
||||||
@@ -51,7 +51,6 @@ POSSIBILITY OF SUCH DAMAGE.
|
|
||||||
#include <boost/asio/connect.hpp>
|
|
||||||
|
|
||||||
#ifdef TORRENT_USE_OPENSSL
|
|
||||||
-#include <boost/asio/ssl/error.hpp> // for asio::error::get_ssl_category()
|
|
||||||
#include <boost/asio/ssl.hpp>
|
|
||||||
|
|
||||||
#include "libtorrent/aux_/disable_warnings_pop.hpp"
|
|
Loading…
Reference in New Issue