gnu: ceph: Disable SSE3 instructions.
Some early 64-bit AMD processors do not support this instruction set. * gnu/packages/patches/ceph-disable-cpu-optimizations.patch: Disable SSE3.
This commit is contained in:
parent
daaec43120
commit
358b10b22b
|
@ -1,12 +1,13 @@
|
|||
Disable CPU optimizations not supported by the vast majority of
|
||||
x86_64 systems. Also don't add anything for i686.
|
||||
Disable CPU optimizations not supported by all x86_64 systems. Also
|
||||
don't add anything for i686.
|
||||
|
||||
--- a/cmake/modules/SIMDExt.cmake 2017-03-23 22:22:58.254071694 +0100
|
||||
+++ b/cmake/modules/SIMDExt.cmake 2017-03-23 22:23:22.446848845 +0100
|
||||
@@ -6,10 +6,6 @@
|
||||
@@ -5,11 +5,6 @@
|
||||
# HAVE_ARM_NEON
|
||||
# HAVE_INTEL_SSE
|
||||
# HAVE_INTEL_SSE2
|
||||
# HAVE_INTEL_SSE3
|
||||
-# HAVE_INTEL_SSE3
|
||||
-# HAVE_INTEL_SSSE3
|
||||
-# HAVE_INTEL_PCLMUL
|
||||
-# HAVE_INTEL_SSE4_1
|
||||
|
@ -14,7 +15,7 @@ x86_64 systems. Also don't add anything for i686.
|
|||
#
|
||||
# SIMD_COMPILE_FLAGS
|
||||
#
|
||||
@@ -56,7 +53,7 @@
|
||||
@@ -56,7 +51,7 @@
|
||||
if(HAVE_ARM_NEON)
|
||||
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
|
||||
endif()
|
||||
|
@ -23,10 +24,14 @@ x86_64 systems. Also don't add anything for i686.
|
|||
set(HAVE_INTEL 1)
|
||||
CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
|
||||
if(HAVE_INTEL_SSE)
|
||||
@@ -70,20 +67,4 @@
|
||||
if(HAVE_INTEL_SSE3)
|
||||
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse3")
|
||||
@@ -66,24 +61,4 @@
|
||||
if(HAVE_INTEL_SSE2)
|
||||
set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse2")
|
||||
endif()
|
||||
- CHECK_C_COMPILER_FLAG(-msse3 HAVE_INTEL_SSE3)
|
||||
- if(HAVE_INTEL_SSE3)
|
||||
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse3")
|
||||
- endif()
|
||||
- CHECK_C_COMPILER_FLAG(-mssse3 HAVE_INTEL_SSSE3)
|
||||
- if(HAVE_INTEL_SSSE3)
|
||||
- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mssse3")
|
||||
|
|
Loading…
Reference in New Issue