gnu: jbig2dec: Update to 0.13.
* gnu/packages/image.scm (jbig2dec): Update to 0.13. [source]: Update URL. [home-page]: Update URL. * gnu/packages/patches/jbig2dec-ignore-testtest.patch: Adjust patch.
This commit is contained in:
parent
cbe2cc02fb
commit
35eade9cf3
|
@ -351,15 +351,14 @@ arithmetic ops.")
|
||||||
(define-public jbig2dec
|
(define-public jbig2dec
|
||||||
(package
|
(package
|
||||||
(name "jbig2dec")
|
(name "jbig2dec")
|
||||||
(version "0.11")
|
(version "0.13")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri ;; The link on the homepage is dead.
|
(uri (string-append "http://downloads.ghostscript.com/public/" name "/"
|
||||||
(string-append "http://distfiles.gentoo.org/distfiles/" name "-"
|
name "-" version ".tar.gz"))
|
||||||
version ".tar.gz"))
|
|
||||||
(sha256
|
(sha256
|
||||||
(base32 "1ffhgmf2fqzk0h4k736pp06z7q5y4x41fg844bd6a9vgncq86bby"))
|
(base32 "04akiwab8iy5iy34razcvh9mcja9wy737civ3sbjxk4j143s1b2s"))
|
||||||
(patches (search-patches "jbig2dec-ignore-testtest.patch"))))
|
(patches (search-patches "jbig2dec-ignore-testtest.patch"))))
|
||||||
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
|
@ -374,7 +373,7 @@ This is a decoder only implementation, and currently is in the alpha
|
||||||
stage, meaning it doesn't completely work yet. However, it is
|
stage, meaning it doesn't completely work yet. However, it is
|
||||||
maintaining parity with available encoders, so it is useful for real
|
maintaining parity with available encoders, so it is useful for real
|
||||||
work.")
|
work.")
|
||||||
(home-page "http://jbig2dec.sourceforge.net/")
|
(home-page "http://www.ghostscript.com/jbig2dec.html")
|
||||||
(license license:gpl2+)))
|
(license license:gpl2+)))
|
||||||
|
|
||||||
(define-public openjpeg
|
(define-public openjpeg
|
||||||
|
|
|
@ -1,14 +1,16 @@
|
||||||
Do not run the "testtest script", it doesn't seem to do anything and reports
|
Do not run the "testtest script", it doesn't seem to do anything and reports
|
||||||
failiute. TODO: Actually fix the test instead of ignoring it.
|
failiute. TODO: Actually fix the test instead of ignoring it.
|
||||||
|
|
||||||
--- a/Makefile.in 2010-02-02 20:13:56.000000000 +0100
|
diff --git a/Makefile.in b/Makefile.in
|
||||||
+++ b/Makefile.in 2014-09-13 17:50:10.957816767 +0200
|
index 0573592..1a5de77 100644
|
||||||
@@ -181,7 +181,7 @@
|
--- a/Makefile.in
|
||||||
|
+++ b/Makefile.in
|
||||||
MAINTAINERCLEANFILES = config_types.h.in
|
@@ -93,7 +93,7 @@ host_triplet = @host@
|
||||||
|
bin_PROGRAMS = jbig2dec$(EXEEXT)
|
||||||
-TESTS = test_sha1 test_jbig2dec.py test_huffman test_arith
|
noinst_PROGRAMS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
|
||||||
+TESTS = test_sha1 test_huffman test_arith
|
test_arith$(EXEEXT)
|
||||||
|
-TESTS = test_sha1$(EXEEXT) test_jbig2dec.py test_huffman$(EXEEXT) \
|
||||||
test_sha1_SOURCES = sha1.c sha1.h
|
+TESTS = test_sha1$(EXEEXT) test_huffman$(EXEEXT) \
|
||||||
test_sha1_CFLAGS = -DTEST
|
test_arith$(EXEEXT)
|
||||||
|
subdir = .
|
||||||
|
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
|
||||||
|
|
Loading…
Reference in New Issue