gnu: ceph: Update to 12.2.5.

* gnu/packages/patches/ceph-skip-collect-sys-info-test.patch: Adjust.
* gnu/packages/storage.scm (ceph): Update to 12.2.5.
master
Marius Bakke 2018-04-25 12:26:25 +02:00
parent 8bf8dedc9a
commit 3743e1320e
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 5 additions and 10 deletions

View File

@ -1,14 +1,13 @@
This test fails because /etc/os-release is not available.
diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
index 288dd37db1..95b6cd4b30 100644
index 64eace923c..6daf4aa514 100644
--- a/src/test/common/test_util.cc
+++ b/src/test/common/test_util.cc
@@ -31,19 +31,3 @@ TEST(util, unit_to_bytesize)
@@ -32,17 +32,3 @@ TEST(util, unit_to_bytesize)
ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
}
-
-#if defined(__linux__)
-TEST(util, collect_sys_info)
-{
@ -18,12 +17,8 @@ index 288dd37db1..95b6cd4b30 100644
- collect_sys_info(&sys_info, cct);
-
- ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
- ASSERT_TRUE(sys_info.find("distro_version") != sys_info.end());
- ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
-
- cct->put();
-}
-#endif
--
2.11.1

View File

@ -52,14 +52,14 @@
(define-public ceph
(package
(name "ceph")
(version "12.2.4")
(version "12.2.5")
(source (origin
(method url-fetch)
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
version ".tar.gz"))
(sha256
(base32
"13hv8scaxc1gdvrhzbfnsk4yy3pla6n1i4j4j4zf7schmbf0j8mp"))
"1ydc3mfvc0vpnpfnfmissvsrsj4jyxgzc2pcl1a4vdr3bwkcglp3"))
(patches
(search-patches "ceph-skip-unittest_blockdev.patch"
"ceph-skip-collect-sys-info-test.patch"