gnu: ceph: Update to 12.2.5.
* gnu/packages/patches/ceph-skip-collect-sys-info-test.patch: Adjust. * gnu/packages/storage.scm (ceph): Update to 12.2.5.
This commit is contained in:
parent
8bf8dedc9a
commit
3743e1320e
|
@ -1,14 +1,13 @@
|
||||||
This test fails because /etc/os-release is not available.
|
This test fails because /etc/os-release is not available.
|
||||||
|
|
||||||
diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
|
diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
|
||||||
index 288dd37db1..95b6cd4b30 100644
|
index 64eace923c..6daf4aa514 100644
|
||||||
--- a/src/test/common/test_util.cc
|
--- a/src/test/common/test_util.cc
|
||||||
+++ b/src/test/common/test_util.cc
|
+++ b/src/test/common/test_util.cc
|
||||||
@@ -31,19 +31,3 @@ TEST(util, unit_to_bytesize)
|
@@ -32,17 +32,3 @@ TEST(util, unit_to_bytesize)
|
||||||
|
|
||||||
ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
|
ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
|
||||||
}
|
}
|
||||||
-
|
|
||||||
-#if defined(__linux__)
|
-#if defined(__linux__)
|
||||||
-TEST(util, collect_sys_info)
|
-TEST(util, collect_sys_info)
|
||||||
-{
|
-{
|
||||||
|
@ -18,12 +17,8 @@ index 288dd37db1..95b6cd4b30 100644
|
||||||
- collect_sys_info(&sys_info, cct);
|
- collect_sys_info(&sys_info, cct);
|
||||||
-
|
-
|
||||||
- ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
|
- ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
|
||||||
- ASSERT_TRUE(sys_info.find("distro_version") != sys_info.end());
|
|
||||||
- ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
|
- ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
|
||||||
-
|
-
|
||||||
- cct->put();
|
- cct->put();
|
||||||
-}
|
-}
|
||||||
-#endif
|
-#endif
|
||||||
--
|
|
||||||
2.11.1
|
|
||||||
|
|
||||||
|
|
|
@ -52,14 +52,14 @@
|
||||||
(define-public ceph
|
(define-public ceph
|
||||||
(package
|
(package
|
||||||
(name "ceph")
|
(name "ceph")
|
||||||
(version "12.2.4")
|
(version "12.2.5")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
|
(uri (string-append "https://download.ceph.com/tarballs/ceph-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"13hv8scaxc1gdvrhzbfnsk4yy3pla6n1i4j4j4zf7schmbf0j8mp"))
|
"1ydc3mfvc0vpnpfnfmissvsrsj4jyxgzc2pcl1a4vdr3bwkcglp3"))
|
||||||
(patches
|
(patches
|
||||||
(search-patches "ceph-skip-unittest_blockdev.patch"
|
(search-patches "ceph-skip-unittest_blockdev.patch"
|
||||||
"ceph-skip-collect-sys-info-test.patch"
|
"ceph-skip-collect-sys-info-test.patch"
|
||||||
|
|
Loading…
Reference in New Issue