handbrake: Update to 1.1.2.

* gnu/packages/video.scm (handbrake): Update to 1.1.2.
[source]: Use direct download url.  Remove upstreamed patch.  Patch make
fragments in snippet.
[inputs]: Use latest ffmpeg.  Add jansson and opus.
[arguments]: Remove 'disable-contrib phase, which is now in source snippet.
Move 'fix-x265-linking phase fix to #:configure-flags.
[license]: Use 'gpl2' as clarified in LICENSE.
* gnu/packages/patches/handbrake-pkg-config-path.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Eric Bavier 2018-12-01 09:36:43 -06:00
parent b5944fcbc3
commit 37b82ccc39
No known key found for this signature in database
GPG Key ID: FD73CAC719D32566
3 changed files with 25 additions and 52 deletions

View File

@ -799,7 +799,6 @@ dist_patch_DATA = \
%D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \ %D%/packages/patches/gtk3-respect-GUIX_GTK3_IM_MODULE_FILE.patch \
%D%/packages/patches/gtkglext-disable-disable-deprecated.patch \ %D%/packages/patches/gtkglext-disable-disable-deprecated.patch \
%D%/packages/patches/gzdoom-search-in-installed-share.patch \ %D%/packages/patches/gzdoom-search-in-installed-share.patch \
%D%/packages/patches/handbrake-pkg-config-path.patch \
%D%/packages/patches/haskell-mode-unused-variables.patch \ %D%/packages/patches/haskell-mode-unused-variables.patch \
%D%/packages/patches/haskell-mode-make-check.patch \ %D%/packages/patches/haskell-mode-make-check.patch \
%D%/packages/patches/hdf4-architectures.patch \ %D%/packages/patches/hdf4-architectures.patch \

View File

@ -1,24 +0,0 @@
Do not clobber PKG_CONFIG_PATH during configure.
--- HandBrake-0.10.5/gtk/module.rules.orig 2016-02-11 14:14:05.000000000 -0600
+++ HandBrake-0.10.5/gtk/module.rules 2016-10-29 22:27:50.550960848 -0500
@@ -15,7 +15,7 @@
set -e; cd $(GTK.src/); NOCONFIGURE=1 ./autogen.sh
set -e; cd $(GTK.build/); $(call fn.ABSOLUTE,$(GTK.src/))configure \
$(GTK.CONFIGURE.extra) \
- PKG_CONFIG_PATH=$(BUILD/)contrib/lib/pkgconfig \
+ PKG_CONFIG_PATH=$(BUILD/)contrib/lib/pkgconfig$(if $(PKG_CONFIG_PATH),:)$(PKG_CONFIG_PATH) \
CFLAGS="$(call fn.ARGS,GTK.GCC,.g .O *D ?extra)" \
LDFLAGS="$(call fn.ARGS,GTK.GCC,?strip .g .O ?extra.exe)" \
--prefix=$(PREFIX) \
--- Handbrake-0.10.5-0.77d09e9-checkout/make/include/contrib.defs 1969-12-31 18:00:00.000000000 -0600
+++ Handbrake-0.10.5-0.77d09e9-checkout/make/include/contrib.defs 2016-11-01 13:11:43.826144311 -0500
@@ -119,7 +119,7 @@
endif
$(1).CONFIGURE.env.CPPFLAGS = CPPFLAGS="-I$$(call fn.ABSOLUTE,$(CONTRIB.build/))include $$(call fn.ARGS,$(1).GCC,*archs *sysroot *minver ?extra *D)"
$(1).CONFIGURE.env.LDFLAGS = LDFLAGS="-L$$(call fn.ABSOLUTE,$(CONTRIB.build/))lib $$(call fn.ARGS,$(1).GCC,*archs *sysroot *minver ?extra.exe *D)"
- $(1).CONFIGURE.env.PKG_CONFIG_PATH = PKG_CONFIG_PATH="$$(call fn.ABSOLUTE,$$(CONTRIB.build/))lib/pkgconfig"
+ $(1).CONFIGURE.env.PKG_CONFIG_PATH = PKG_CONFIG_PATH="$$(call fn.ABSOLUTE,$$(CONTRIB.build/))lib/pkgconfig$(if $(PKG_CONFIG_PATH),:)$(PKG_CONFIG_PATH)"
$(1).CONFIGURE.env.args = !CC !CFLAGS !CXX !CXXFLAGS !CPPFLAGS !LD !LDFLAGS !PKG_CONFIG_PATH !LOCAL_PATH !CROSS
$(1).CONFIGURE.env = $$(call fn.ARGS,$(1).CONFIGURE.env,$$($(1).CONFIGURE.env.args))

View File

@ -2426,22 +2426,27 @@ supported players in addition to this package.")
(define-public handbrake (define-public handbrake
(package (package
(name "handbrake") (name "handbrake")
(version "0.10.5") (version "1.1.2")
(source (origin (source (origin
(method url-fetch) (method url-fetch)
(uri (string-append "https://handbrake.fr/rotation.php?file=" (uri (string-append "https://download.handbrake.fr/releases/"
"HandBrake-" version ".tar.bz2")) version "/HandBrake-" version "-source.tar.bz2"))
(file-name (string-append "handbrake-" version ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"1w720y3bplkz187wgvy4a4xm0vpppg45mlni55l6yi8v2bfk14pv")) "0bny0hwlr55g2c69rsamv0xvwmfh1s4a582b9vq20xv5ly84m6ms"))
(patches (search-patches "handbrake-pkg-config-path.patch"))
(modules '((guix build utils))) (modules '((guix build utils)))
(snippet (snippet
;; Remove bundled libraries and source not necessary for ;; Remove "contrib" and source not necessary for
;; running under a GNU environment. ;; building/running under a GNU environment.
'(begin '(begin
(for-each delete-file-recursively '("contrib" "macosx" "win")) (for-each delete-file-recursively
'("contrib" "macosx" "win"))
(substitute* "make/include/main.defs"
;; Disable unconditional inclusion of "contrib" libraries
;; (ffmpeg, libvpx, libdvdread, libdvdnav, and libbluray),
;; which would lead to fetching and building of these
;; libraries. Use our own instead.
(("MODULES \\+= contrib") "# MODULES += contrib"))
#t)))) #t))))
(build-system glib-or-gtk-build-system) (build-system glib-or-gtk-build-system)
(native-inputs (native-inputs
@ -2455,13 +2460,14 @@ supported players in addition to this package.")
(inputs (inputs
`(("bzip2" ,bzip2) `(("bzip2" ,bzip2)
("dbus-glib" ,dbus-glib) ("dbus-glib" ,dbus-glib)
("ffmpeg" ,ffmpeg-3.4) ;compilation errors with ffmpeg-4 ("ffmpeg" ,ffmpeg)
("fontconfig" ,fontconfig) ("fontconfig" ,fontconfig)
("freetype" ,freetype) ("freetype" ,freetype)
("glib" ,glib) ("glib" ,glib)
("gstreamer" ,gstreamer) ("gstreamer" ,gstreamer)
("gst-plugins-base" ,gst-plugins-base) ("gst-plugins-base" ,gst-plugins-base)
("gtk+" ,gtk+) ("gtk+" ,gtk+)
("jansson" ,jansson)
("lame" ,lame) ("lame" ,lame)
("libass" ,libass) ("libass" ,libass)
("libbluray" ,libbluray) ("libbluray" ,libbluray)
@ -2471,6 +2477,7 @@ supported players in addition to this package.")
("libmpeg2" ,libmpeg2) ("libmpeg2" ,libmpeg2)
("libnotify" ,libnotify) ("libnotify" ,libnotify)
("libogg" ,libogg) ("libogg" ,libogg)
("libopus" ,opus)
("libsamplerate" ,libsamplerate) ("libsamplerate" ,libsamplerate)
("libtheora" ,libtheora) ("libtheora" ,libtheora)
("libvorbis" ,libvorbis) ("libvorbis" ,libvorbis)
@ -2481,6 +2488,11 @@ supported players in addition to this package.")
("zlib" ,zlib))) ("zlib" ,zlib)))
(arguments (arguments
`(#:tests? #f ;tests require Ruby and claim to be unsupported `(#:tests? #f ;tests require Ruby and claim to be unsupported
#:configure-flags
(list (string-append "CPPFLAGS=-I"
(assoc-ref %build-inputs "libxml2")
"/include/libxml2")
"LDFLAGS=-lx265")
#:phases #:phases
(modify-phases %standard-phases (modify-phases %standard-phases
(replace 'bootstrap (replace 'bootstrap
@ -2492,21 +2504,6 @@ supported players in addition to this package.")
(substitute* "gtk/module.rules" (substitute* "gtk/module.rules"
((".*autogen\\.sh.*") "")) ((".*autogen\\.sh.*") ""))
(invoke "sh" "./gtk/autogen.sh"))) (invoke "sh" "./gtk/autogen.sh")))
(add-before 'configure 'disable-contrib
(lambda _
(substitute* "make/include/main.defs"
;; Disable unconditional inclusion of some "contrib"
;; libraries (ffmpeg, libvpx, libdvdread, libdvdnav,
;; and libbluray), which would lead to fetching and
;; building of these libraries. Use our own instead.
(("MODULES \\+= contrib") "# MODULES += contrib"))
#t))
(add-before 'configure 'fix-x265-linking
(lambda _
(substitute* "test/module.defs"
;; Fix missing library during linking error
(("TEST.GCC.l =") "TEST.GCC.l = x265"))
#t))
(replace 'configure (replace 'configure
(lambda* (#:key outputs configure-flags #:allow-other-keys) (lambda* (#:key outputs configure-flags #:allow-other-keys)
;; 'configure' is not an autoconf-generated script, and ;; 'configure' is not an autoconf-generated script, and
@ -2523,8 +2520,9 @@ supported players in addition to this package.")
(description (description
"HandBrake is a tool for converting video from any format to a selection "HandBrake is a tool for converting video from any format to a selection
of modern, widely supported codecs.") of modern, widely supported codecs.")
;; Most under GPL version 2 or later, and portions under BSD 3 Clause ;; Some under GPLv2+, some under LGPLv2.1+, and portions under BSD3.
(license (list license:gpl2+ license:bsd-3)))) ;; Combination under GPLv2. See LICENSE.
(license license:gpl2)))
(define-public openh264 (define-public openh264
(package (package