gnu: bcftools: Fix building on aarch64.

* gnu/packages/patches/bcftools-regidx-unsigned-char.patch: New file.
* gnu/packages/bioinformatics.scm (bcftools)[source]: Use it.
* gnu/local.mk (dist_patch_DATA): Register it.
master
Efraim Flashner 2017-08-15 10:30:33 +03:00
parent 2d430f2923
commit 3837108e40
No known key found for this signature in database
GPG Key ID: 41AAE7DCCA3D8351
3 changed files with 18 additions and 0 deletions

View File

@ -527,6 +527,7 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-completion-directories.patch \
%D%/packages/patches/bcftools-regidx-unsigned-char.patch \
%D%/packages/patches/binutils-ld-new-dtags.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/binutils-mips-bash-bug.patch \

View File

@ -311,6 +311,7 @@ BAM files.")
(sha256
(base32
"0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
(patches (search-patches "bcftools-regidx-unsigned-char.patch"))
(modules '((guix build utils)))
(snippet
;; Delete bundled htslib.

View File

@ -0,0 +1,16 @@
Description: Fix test-regidx argument parsing on archs with unsigned char
On architectures where char is unsigned "c >= 0" was always true.
Author: Adrian Bunk <bunk@debian.org>
Bug-Debian: https://bugs.debian.org/865060
--- a/test/test-regidx.c
+++ b/test/test-regidx.c
@@ -336,7 +336,7 @@
{"seed",1,0,'s'},
{0,0,0,0}
};
- char c;
+ int c;
int seed = (int)time(NULL);
while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
{