gnu: ruby-puma: Update to 3.6.0.
* gnu/packages/ruby.scm (ruby-puma): Update to 3.6.0. [arguments]: Add 'delete-integration-tests' phase. (gnu/packages/patches/ruby-puma-ignore-broken-test.patch): Remove only one broken test.
This commit is contained in:
parent
10fa1d98e1
commit
3840373b39
|
@ -1,13 +1,13 @@
|
||||||
diff --git a/test/test_integration.rb b/test/test_integration.rb
|
diff --git a/test/test_cli.rb b/test/test_cli.rb
|
||||||
index d9b189c..6e21180 100644
|
index 9c515c6..6bd439f 100644
|
||||||
--- a/test/test_integration.rb
|
--- a/test/test_cli.rb
|
||||||
+++ b/test/test_integration.rb
|
+++ b/test/test_cli.rb
|
||||||
@@ -115,7 +115,7 @@ class TestIntegration < Test::Unit::TestCase
|
@@ -88,7 +88,7 @@ class TestCLI < Test::Unit::TestCase
|
||||||
assert_kind_of Thread, t.join(1), "server didn't stop"
|
s << "GET /stats HTTP/1.0\r\n\r\n"
|
||||||
end
|
body = s.read
|
||||||
|
|
||||||
- def test_phased_restart_via_pumactl
|
- assert_match(/\{ "workers": 2, "phase": 0, "booted_workers": 0, "old_workers": 0, "worker_status": \[\{ "pid": \d+, "index": 0, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \},\{ "pid": \d+, "index": 1, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \}\] \}/, body.split("\r\n").last)
|
||||||
+ def no_test_phased_restart_via_pumactl
|
+ #assert_match(/\{ "workers": 2, "phase": 0, "booted_workers": 0, "old_workers": 0, "worker_status": \[\{ "pid": \d+, "index": 0, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \},\{ "pid": \d+, "index": 1, "phase": 0, "booted": false, "last_checkin": "[^"]+", "last_status": \{\} \}\] \}/, body.split("\r\n").last)
|
||||||
if Puma.jruby? || Puma.windows?
|
|
||||||
assert true
|
# wait until the first status ping has come through
|
||||||
return
|
sleep 6
|
||||||
|
|
|
@ -3953,7 +3953,7 @@ part of the Prawn PDF generator.")
|
||||||
(define-public ruby-puma
|
(define-public ruby-puma
|
||||||
(package
|
(package
|
||||||
(name "ruby-puma")
|
(name "ruby-puma")
|
||||||
(version "3.4.0")
|
(version "3.6.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -3963,14 +3963,22 @@ part of the Prawn PDF generator.")
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(file-name (string-append name "-" version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"10svyj2jk949y1dmkxyzipk1ddzl4iz9limrcws1zhpganpvq3j8"))
|
"08aws79n9slcr50d9lwm011cp1pxvr1409c2jmyjxywvrc0a30v1"))
|
||||||
;; Ignore broken test reported upstream.
|
;; Ignore broken tests reported upstream.
|
||||||
;; https://github.com/puma/puma/issues/995
|
;; https://github.com/puma/puma/issues/995
|
||||||
|
;; https://github.com/puma/puma/issues/1044
|
||||||
(patches (search-patches "ruby-puma-ignore-broken-test.patch"))))
|
(patches (search-patches "ruby-puma-ignore-broken-test.patch"))))
|
||||||
(build-system ruby-build-system)
|
(build-system ruby-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
`(#:phases
|
`(#:phases
|
||||||
(modify-phases %standard-phases
|
(modify-phases %standard-phases
|
||||||
|
(add-after 'unpack 'delete-integration-tests
|
||||||
|
(lambda _
|
||||||
|
;; One broken test in this file cannot be easily removed in
|
||||||
|
;; isolation, it probably causes race conditions. So we delete
|
||||||
|
;; the entire file.
|
||||||
|
(delete-file "test/test_integration.rb")
|
||||||
|
#t))
|
||||||
(add-before 'build 'fix-gemspec
|
(add-before 'build 'fix-gemspec
|
||||||
(lambda _
|
(lambda _
|
||||||
(substitute* "puma.gemspec"
|
(substitute* "puma.gemspec"
|
||||||
|
|
Loading…
Reference in New Issue