gnu: emacs: Update to 24.4.

* gnu/packages/patches/emacs-configure-sh.patch: Remove.
* gnu-system.am (dist_patch_DATA): Remove it.
* gnu/packages/emacs.scm (emacs): Update to 24.4.  Add 'acl' as input.
  Remove --with-crt-dir configure option.
  (emacs-no-x-toolkit): Add 'inotify-tools' as input.  Adjust to cope
  with the lack of configure-flags in the main 'emacs' package.
master
Mark H Weaver 2014-10-08 03:49:43 -04:00
parent 05b4226ad9
commit 388fd01b02
3 changed files with 9 additions and 26 deletions

View File

@ -327,7 +327,6 @@ dist_patch_DATA = \
gnu/packages/patches/doxygen-tmake.patch \
gnu/packages/patches/duplicity-piped-password.patch \
gnu/packages/patches/duplicity-test_selection-tmp.patch \
gnu/packages/patches/emacs-configure-sh.patch \
gnu/packages/patches/eudev-rules-directory.patch \
gnu/packages/patches/file-CVE-2014-3587.patch \
gnu/packages/patches/findutils-absolute-paths.patch \

View File

@ -43,27 +43,24 @@
#:use-module ((gnu packages compression) #:prefix compression:)
#:use-module (gnu packages xml)
#:use-module (gnu packages glib)
#:use-module (gnu packages acl)
#:use-module (guix utils)
#:use-module (srfi srfi-1))
(define-public emacs
(package
(name "emacs")
(version "24.3")
(version "24.4")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/emacs/emacs-"
version ".tar.xz"))
(sha256
(base32
"1385qzs3bsa52s5rcncbrkxlydkw0ajzrvfxgv8rws5fx512kakh"))
(patches (list (search-patch "emacs-configure-sh.patch")))))
"1zflm6ac34s6v166p58ilxrxbxjm0q2wfc25f8y0mjml1lbr3qs7"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
(list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
"/lib"))
#:phases (alist-cons-before
'(#:phases (alist-cons-before
'configure 'fix-/bin/pwd
(lambda _
;; Use `pwd', not `/bin/pwd'.
@ -82,6 +79,7 @@
("libtiff" ,libtiff)
("giflib" ,giflib)
("libjpeg" ,libjpeg-8)
("acl" ,acl)
;; When looking for libpng `configure' links with `-lpng -lz', so we
;; must also provide zlib as an input.
@ -116,11 +114,10 @@ languages.")
(name "emacs-no-x-toolkit")
(synopsis "The extensible, customizable, self-documenting text
editor (without an X toolkit)" )
(inputs (alist-delete "gtk+" (package-inputs emacs)))
(arguments
(substitute-keyword-arguments (package-arguments emacs)
((#:configure-flags flags)
`(cons "--with-x-toolkit=no" ,flags))))))
(inputs (append `(("inotify-tools" ,inotify-tools))
(alist-delete "gtk+" (package-inputs emacs))))
(arguments (append '(#:configure-flags '("--with-x-toolkit=no"))
(package-arguments emacs)))))
;;;

View File

@ -1,13 +0,0 @@
Make sure the right shell is used when creating src/epaths.h.
--- emacs-24.3/configure 2013-03-14 17:42:26.000000000 +0100
+++ emacs-24.3/configure 2013-03-14 17:42:58.000000000 +0100
@@ -26463,7 +26463,7 @@ done
;;
"epaths":C)
echo creating src/epaths.h
-${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force
+${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force SHELL="$CONFIG_SHELL"
;;
"gdbinit":C)
if test ! -f src/.gdbinit && test -f $srcdir/src/.gdbinit; then