gnu: emacs: Update to 24.4.
* gnu/packages/patches/emacs-configure-sh.patch: Remove. * gnu-system.am (dist_patch_DATA): Remove it. * gnu/packages/emacs.scm (emacs): Update to 24.4. Add 'acl' as input. Remove --with-crt-dir configure option. (emacs-no-x-toolkit): Add 'inotify-tools' as input. Adjust to cope with the lack of configure-flags in the main 'emacs' package.
This commit is contained in:
parent
05b4226ad9
commit
388fd01b02
|
@ -327,7 +327,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/doxygen-tmake.patch \
|
gnu/packages/patches/doxygen-tmake.patch \
|
||||||
gnu/packages/patches/duplicity-piped-password.patch \
|
gnu/packages/patches/duplicity-piped-password.patch \
|
||||||
gnu/packages/patches/duplicity-test_selection-tmp.patch \
|
gnu/packages/patches/duplicity-test_selection-tmp.patch \
|
||||||
gnu/packages/patches/emacs-configure-sh.patch \
|
|
||||||
gnu/packages/patches/eudev-rules-directory.patch \
|
gnu/packages/patches/eudev-rules-directory.patch \
|
||||||
gnu/packages/patches/file-CVE-2014-3587.patch \
|
gnu/packages/patches/file-CVE-2014-3587.patch \
|
||||||
gnu/packages/patches/findutils-absolute-paths.patch \
|
gnu/packages/patches/findutils-absolute-paths.patch \
|
||||||
|
|
|
@ -43,27 +43,24 @@
|
||||||
#:use-module ((gnu packages compression) #:prefix compression:)
|
#:use-module ((gnu packages compression) #:prefix compression:)
|
||||||
#:use-module (gnu packages xml)
|
#:use-module (gnu packages xml)
|
||||||
#:use-module (gnu packages glib)
|
#:use-module (gnu packages glib)
|
||||||
|
#:use-module (gnu packages acl)
|
||||||
#:use-module (guix utils)
|
#:use-module (guix utils)
|
||||||
#:use-module (srfi srfi-1))
|
#:use-module (srfi srfi-1))
|
||||||
|
|
||||||
(define-public emacs
|
(define-public emacs
|
||||||
(package
|
(package
|
||||||
(name "emacs")
|
(name "emacs")
|
||||||
(version "24.3")
|
(version "24.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://gnu/emacs/emacs-"
|
(uri (string-append "mirror://gnu/emacs/emacs-"
|
||||||
version ".tar.xz"))
|
version ".tar.xz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1385qzs3bsa52s5rcncbrkxlydkw0ajzrvfxgv8rws5fx512kakh"))
|
"1zflm6ac34s6v166p58ilxrxbxjm0q2wfc25f8y0mjml1lbr3qs7"))))
|
||||||
(patches (list (search-patch "emacs-configure-sh.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:configure-flags
|
'(#:phases (alist-cons-before
|
||||||
(list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
|
|
||||||
"/lib"))
|
|
||||||
#:phases (alist-cons-before
|
|
||||||
'configure 'fix-/bin/pwd
|
'configure 'fix-/bin/pwd
|
||||||
(lambda _
|
(lambda _
|
||||||
;; Use `pwd', not `/bin/pwd'.
|
;; Use `pwd', not `/bin/pwd'.
|
||||||
|
@ -82,6 +79,7 @@
|
||||||
("libtiff" ,libtiff)
|
("libtiff" ,libtiff)
|
||||||
("giflib" ,giflib)
|
("giflib" ,giflib)
|
||||||
("libjpeg" ,libjpeg-8)
|
("libjpeg" ,libjpeg-8)
|
||||||
|
("acl" ,acl)
|
||||||
|
|
||||||
;; When looking for libpng `configure' links with `-lpng -lz', so we
|
;; When looking for libpng `configure' links with `-lpng -lz', so we
|
||||||
;; must also provide zlib as an input.
|
;; must also provide zlib as an input.
|
||||||
|
@ -116,11 +114,10 @@ languages.")
|
||||||
(name "emacs-no-x-toolkit")
|
(name "emacs-no-x-toolkit")
|
||||||
(synopsis "The extensible, customizable, self-documenting text
|
(synopsis "The extensible, customizable, self-documenting text
|
||||||
editor (without an X toolkit)" )
|
editor (without an X toolkit)" )
|
||||||
(inputs (alist-delete "gtk+" (package-inputs emacs)))
|
(inputs (append `(("inotify-tools" ,inotify-tools))
|
||||||
(arguments
|
(alist-delete "gtk+" (package-inputs emacs))))
|
||||||
(substitute-keyword-arguments (package-arguments emacs)
|
(arguments (append '(#:configure-flags '("--with-x-toolkit=no"))
|
||||||
((#:configure-flags flags)
|
(package-arguments emacs)))))
|
||||||
`(cons "--with-x-toolkit=no" ,flags))))))
|
|
||||||
|
|
||||||
|
|
||||||
;;;
|
;;;
|
||||||
|
|
|
@ -1,13 +0,0 @@
|
||||||
Make sure the right shell is used when creating src/epaths.h.
|
|
||||||
|
|
||||||
--- emacs-24.3/configure 2013-03-14 17:42:26.000000000 +0100
|
|
||||||
+++ emacs-24.3/configure 2013-03-14 17:42:58.000000000 +0100
|
|
||||||
@@ -26463,7 +26463,7 @@ done
|
|
||||||
;;
|
|
||||||
"epaths":C)
|
|
||||||
echo creating src/epaths.h
|
|
||||||
-${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force
|
|
||||||
+${MAKE-make} MAKEFILE_NAME=do-not-make-Makefile epaths-force SHELL="$CONFIG_SHELL"
|
|
||||||
;;
|
|
||||||
"gdbinit":C)
|
|
||||||
if test ! -f src/.gdbinit && test -f $srcdir/src/.gdbinit; then
|
|
Loading…
Reference in New Issue