gnu: flac: Upgrade to 1.3.0.
* gnu/packages/xiph.scm (flac): Update to version 1.3.0. Remove 'patches' field. * gnu/packages/patches/flac-fix-memcmp-not-declared.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly. Signed-off-by: Jason Self <j@jxself.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
This commit is contained in:
parent
49d91de763
commit
399fdcf75c
|
@ -297,7 +297,6 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/doxygen-tmake.patch \
|
||||
gnu/packages/patches/emacs-configure-sh.patch \
|
||||
gnu/packages/patches/findutils-absolute-paths.patch \
|
||||
gnu/packages/patches/flac-fix-memcmp-not-declared.patch \
|
||||
gnu/packages/patches/flex-bison-tests.patch \
|
||||
gnu/packages/patches/gawk-shell.patch \
|
||||
gnu/packages/patches/gcc-cross-environment-variables.patch \
|
||||
|
|
|
@ -1,13 +0,0 @@
|
|||
See http://sourceforge.net/p/flac/bugs/364/
|
||||
|
||||
diff -Naur flac-1.2.1-orig/examples/cpp/encode/file/main.cpp flac-1.2.1-ae/examples/cpp/encode/file/main.cpp
|
||||
--- flac-1.2.1-orig/examples/cpp/encode/file/main.cpp 2012-12-27 20:15:11.000000000 +0100
|
||||
+++ flac-1.2.1-ae/examples/cpp/encode/file/main.cpp 2012-12-27 20:25:01.000000000 +0100
|
||||
@@ -30,6 +30,7 @@
|
||||
|
||||
#include <stdio.h>
|
||||
#include <stdlib.h>
|
||||
+#include <string.h>
|
||||
#include "FLAC++/metadata.h"
|
||||
#include "FLAC++/encoder.h"
|
||||
|
|
@ -192,16 +192,14 @@ OpenBSD's sndio.")
|
|||
(define flac
|
||||
(package
|
||||
(name "flac")
|
||||
(version "1.2.1")
|
||||
(version "1.3.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
|
||||
version ".tar.gz"))
|
||||
version ".tar.xz"))
|
||||
(sha256
|
||||
(base32
|
||||
"1pry5lgzfg57pga1zbazzdd55fkgk3v5qy4axvrbny5lrr5s8dcn"))
|
||||
(patches
|
||||
(list (search-patch "flac-fix-memcmp-not-declared.patch")))))
|
||||
"1p0hh190kqvpkbk1bbajd81jfbmkyl4fn2i7pggk2zppq6m68bgs"))))
|
||||
(build-system gnu-build-system)
|
||||
(arguments
|
||||
`(#:parallel-tests? #f
|
||||
|
|
Loading…
Reference in New Issue