gnu: bitlbee: Update to 3.4.

* gnu/packages/patches/bitlbee-configure-doc-fix.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/messaging.scm (bitlbee): Update to 3.4.  Add patch.
  [inputs]: Remove 'zlib'.
master
Mark H Weaver 2015-05-20 14:55:26 -04:00
parent 87158e851f
commit 3a6fb858ad
3 changed files with 19 additions and 3 deletions

View File

@ -387,6 +387,7 @@ dist_patch_DATA = \
gnu/packages/patches/bigloo-gc-shebangs.patch \
gnu/packages/patches/binutils-ld-new-dtags.patch \
gnu/packages/patches/binutils-loongson-workaround.patch \
gnu/packages/patches/bitlbee-configure-doc-fix.patch \
gnu/packages/patches/calibre-drop-unrar.patch \
gnu/packages/patches/calibre-no-updates-dialog.patch \
gnu/packages/patches/cdparanoia-fpic.patch \

View File

@ -86,20 +86,20 @@ providing:
(define-public bitlbee
(package
(name "bitlbee")
(version "3.2.2")
(version "3.4")
(source (origin
(method url-fetch)
(uri (string-append "http://get.bitlbee.org/src/bitlbee-"
version ".tar.gz"))
(sha256
(base32 "13jmcxxgli82wb2n4hs091159xk8rgh7nb02f478lgpjh6996f5s"))))
(base32 "0plx4dryf8i6hz7vghg84z5f6w6rkw1l8ckl4c4wh5zxpd3ddfnf"))
(patches (list (search-patch "bitlbee-configure-doc-fix.patch")))))
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)
("check" ,check)))
(inputs `(("glib" ,glib)
("libotr" ,libotr)
("gnutls" ,gnutls)
("zlib" ,zlib) ; Needed to satisfy "pkg-config --exists gnutls"
("python" ,python-2)
("perl" ,perl)))
(arguments

View File

@ -0,0 +1,15 @@
Fix the check for the prebuilt helpfile when xsltproc is not available.
--- bitlbee-3.4/configure.orig 2015-03-25 18:09:10.000000000 -0400
+++ bitlbee-3.4/configure 2015-05-20 14:51:33.627975970 -0400
@@ -650,8 +650,8 @@
if [ "$doc" = "1" ]; then
if [ ! -e doc/user-guide/help.txt ] && \
- ! type xmlto > /dev/null 2> /dev/null || \
- ! type xsltproc > /dev/null 2> /dev/null
+ (! type xmlto > /dev/null 2> /dev/null || \
+ ! type xsltproc > /dev/null 2> /dev/null)
then
echo
echo 'WARNING: Building from an unreleased source tree without prebuilt helpfile.'