gnu: libtorrent-rasterbar: Update to 1.1.2.

* gnu/packages/bittorrent.scm (libtorrent-rasterbar): Update to 1.1.2.
[source]: Use patch.
* gnu/packages/patches/libtorrent-rasterbar-boost-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
master
Marius Bakke 2017-03-26 07:49:50 +02:00
parent ff4dc16eac
commit 3c5698046a
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
3 changed files with 35 additions and 3 deletions

View File

@ -712,6 +712,7 @@ dist_patch_DATA = \
%D%/packages/patches/libtiff-invalid-read.patch \
%D%/packages/patches/libtiff-null-dereference.patch \
%D%/packages/patches/libtiff-tiffcp-underflow.patch \
%D%/packages/patches/libtorrent-rasterbar-boost-compat.patch \
%D%/packages/patches/libtool-skip-tests2.patch \
%D%/packages/patches/libunwind-CVE-2015-3239.patch \
%D%/packages/patches/libvpx-CVE-2016-2818.patch \

View File

@ -31,6 +31,7 @@
#:use-module (guix build-system python)
#:use-module (guix build-system glib-or-gtk)
#:use-module ((guix licenses) #:prefix l:)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@ -379,16 +380,19 @@ and will take advantage of multiple processor cores where possible.")
(define-public libtorrent-rasterbar
(package
(name "libtorrent-rasterbar")
(version "1.0.10")
(version "1.1.2")
(source (origin
(method url-fetch)
(uri
(string-append
"https://github.com/arvidn/libtorrent/releases/download/libtorrent-"
"1_0_10" "/libtorrent-rasterbar-" version ".tar.gz"))
(string-join (string-split version #\.) "_")
"/libtorrent-rasterbar-" version ".tar.gz"))
(patches
(search-patches "libtorrent-rasterbar-boost-compat.patch"))
(sha256
(base32
"0gjcr892hzmcngvpw5bycjci4dk49v763lsnpvbwsjmim2ncwrd8"))))
"16im9qsmfrmmkhfjpij9739nqpn4s6wgc9cikdxbcyshfhimzra5"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags

View File

@ -0,0 +1,27 @@
Fix compatibility with Boost 1.63.
Patch copied from upstream source repository:
https://github.com/arvidn/libtorrent/commit/6d2d736cecce0af274dd651dd1f562716b625d92
From 6d2d736cecce0af274dd651dd1f562716b625d92 Mon Sep 17 00:00:00 2001
From: arvidn <arvid@cs.umu.se>
Date: Sun, 12 Mar 2017 13:03:26 -0400
Subject: [PATCH] fix test_ssl.cpp build with newer versions of boost
---
test/test_ssl.cpp | 1 -
1 file changed, 1 deletion(-)
diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
index 01c5bc7..2903332 100644
--- a/test/test_ssl.cpp
+++ b/test/test_ssl.cpp
@@ -51,7 +51,6 @@ POSSIBILITY OF SUCH DAMAGE.
#include <boost/asio/connect.hpp>
#ifdef TORRENT_USE_OPENSSL
-#include <boost/asio/ssl/error.hpp> // for asio::error::get_ssl_category()
#include <boost/asio/ssl.hpp>
#include "libtorrent/aux_/disable_warnings_pop.hpp"