gnu: libdrm: Update to 2.4.77.

* gnu/packages/xdisorg.scm (libdrm): Update to 2.4.77.
* gnu/packages/patches/libdrm-symbol-check.patch: Adjust to upstream changes.
This commit is contained in:
Marius Bakke 2017-04-06 15:30:36 +02:00
parent 9092633c7f
commit 3c81c4f90c
No known key found for this signature in database
GPG Key ID: A2A06DF2A33A54FA
2 changed files with 12 additions and 17 deletions

View File

@ -174,26 +174,21 @@ mips64el-linux, armhf-linux and aarch64-linux.
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@
#!/bin/bash #!/bin/bash
-# The following symbols (past the first five) are taken from the public headers. -# The following symbols (past the first nine) are taken from tegra.h.
+# The following symbols (past the first 12) are taken from the public headers. +# The following symbols (past the first 12) are taken from tegra.h.
# A list of the latter should be available Makefile.sources/LIBDRM_FREEDRENO_H_FILES
FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do FUNCS=$(nm -D --format=bsd --defined-only ${1-.libs/libdrm_tegra.so} | awk '{print $3}'| while read func; do
@@ -10,6 +10,13 @@ ( grep -q "^$func$" || echo $func ) <<EOF
_end @@ -9,6 +9,9 @@
_fini __bss_start
_init __end__
_bss_end__
+_fbss +_fbss
+_fdata +_fdata
+_ftext +_ftext
+__bss_start__ _edata
+__bss_end__ _end
+_bss_end__ _fini
+__end__
drm_tegra_bo_get_flags
drm_tegra_bo_get_handle
drm_tegra_bo_get_tiling
--- libdrm-2.4.65/radeon/radeon-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400 --- libdrm-2.4.65/radeon/radeon-symbol-check.orig 2015-05-04 11:47:43.000000000 -0400
+++ libdrm-2.4.65/radeon/radeon-symbol-check 2015-10-18 23:57:00.756759698 -0400 +++ libdrm-2.4.65/radeon/radeon-symbol-check 2015-10-18 23:57:00.756759698 -0400
@@ -1,6 +1,6 @@ @@ -1,6 +1,6 @@

View File

@ -277,7 +277,7 @@ rasterisation.")
(define-public libdrm (define-public libdrm
(package (package
(name "libdrm") (name "libdrm")
(version "2.4.75") (version "2.4.77")
(source (source
(origin (origin
(method url-fetch) (method url-fetch)
@ -287,7 +287,7 @@ rasterisation.")
".tar.bz2")) ".tar.bz2"))
(sha256 (sha256
(base32 (base32
"0kq5hmck0gq7b29fr8jp94njc7jpkpbyws12s63w4b21xw750nid")) "0v9vzgv8nb7q4q83c2402m6b7vifl52xwzzr9lmx19227b5f5mg8"))
(patches (search-patches "libdrm-symbol-check.patch")))) (patches (search-patches "libdrm-symbol-check.patch"))))
(build-system gnu-build-system) (build-system gnu-build-system)
(inputs (inputs