gnu: efl: Update to 1.22.2.
* gnu/packages/enlightenment.scm (efl): Update to 1.22.2. [propagated-inputs]: Move libsndfile, pulseaudio ... [inputs]: ... to here. [source]: Remove patch. * gnu/packages/patches/efl-mesa-compat.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
515a92cf20
commit
3ec29587b5
|
@ -745,7 +745,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/dovecot-trees-support-dovecot-2.3.patch \
|
||||
%D%/packages/patches/doxygen-test.patch \
|
||||
%D%/packages/patches/dvd+rw-tools-add-include.patch \
|
||||
%D%/packages/patches/efl-mesa-compat.patch \
|
||||
%D%/packages/patches/elfutils-tests-ptrace.patch \
|
||||
%D%/packages/patches/elixir-path-length.patch \
|
||||
%D%/packages/patches/einstein-build.patch \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015 Tomáš Čech <sleep_walker@suse.cz>
|
||||
;;; Copyright © 2015 Daniel Pimentel <d4n1@member.fsf.org>
|
||||
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2017 ng0 <ng0@n0.is>
|
||||
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
|
||||
;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
|
||||
|
@ -65,18 +65,17 @@
|
|||
(define-public efl
|
||||
(package
|
||||
(name "efl")
|
||||
(version "1.21.1")
|
||||
(version "1.22.2")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
"https://download.enlightenment.org/rel/libs/efl/efl-"
|
||||
version ".tar.xz"))
|
||||
(patches (search-patches "efl-mesa-compat.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"0a5907h896pvpix7a6idc2fspzy6d78xrzf84k8y9fyvnd14nxs4"))))
|
||||
(outputs '("out" ; 49 MB
|
||||
"include")) ; 17 MB
|
||||
"1l0wdgzxqm2y919277b1p9d37xzg808zwxxaw0nn44arh8gqk68n"))))
|
||||
(outputs '("out" ; 53 MB
|
||||
"include")) ; 21 MB
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs
|
||||
`(("pkg-config" ,pkg-config)))
|
||||
|
@ -91,6 +90,7 @@
|
|||
("libjpeg" ,libjpeg)
|
||||
("libraw" ,libraw)
|
||||
("librsvg" ,librsvg)
|
||||
("libsndfile" ,libsndfile)
|
||||
("libspectre" ,libspectre)
|
||||
("libtiff" ,libtiff)
|
||||
("libwebp" ,libwebp)
|
||||
|
@ -113,6 +113,7 @@
|
|||
("openjpeg" ,openjpeg-1)
|
||||
("poppler" ,poppler)
|
||||
("printproto" ,printproto)
|
||||
("pulseaudio" ,pulseaudio)
|
||||
("wayland-protocols" ,wayland-protocols)
|
||||
("xinput" ,xinput)
|
||||
("xpr" ,xpr)
|
||||
|
@ -131,11 +132,9 @@
|
|||
("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
|
||||
("libinput" ,libinput-minimal) ; elput.pc
|
||||
("libpng" ,libpng) ; evas.pc, evas-cxx.pc
|
||||
("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
|
||||
("libxkbcommon" ,libxkbcommon) ; ecore-wl2.pc, elementary.pc, elput.pc
|
||||
("mesa" ,mesa) ; ecore-drm2.pc
|
||||
("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
|
||||
("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
|
||||
("util-linux" ,util-linux) ; mount: eeze.pc
|
||||
("wayland" ,wayland) ; ecore-wl2.pc, elementary.pc
|
||||
("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
|
||||
|
|
|
@ -1,21 +0,0 @@
|
|||
Fix build on 32-bit architectures with Mesa 18.3. Patch taken from upstream:
|
||||
|
||||
https://git.enlightenment.org/core/efl.git/commit/?id=0d2b624f1e24240a1c4e651aa1cfe9a8dd10a573
|
||||
|
||||
diff --git a/src/lib/evas/Evas_GL.h b/src/lib/evas/Evas_GL.h
|
||||
index b6b642400f..4f67b1695f 100644
|
||||
--- a/src/lib/evas/Evas_GL.h
|
||||
+++ b/src/lib/evas/Evas_GL.h
|
||||
@@ -4272,9 +4272,11 @@ typedef signed int GLfixed; // Changed khronos_int32_t
|
||||
|
||||
#ifndef GL_ES_VERSION_2_0
|
||||
/* GL types for handling large vertex buffer objects */
|
||||
-#include <stddef.h>
|
||||
+# ifndef GL_VERSION_1_5
|
||||
+# include <stddef.h>
|
||||
typedef ptrdiff_t GLintptr; // Changed khronos_intptr_t
|
||||
typedef ptrdiff_t GLsizeiptr; // Changed khronos_ssize_t
|
||||
+# endif
|
||||
#endif
|
||||
|
||||
/* Some definitions from GLES 3.0.
|
Loading…
Reference in New Issue