gnu: shadow: Update to 4.4.
* gnu/packages/admin.scm (shadow): Update to 4.4. [source]: Adjust URL. * gnu/packages/patches/shadow-4.4-su-snprintf-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. Signed-off-by: Leo Famulari <leo@famulari.name>
This commit is contained in:
parent
52701a3d35
commit
4153ef23f5
|
@ -892,6 +892,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||||
%D%/packages/patches/serf-comment-style-fix.patch \
|
%D%/packages/patches/serf-comment-style-fix.patch \
|
||||||
%D%/packages/patches/serf-deflate-buckets-test-fix.patch \
|
%D%/packages/patches/serf-deflate-buckets-test-fix.patch \
|
||||||
|
%D%/packages/patches/shadow-4.4-su-snprintf-fix.patch \
|
||||||
%D%/packages/patches/slim-session.patch \
|
%D%/packages/patches/slim-session.patch \
|
||||||
%D%/packages/patches/slim-config.patch \
|
%D%/packages/patches/slim-config.patch \
|
||||||
%D%/packages/patches/slim-sigusr1.patch \
|
%D%/packages/patches/slim-sigusr1.patch \
|
||||||
|
|
|
@ -270,15 +270,16 @@ client and server, a telnet client and server, and an rsh client and server.")
|
||||||
(define-public shadow
|
(define-public shadow
|
||||||
(package
|
(package
|
||||||
(name "shadow")
|
(name "shadow")
|
||||||
(version "4.2.1")
|
(version "4.4")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
"http://pkg-shadow.alioth.debian.org/releases/"
|
"https://github.com/shadow-maint/shadow/releases/"
|
||||||
name "-" version ".tar.xz"))
|
"download/" version "/shadow-" version ".tar.xz"))
|
||||||
|
(patches (search-patches "shadow-4.4-su-snprintf-fix.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0h9x1zdbq0pqmygmc1x459jraiqw4gqz8849v268crk78z8r621v"))))
|
"0g7hf55ar2pafg5g3ldx0fwzjk36wf4xb21p4ndanbjm3c2a9ab1"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(;; Assume System V `setpgrp (void)', which is the default on GNU
|
'(;; Assume System V `setpgrp (void)', which is the default on GNU
|
||||||
|
|
|
@ -0,0 +1,31 @@
|
||||||
|
Patch copied from upstream source repository:
|
||||||
|
|
||||||
|
https://github.com/shadow-maint/shadow/commit/67d2bb6e0a5ac124ce1f026dd5723217b1493194
|
||||||
|
|
||||||
|
From 67d2bb6e0a5ac124ce1f026dd5723217b1493194 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Serge Hallyn <serge@hallyn.com>
|
||||||
|
Date: Sun, 18 Sep 2016 21:31:18 -0500
|
||||||
|
Subject: [PATCH] su.c: fix missing length argument to snprintf
|
||||||
|
|
||||||
|
---
|
||||||
|
src/su.c | 4 ++--
|
||||||
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/su.c b/src/su.c
|
||||||
|
index 0c50a9456afd..93ffd2fbe2b4 100644
|
||||||
|
--- a/src/su.c
|
||||||
|
+++ b/src/su.c
|
||||||
|
@@ -373,8 +373,8 @@ static void prepare_pam_close_session (void)
|
||||||
|
stderr);
|
||||||
|
(void) kill (-pid_child, caught);
|
||||||
|
|
||||||
|
- snprintf (kill_msg, _(" ...killed.\n"));
|
||||||
|
- snprintf (wait_msg, _(" ...waiting for child to terminate.\n"));
|
||||||
|
+ snprintf (kill_msg, 256, _(" ...killed.\n"));
|
||||||
|
+ snprintf (wait_msg, 256, _(" ...waiting for child to terminate.\n"));
|
||||||
|
|
||||||
|
(void) signal (SIGALRM, kill_child);
|
||||||
|
(void) alarm (2);
|
||||||
|
--
|
||||||
|
2.11.0.rc2
|
||||||
|
|
Loading…
Reference in New Issue