gnu: scribus: Fix build with recent Poppler.
Suggested by ngz on #guix. * gnu/packages/patches/scribus-poppler.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/scribus.scm (scribus)[source]: Add patch.
This commit is contained in:
parent
8b5e2e94af
commit
4236959de8
|
@ -1145,6 +1145,7 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/scotch-build-parallelism.patch \
|
||||
%D%/packages/patches/scotch-graph-diam-64.patch \
|
||||
%D%/packages/patches/scotch-graph-induce-type-64.patch \
|
||||
%D%/packages/patches/scribus-poppler.patch \
|
||||
%D%/packages/patches/sdl-libx11-1.6.patch \
|
||||
%D%/packages/patches/seq24-rename-mutex.patch \
|
||||
%D%/packages/patches/sharutils-CVE-2018-1000097.patch \
|
||||
|
|
|
@ -0,0 +1,72 @@
|
|||
Fix build with recent Poppler.
|
||||
|
||||
From d867ec3c386baaed1b8e076dd70b278863411480 Mon Sep 17 00:00:00 2001
|
||||
From: Jean Ghali <jghali@libertysurf.fr>
|
||||
Date: Mon, 30 Apr 2018 09:19:33 +0000
|
||||
Subject: [PATCH] =?UTF-8?q?#15289:=20FTBFS=201.5.4=20with=20error:=20inval?=
|
||||
=?UTF-8?q?id=20conversion=20from=20=E2=80=98const=20GooString*=E2=80=99?=
|
||||
=?UTF-8?q?=20to=20=E2=80=98GooString*=E2=80=99?=
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
git-svn-id: svn://scribus.net/trunk/Scribus@22498 11d20701-8431-0410-a711-e3c959e3b870
|
||||
---
|
||||
scribus/plugins/import/pdf/importpdf.cpp | 2 +-
|
||||
scribus/plugins/import/pdf/importpdf.h | 2 +-
|
||||
scribus/plugins/import/pdf/slaoutput.cpp | 2 +-
|
||||
scribus/plugins/import/pdf/slaoutput.h | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/scribus/plugins/import/pdf/importpdf.cpp b/scribus/plugins/import/pdf/importpdf.cpp
|
||||
index c1802861aa..d4c5a9ba49 100644
|
||||
--- a/scribus/plugins/import/pdf/importpdf.cpp
|
||||
+++ b/scribus/plugins/import/pdf/importpdf.cpp
|
||||
@@ -1081,7 +1081,7 @@ QRectF PdfPlug::getCBox(int box, int pgNum)
|
||||
return cRect;
|
||||
}
|
||||
|
||||
-QString PdfPlug::UnicodeParsedString(GooString *s1)
|
||||
+QString PdfPlug::UnicodeParsedString(const GooString *s1)
|
||||
{
|
||||
if ( !s1 || s1->getLength() == 0 )
|
||||
return QString();
|
||||
diff --git a/scribus/plugins/import/pdf/importpdf.h b/scribus/plugins/import/pdf/importpdf.h
|
||||
index c8c5efcd0d..5249562692 100644
|
||||
--- a/scribus/plugins/import/pdf/importpdf.h
|
||||
+++ b/scribus/plugins/import/pdf/importpdf.h
|
||||
@@ -81,7 +81,7 @@ class PdfPlug : public QObject
|
||||
private:
|
||||
bool convert(const QString& fn);
|
||||
QRectF getCBox(int box, int pgNum);
|
||||
- QString UnicodeParsedString(GooString *s1);
|
||||
+ QString UnicodeParsedString(const GooString *s1);
|
||||
|
||||
QList<PageItem*> Elements;
|
||||
double baseX, baseY;
|
||||
diff --git a/scribus/plugins/import/pdf/slaoutput.cpp b/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
index be1815dc29..17b6357246 100644
|
||||
--- a/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
+++ b/scribus/plugins/import/pdf/slaoutput.cpp
|
||||
@@ -4252,7 +4252,7 @@ void SlaOutputDev::pushGroup(QString maskName, GBool forSoftMask, GBool alpha, b
|
||||
m_groupStack.push(gElements);
|
||||
}
|
||||
|
||||
-QString SlaOutputDev::UnicodeParsedString(GooString *s1)
|
||||
+QString SlaOutputDev::UnicodeParsedString(const GooString *s1)
|
||||
{
|
||||
if ( !s1 || s1->getLength() == 0 )
|
||||
return QString();
|
||||
diff --git a/scribus/plugins/import/pdf/slaoutput.h b/scribus/plugins/import/pdf/slaoutput.h
|
||||
index 20e8b2d311..6698c030e0 100644
|
||||
--- a/scribus/plugins/import/pdf/slaoutput.h
|
||||
+++ b/scribus/plugins/import/pdf/slaoutput.h
|
||||
@@ -266,7 +266,7 @@ class SlaOutputDev : public OutputDev
|
||||
int getBlendMode(GfxState *state);
|
||||
void applyMask(PageItem *ite);
|
||||
void pushGroup(QString maskName = "", GBool forSoftMask = gFalse, GBool alpha = gFalse, bool inverted = false);
|
||||
- QString UnicodeParsedString(GooString *s1);
|
||||
+ QString UnicodeParsedString(const GooString *s1);
|
||||
bool checkClip();
|
||||
bool pathIsClosed;
|
||||
QString CurrColorFill;
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2015, 2018 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2017, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
|
||||
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
|
||||
|
@ -56,7 +56,7 @@
|
|||
(sha256
|
||||
(base32
|
||||
"00ys0p6h3iq77kh72dkl0qrf7qvznq18qdrgiq10gfxja1995034"))
|
||||
(modules '((guix build utils)))))
|
||||
(patches (search-patches "scribus-poppler.patch"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments
|
||||
`(#:tests? #f ;no test target
|
||||
|
|
Loading…
Reference in New Issue