gnu: gmp: Skip unreliable test.
* gnu/packages/patches/gmp-faulty-test.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/multiprecision.scm (gmp)[source]: Use it.
This commit is contained in:
parent
18bf40a087
commit
42e735dfc7
|
@ -474,6 +474,7 @@ dist_patch_DATA = \
|
|||
gnu/packages/patches/glibc-o-largefile.patch \
|
||||
gnu/packages/patches/glibc-versioned-locpath.patch \
|
||||
gnu/packages/patches/gmp-arm-asm-nothumb.patch \
|
||||
gnu/packages/patches/gmp-faulty-test.patch \
|
||||
gnu/packages/patches/gnucash-price-quotes-perl.patch \
|
||||
gnu/packages/patches/gnutls-doc-fix.patch \
|
||||
gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
|
||||
|
|
|
@ -1,5 +1,5 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
|
||||
;;;
|
||||
|
@ -39,7 +39,9 @@
|
|||
(sha256
|
||||
(base32
|
||||
"0r5pp27cy7ch3dg5v0rsny8bib1zfvrza6027g2mp5f6v8pd6mli"))
|
||||
(patches (list (search-patch "gmp-arm-asm-nothumb.patch")))))
|
||||
(patches (map search-patch
|
||||
'("gmp-arm-asm-nothumb.patch"
|
||||
"gmp-faulty-test.patch")))))
|
||||
(build-system gnu-build-system)
|
||||
(native-inputs `(("m4" ,m4)))
|
||||
(outputs '("out" "debug"))
|
||||
|
|
|
@ -0,0 +1,11 @@
|
|||
Skip a test that randomly fails on ARMv7: <http://bugs.gnu.org/21620>.
|
||||
|
||||
--- a/tests/mpz/reuse.c
|
||||
+++ b/tests/mpz/reuse.c
|
||||
@@ -213,6 +213,7 @@ main (int argc, char **argv)
|
||||
mpz_t bs;
|
||||
unsigned long bsi, size_range;
|
||||
|
||||
+ exit (77); /* skip */
|
||||
tests_start ();
|
||||
TESTS_REPS (reps, argv, argc);
|
Loading…
Reference in New Issue