gnu: kde-frameworks: Update to 5.42.0 resp. 5.42.1

Beside simple updating:
- Change all todo-comments for test-cases into "fixme" comments to make them
  easier to find.
- breeze-icons: Blacklist a test failing at build.kde.org, too.
- extra-cmake-modules: Patch out a vanised test-case.
- kfilemetadata: Can now run the test-suite uninstalled. Blacklist a failing
  test-case.
- kimageformats: No longer symlink plugins into ./bin for testing.
- ktexteditor: Remove now unused patch.
- plasma-framework: Add input kirigami
- sonnet: For testing set QT_QPA_PLATFORM=offscreen.

* gnu/packages/kde-frameworks.scm (attica, baloo, bluez-qt, kactivities,
  kactivities-stats, kapidox, karchive, kauth, kbookmarks, kcmutils, kcodecs,
  kcompletion, kconfig, kconfigwidgets, kcoreaddons, kcrash, kdbusaddons,
  kde-frameworkintegration, kdeclarative, kded, kdelibs4support,
  kdesignerplugin, kdesu, kdewebkit, kdnssd, kdoctools, kemoticons,
  kglobalaccel, kguiaddons, khtml, ki18n, kiconthemes, kidletime, kinit, kio,
  kirigami, kitemmodels, kitemviews, kjobwidgets, kjs, kjsembed, kmediaplayer,
  knewstuff, knotifications, knotifyconfig, kpackage, kparts, kpeople,
  kplotting, kpty, kross, krunner, kservice, ksyntaxhighlighting,
  ktextwidgets, kunitconversion, kwallet, kwayland, kwindowsystem, kxmlgui,
  kxmlrpcclient, modemmanager-qt, networkmanager-qt, oxygen-icons,
  prison, solid, threadweaver): Update to 5.42.0.
  (kwidgetsaddons): Update to 5.42.1.
  (breeze-icons): Update to 5.42.0. [#:phases]<disable-failing-test> New
  phase.
  (extra-cmake-modules): Update to 5.42.0.
  [#:phases]<post-5.42.0-release-fix>: New phase.
  (kfilemetadata): Update to 5.42.0. [#:phases]: No longer move check behind
  install. [#:phases]<check-setup> Remove. [#:phase]<disable-failing-test> New
  phase.
  (kimageformats): Update to 5.42.0. [#:phases]<check-setup>: No longer
  symlink plugins into ./bin.
  (ktesteditor)[source]: Remove patch.
  (plasma-framework)[inputs]: Add  kirigami
  (sonnet): Update to 5.42.0. [#:phases]<check-setup> New phase.
* gnu/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch:
  Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
master
Hartmut Goebel 2018-02-04 14:33:48 +01:00
parent 042f7c2636
commit 431ff8bea3
No known key found for this signature in database
GPG Key ID: 634A8DFFD3F631DF
3 changed files with 189 additions and 217 deletions

View File

@ -798,7 +798,6 @@ dist_patch_DATA = \
%D%/packages/patches/kobodeluxe-manpage-minus-not-hyphen.patch \
%D%/packages/patches/kobodeluxe-midicon-segmentation-fault.patch \
%D%/packages/patches/kobodeluxe-graphics-window-signed-char.patch \
%D%/packages/patches/ktexteditor-5.39.0-autotests-dependencies.patch \
%D%/packages/patches/laby-make-install.patch \
%D%/packages/patches/lcms-CVE-2016-10165.patch \
%D%/packages/patches/ldc-disable-tests.patch \

File diff suppressed because it is too large Load Diff

View File

@ -1,49 +0,0 @@
Add missing dependencies, see <https://phabricator.kde.org/D8577>.
diff -r -U5 ktexteditor-5.39.0.orig/autotests/CMakeLists.txt ktexteditor-5.39.0/autotests/CMakeLists.txt
--- ktexteditor-5.39.0.orig/autotests/CMakeLists.txt 2017-10-31 16:28:45.018163060 +0100
+++ ktexteditor-5.39.0/autotests/CMakeLists.txt 2017-10-31 16:28:16.439559888 +0100
@@ -37,10 +37,11 @@
set (KTEXTEDITOR_TEST_LINK_LIBS KF5TextEditor
KF5::I18n
KF5::IconThemes
KF5::GuiAddons
Qt5::Qml
+ Qt5::Script
)
include(ECMMarkAsTest)
# test executable for encoding
diff -r -U5 ktexteditor-5.39.0.orig/CMakeLists.txt ktexteditor-5.39.0/CMakeLists.txt
--- ktexteditor-5.39.0.orig/CMakeLists.txt 2017-10-31 16:28:38.578252490 +0100
+++ ktexteditor-5.39.0/CMakeLists.txt 2017-10-31 16:30:24.656778737 +0100
@@ -38,11 +38,12 @@
# Dependencies
set(REQUIRED_QT_VERSION 5.7.0)
# Required Qt5 components to build this framework
-find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets Qml PrintSupport Xml XmlPatterns)
+find_package(Qt5 ${REQUIRED_QT_VERSION} NO_MODULE REQUIRED Core Widgets Qml
+ Script PrintSupport Xml XmlPatterns)
find_package(KF5Archive ${KF5_DEP_VERSION} REQUIRED)
find_package(KF5Config ${KF5_DEP_VERSION} REQUIRED)
find_package(KF5GuiAddons ${KF5_DEP_VERSION} REQUIRED)
find_package(KF5I18n ${KF5_DEP_VERSION} REQUIRED)
diff -r -U5 ktexteditor-5.39.0/autotests/src/vimode/CMakeLists.txt ktexteditor-5.39.0.new/autotests/src/vimode/CMakeLists.txt
--- ktexteditor-5.39.0/autotests/src/vimode/CMakeLists.txt 1970-01-01 01:00:00.000000000 +0100
+++ ktexteditor-5.39.0.new/autotests/src/vimode/CMakeLists.txt 2017-10-31 16:58:29.909003953 +0100
@@ -4,10 +4,11 @@
${CMAKE_SOURCE_DIR}/src/vimode
)
set (VIMODE_TEST_LINK_LIBS KF5TextEditor
KF5::I18n
+ Qt5::Qml
Qt5::Test
)
macro(vimode_unit_test)
ecm_add_test(${ARGN} TEST_NAME "vimode_${ARGV0}"