gnu: nyacc: Update to 0.86.0.
* gnu/packages/patches/nyacc-binary-literals.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mes.scm (nyacc): Update to 0.86.0, add patch.
This commit is contained in:
parent
39b5d8fd9d
commit
445ecce923
|
@ -988,6 +988,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
%D%/packages/patches/nvi-assume-preserve-path.patch \
|
||||||
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
%D%/packages/patches/nvi-dbpagesize-binpower.patch \
|
||||||
%D%/packages/patches/nvi-db4.patch \
|
%D%/packages/patches/nvi-db4.patch \
|
||||||
|
%D%/packages/patches/nyacc-binary-literals.patch \
|
||||||
%D%/packages/patches/nyx-show-header-stats-with-python3.patch \
|
%D%/packages/patches/nyx-show-header-stats-with-python3.patch \
|
||||||
%D%/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch \
|
%D%/packages/patches/ocaml-bisect-fix-camlp4-in-another-directory.patch \
|
||||||
%D%/packages/patches/ocaml-bitstring-fix-configure.patch \
|
%D%/packages/patches/ocaml-bitstring-fix-configure.patch \
|
||||||
|
|
|
@ -39,15 +39,15 @@
|
||||||
(define-public nyacc
|
(define-public nyacc
|
||||||
(package
|
(package
|
||||||
(name "nyacc")
|
(name "nyacc")
|
||||||
(version "0.83.3")
|
(version "0.86.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "mirror://savannah/nyacc/"
|
(uri (string-append "mirror://savannah/nyacc/"
|
||||||
name "-" version ".tar.gz"))
|
name "-" version ".tar.gz"))
|
||||||
(file-name (string-append name "-" version ".tar.gz"))
|
(patches (search-patches "nyacc-binary-literals.patch"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0120n0mdb6r58c4jc024dhwqy5s8a20waknijfhqjc59a884lrd6"))))
|
"0lkd9lyspvhxlfs0496gsllwinh62jk9wij6gpadvx9gwz6yavd9"))))
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("guile" ,guile-2.2)))
|
`(("guile" ,guile-2.2)))
|
||||||
|
|
|
@ -0,0 +1,29 @@
|
||||||
|
From 6a08014b77bf435f025ecdac08396580b85f159a Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jan Nieuwenhuizen <janneke@gnu.org>
|
||||||
|
Date: Sat, 8 Sep 2018 20:22:45 +0200
|
||||||
|
Subject: [PATCH] fix binary literals.
|
||||||
|
|
||||||
|
---
|
||||||
|
module/nyacc/lex.scm | 3 ++-
|
||||||
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/module/nyacc/lex.scm b/module/nyacc/lex.scm
|
||||||
|
index 2ec9895..b205212 100644
|
||||||
|
--- a/module/nyacc/lex.scm
|
||||||
|
+++ b/module/nyacc/lex.scm
|
||||||
|
@@ -345,10 +345,11 @@
|
||||||
|
((char-numeric? ch) (iter chl '$fixed ba 1 ch))
|
||||||
|
((char=? #\. ch) (iter (cons ch chl) #f ba 15 (read-char)))
|
||||||
|
(else #f)))
|
||||||
|
- ((10) ;; allow x after 0
|
||||||
|
+ ((10) ;; allow x, b after 0
|
||||||
|
(cond
|
||||||
|
((eof-object? ch) (iter chl ty ba 5 ch))
|
||||||
|
((char=? #\x ch) (iter (cons ch chl) ty 16 1 (read-char)))
|
||||||
|
+ ((char=? #\b ch) (iter (cons ch chl) ty 2 1 (read-char)))
|
||||||
|
(else (iter chl ty ba 1 ch))))
|
||||||
|
((15) ;; got `.' only
|
||||||
|
(cond
|
||||||
|
--
|
||||||
|
2.18.0
|
||||||
|
|
Loading…
Reference in New Issue