gnu: node: Update to 8.4.0.

* gnu/packages/patches/node-9077.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
* gnu/packages/node.scm (node): Update to 8.4.0.
(node)[arguments]: Removed broken linter test. Removed dns test.
master
Jelle Licht 2017-07-27 17:11:08 +02:00
parent 4da9beab14
commit 448339709d
No known key found for this signature in database
GPG Key ID: DA4597F947B41025
3 changed files with 5 additions and 39 deletions

View File

@ -872,7 +872,6 @@ dist_patch_DATA = \
%D%/packages/patches/newsbeuter-CVE-2017-12904.patch \
%D%/packages/patches/ngircd-handle-zombies.patch \
%D%/packages/patches/ninja-zero-mtime.patch \
%D%/packages/patches/node-9077.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
%D%/packages/patches/nss-pkgconfig.patch \
%D%/packages/patches/nvi-assume-preserve-path.patch \

View File

@ -40,16 +40,14 @@
(define-public node
(package
(name "node")
(version "8.1.2")
(version "8.4.0")
(source (origin
(method url-fetch)
(uri (string-append "http://nodejs.org/dist/v" version
"/node-v" version ".tar.gz"))
(sha256
(base32
"0l92gar1pivzaiwffiiiz2f2m5k39sl5fphlfnvy0ml9hrjb65yp"))
;; https://github.com/nodejs/node/pull/9077
(patches (search-patches "node-9077.patch"))))
"1vrpc4lspm33hmb8c2q4w1fzg3iaip2gx4wpr4nyy417hbx1a6k4"))))
(build-system gnu-build-system)
(arguments
;; TODO: Purge the bundled copies from the source.
@ -78,10 +76,9 @@
(("'/usr/bin/env'")
(string-append "'" (which "env") "'")))
;; Having the build fail because of linter errors is insane!
;; Linting is no longer supported in the release tarball
(substitute* '("Makefile")
((" \\$\\(MAKE\\) jslint") "")
((" \\$\\(MAKE\\) cpplint\n") ""))
((" \\$\\(MAKE\\) lint") ""))
;; FIXME: This test seems to depends on files that are not
;; available in the bundled v8. See
@ -95,6 +92,7 @@
"test/parallel/test-util-inspect.js"
"test/parallel/test-v8-serdes.js"
"test/parallel/test-dgram-membership.js"
"test/parallel/test-dns-resolveany.js"
"test/parallel/test-cluster-master-error.js"
"test/parallel/test-cluster-master-kill.js"
"test/parallel/test-npm-install.js"

View File

@ -1,31 +0,0 @@
From fc164acbbb700fd50ab9c04b47fc1b2687e9c0f4 Mon Sep 17 00:00:00 2001
From: "Bradley T. Hughes" <bradleythughes@fastmail.fm>
Date: Thu, 13 Oct 2016 07:38:38 +0000
Subject: [PATCH] build: add -DZLIB_CONST when building with --shared-zlib
Commit 782620f added the define only when building with the bundled
zlib. Using a shared zlib results in build breakage:
../src/inspector_agent.cc:179:16: error: assigning to 'Bytef *' (aka 'unsigned char *') from incompatible type
'const uint8_t *' (aka 'const unsigned char *')
strm.next_in = PROTOCOL_JSON + 3;
^ ~~~~~~~~~~~~~~~~~
1 error generated.
---
node.gyp | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/node.gyp b/node.gyp
index 272dc98..667c260 100644
--- a/node.gyp
+++ b/node.gyp
@@ -653,7 +653,8 @@
[ 'node_shared_zlib=="false"', {
'dependencies': [
'deps/zlib/zlib.gyp:zlib',
- ]
+ ]}, {
+ 'defines': [ 'ZLIB_CONST' ],
}],
[ 'node_shared_openssl=="false"', {
'dependencies': [