gnu: liblxqt: Fix build with Qt 5.5.

* gnu/packages/patches/liblxqt-include.patch: New file.
* gnu-system.am (dist_patch_DATA): Register patch.
* gnu/packages/lxqt.scm (liblxqt)[source]: Use patch.
master
Andreas Enge 2015-07-27 22:54:58 +02:00
parent 6cef1b9b99
commit 44a477e1ac
3 changed files with 20 additions and 2 deletions

View File

@ -494,6 +494,7 @@ dist_patch_DATA = \
gnu/packages/patches/libcanberra-sound-theme-freedesktop.patch \
gnu/packages/patches/libevent-dns-tests.patch \
gnu/packages/patches/liboop-mips64-deplibs-fix.patch \
gnu/packages/patches/liblxqt-include.patch \
gnu/packages/patches/libmad-armv7-thumb-pt1.patch \
gnu/packages/patches/libmad-armv7-thumb-pt2.patch \
gnu/packages/patches/libmad-frame-length.patch \

View File

@ -23,6 +23,7 @@
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (gnu packages)
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt))
@ -67,9 +68,11 @@ in Qt.")
(uri
(string-append "https://github.com/lxde/" name "/archive/"
version ".tar.gz"))
(file-name (string-append name "-" version ".tar.gz")) (sha256
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
"0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))))
"0mbl3qc0yfgfsndqrw8vg8k5irsy0pg2wrad8nwv0aphphd4n7rg"))
(patches (map search-patch '("liblxqt-include.patch")))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f))

View File

@ -0,0 +1,14 @@
Patch to fix build with Qt 5.5, taken from upstream:
https://github.com/lxde/liblxqt/commit/7303ea207de0771d6f450a31ec4a1ce69202869b
diff -u -r liblxqt-0.9.0.orig/lxqtnotification.h liblxqt-0.9.0/lxqtnotification.h
--- liblxqt-0.9.0.orig/lxqtnotification.h 2015-07-27 22:49:05.365166482 +0200
+++ liblxqt-0.9.0/lxqtnotification.h 2015-07-27 22:49:36.897606619 +0200
@@ -25,6 +25,7 @@
#ifndef LXQTNOTIFICATION_H
#define LXQTNOTIFICATION_H
+#include <QObject>
#include <QStringList>
#include "lxqtglobals.h"