gnu: python2-unittest2: Update to 1.1.0.
* gnu/packages/python.scm (python2-unittest2): Update to 1.1.0. * gnu/packages/patches/python2-unittest2-remove-argparse.patch: New file. * gnu/local.mk: Add it.
This commit is contained in:
parent
1898eaa335
commit
4792a0321a
|
@ -994,6 +994,7 @@ dist_patch_DATA = \
|
||||||
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
%D%/packages/patches/python2-pygobject-2-gi-info-type-error-domain.patch \
|
||||||
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
%D%/packages/patches/python-pygpgme-fix-pinentry-tests.patch \
|
||||||
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
%D%/packages/patches/python2-subprocess32-disable-input-test.patch \
|
||||||
|
%D%/packages/patches/python2-unittest2-remove-argparse.patch \
|
||||||
%D%/packages/patches/qt4-ldflags.patch \
|
%D%/packages/patches/qt4-ldflags.patch \
|
||||||
%D%/packages/patches/qtscript-disable-tests.patch \
|
%D%/packages/patches/qtscript-disable-tests.patch \
|
||||||
%D%/packages/patches/quagga-reproducible-build.patch \
|
%D%/packages/patches/quagga-reproducible-build.patch \
|
||||||
|
|
|
@ -0,0 +1,11 @@
|
||||||
|
--- a/setup.py 2017-09-12 01:22:06.273997788 +0200
|
||||||
|
+++ b/setup.py 2017-09-12 01:22:14.297918757 +0200
|
||||||
|
@@ -57,7 +57,7 @@
|
||||||
|
# Both install and setup requires - because we read VERSION from within the
|
||||||
|
# package, and the package also exports all the APIs.
|
||||||
|
# six for compat helpers
|
||||||
|
-REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
|
||||||
|
+REQUIRES = ['six>=1.4', 'traceback2'],
|
||||||
|
|
||||||
|
params = dict(
|
||||||
|
name=NAME,
|
|
@ -1843,7 +1843,7 @@ standard library.")
|
||||||
(define-public python2-unittest2
|
(define-public python2-unittest2
|
||||||
(package (inherit python-unittest2)
|
(package (inherit python-unittest2)
|
||||||
(name "python2-unittest2")
|
(name "python2-unittest2")
|
||||||
(version "0.5.1")
|
(version "1.1.0")
|
||||||
(source
|
(source
|
||||||
(origin
|
(origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
|
@ -1852,7 +1852,12 @@ standard library.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"0wbs4i4x3x7klr3v35ss6p9mcqz883i1xgcpkhvl7n2lyv6yhpda"))))
|
"0y855kmx7a8rnf81d3lh5lyxai1908xjp0laf4glwa4c8472m212"))
|
||||||
|
(patches
|
||||||
|
(search-patches "python2-unittest2-remove-argparse.patch"))))
|
||||||
|
(propagated-inputs
|
||||||
|
`(("python2-six" ,python2-six)
|
||||||
|
("python2-traceback2" ,python2-traceback2)))
|
||||||
(arguments
|
(arguments
|
||||||
`(#:python ,python-2
|
`(#:python ,python-2
|
||||||
#:tests? #f)))) ; no setup.py test command
|
#:tests? #f)))) ; no setup.py test command
|
||||||
|
|
Loading…
Reference in New Issue