gnu: icecat: Apply more libvpx-1.4 fixes.

This is a followup to commit c803ffcb3a.

* gnu/packages/patches/icecat-libvpx-1.4.patch: Augment existing patch to
  include fixes for content/media/encoder/VP8TrackEncoder.cpp.
This commit is contained in:
Mark H Weaver 2015-07-07 02:34:54 -04:00
parent c803ffcb3a
commit 48cfe294b0
1 changed files with 51 additions and 3 deletions

View File

@ -1,8 +1,6 @@
The libvpx package 1.4.0 brings new names for various constants. The libvpx package 1.4.0 brings new names for various constants.
To build against the libvpx some few constants have to be renamed.
Patch by Carsten Schoenert <c.schoenert@t-online.de>. Based on a patch by Carsten Schoenert <c.schoenert@t-online.de>.
Copied from Debian.
--- a/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc --- a/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
+++ b/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc +++ b/media/webrtc/trunk/webrtc/modules/video_coding/codecs/vp8/vp8_impl.cc
@ -28,3 +26,53 @@ Copied from Debian.
// TODO(mikhal): Stride should be set in initialization. // TODO(mikhal): Stride should be set in initialization.
raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane); raw_->stride[VPX_PLANE_Y] = input_image.stride(kYPlane);
raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane); raw_->stride[VPX_PLANE_U] = input_image.stride(kUPlane);
--- a/content/media/encoder/VP8TrackEncoder.cpp
+++ b/content/media/encoder/VP8TrackEncoder.cpp
@@ -84,7 +84,7 @@
// Creating a wrapper to the image - setting image data to NULL. Actual
// pointer will be set in encode. Setting align to 1, as it is meaningless
// (actual memory is not allocated).
- vpx_img_wrap(mVPXImageWrapper, IMG_FMT_I420,
+ vpx_img_wrap(mVPXImageWrapper, VPX_IMG_FMT_I420,
mFrameWidth, mFrameHeight, 1, nullptr);
config.g_w = mFrameWidth;
@@ -239,9 +239,9 @@
uint8_t *cb = mMuteFrame.Elements() + yPlaneSize;
uint8_t *cr = mMuteFrame.Elements() + yPlaneSize + uvPlaneSize;
- mVPXImageWrapper->planes[PLANE_Y] = y;
- mVPXImageWrapper->planes[PLANE_U] = cb;
- mVPXImageWrapper->planes[PLANE_V] = cr;
+ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
+ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
+ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;
@@ -297,9 +297,9 @@
const PlanarYCbCrImage::Data *data = yuv->GetData();
if (isYUV420(data) && !data->mCbSkip) { // 420 planar
- mVPXImageWrapper->planes[PLANE_Y] = data->mYChannel;
- mVPXImageWrapper->planes[PLANE_U] = data->mCbChannel;
- mVPXImageWrapper->planes[PLANE_V] = data->mCrChannel;
+ mVPXImageWrapper->planes[VPX_PLANE_Y] = data->mYChannel;
+ mVPXImageWrapper->planes[VPX_PLANE_U] = data->mCbChannel;
+ mVPXImageWrapper->planes[VPX_PLANE_V] = data->mCrChannel;
mVPXImageWrapper->stride[VPX_PLANE_Y] = data->mYStride;
mVPXImageWrapper->stride[VPX_PLANE_U] = data->mCbCrStride;
mVPXImageWrapper->stride[VPX_PLANE_V] = data->mCbCrStride;
@@ -355,9 +355,9 @@
return NS_ERROR_NOT_IMPLEMENTED;
}
- mVPXImageWrapper->planes[PLANE_Y] = y;
- mVPXImageWrapper->planes[PLANE_U] = cb;
- mVPXImageWrapper->planes[PLANE_V] = cr;
+ mVPXImageWrapper->planes[VPX_PLANE_Y] = y;
+ mVPXImageWrapper->planes[VPX_PLANE_U] = cb;
+ mVPXImageWrapper->planes[VPX_PLANE_V] = cr;
mVPXImageWrapper->stride[VPX_PLANE_Y] = mFrameWidth;
mVPXImageWrapper->stride[VPX_PLANE_U] = halfWidth;
mVPXImageWrapper->stride[VPX_PLANE_V] = halfWidth;