gnu: allegro: Update to 5.2.5.0.
* gnu/packages/game-development.scm (allegro): Update to 5.2.5.0. [source]: Remove patch. * gnu/packages/patches/allegro-mesa-18.2.5-and-later.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
This commit is contained in:
parent
9828859c29
commit
49405aaf5c
|
@ -662,7 +662,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/aegisub-icu59-include-unistr.patch \
|
||||
%D%/packages/patches/aegisub-boost68.patch \
|
||||
%D%/packages/patches/agg-am_c_prototype.patch \
|
||||
%D%/packages/patches/allegro-mesa-18.2.5-and-later.patch \
|
||||
%D%/packages/patches/amule-crypto-6.patch \
|
||||
%D%/packages/patches/antiword-CVE-2014-8123.patch \
|
||||
%D%/packages/patches/antlr3-3_1-fix-java8-compilation.patch \
|
||||
|
|
|
@ -684,19 +684,17 @@ etc.")
|
|||
(define-public allegro
|
||||
(package
|
||||
(name "allegro")
|
||||
(version "5.2.4.0")
|
||||
(version "5.2.5.0")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append "https://github.com/liballeg/allegro5/releases"
|
||||
"/download/" version "/allegro-"
|
||||
version ".tar.gz"))
|
||||
(patches (search-patches
|
||||
"allegro-mesa-18.2.5-and-later.patch"))
|
||||
(sha256
|
||||
(base32
|
||||
"1w9a5yqi5q03b2qvmx5ff90paz0xbr9cy7i7f0xiqa65ava66q9l"))))
|
||||
"06dpkfnac8w3pq36834nn2iij3ajz6prladqd0w92lq39aiqv5jr"))))
|
||||
(build-system cmake-build-system)
|
||||
(arguments `(#:tests? #f)) ; there are no tests
|
||||
(arguments `(#:tests? #f)) ; there are no tests
|
||||
(inputs
|
||||
;; FIXME: Add the following optional inputs: xinput2, opensl, dumb
|
||||
`(("flac" ,flac)
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
Fixes compilation with Mesa >= 18.2.5.
|
||||
|
||||
Taken from upstream:
|
||||
|
||||
https://github.com/liballeg/allegro5/commit/a40d30e21802ecf5c9382cf34af9b01bd3781e47
|
||||
|
||||
diff --git a/include/allegro5/allegro_opengl.h b/include/allegro5/allegro_opengl.h
|
||||
index 0f86a6768..652dd024e 100644
|
||||
--- a/include/allegro5/allegro_opengl.h
|
||||
+++ b/include/allegro5/allegro_opengl.h
|
||||
@@ -103,10 +103,14 @@
|
||||
|
||||
/* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
|
||||
#define __glext_h_
|
||||
+#define __gl_glext_h_
|
||||
#define __glxext_h_
|
||||
+#define __glx_glxext_h_
|
||||
#include <GL/gl.h>
|
||||
#undef __glext_h_
|
||||
+#undef __gl_glext_h_
|
||||
#undef __glxext_h_
|
||||
+#undef __glx_glxext_h_
|
||||
|
||||
#endif /* ALLEGRO_MACOSX */
|
||||
|
||||
diff --git a/include/allegro5/opengl/GLext/glx_ext_defs.h b/include/allegro5/opengl/GLext/glx_ext_defs.h
|
||||
index 49c502091..fba8aea5d 100644
|
||||
--- a/include/allegro5/opengl/GLext/glx_ext_defs.h
|
||||
+++ b/include/allegro5/opengl/GLext/glx_ext_defs.h
|
||||
@@ -1,7 +1,9 @@
|
||||
/* HACK: Prevent both Mesa and SGI's broken headers from screwing us */
|
||||
#define __glxext_h_
|
||||
+#define __glx_glxext_h_
|
||||
#include <GL/glx.h>
|
||||
#undef __glxext_h_
|
||||
+#undef __glx_glxext_h_
|
||||
|
||||
#ifndef GLX_VERSION_1_3
|
||||
#define _ALLEGRO_GLX_VERSION_1_3
|
||||
--
|
||||
2.20.0
|
Loading…
Reference in New Issue