gnu: minetest: Update to 0.4.11.
* gnu/packages/patches/minetest-subgame-env-var.patch: Delete. * gnu-system.am (dist_patch_DATA): Remove patch. * gnu/packages/games.scm (minetest, minetest-data): Update to 0.4.11.
This commit is contained in:
parent
f4e9727786
commit
4b2fd119be
|
@ -415,7 +415,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/mc-fix-ncurses-build.patch \
|
gnu/packages/patches/mc-fix-ncurses-build.patch \
|
||||||
gnu/packages/patches/mcron-install.patch \
|
gnu/packages/patches/mcron-install.patch \
|
||||||
gnu/packages/patches/mhash-keygen-test-segfault.patch \
|
gnu/packages/patches/mhash-keygen-test-segfault.patch \
|
||||||
gnu/packages/patches/minetest-subgame-env-var.patch \
|
|
||||||
gnu/packages/patches/mit-krb5-init-fix.patch \
|
gnu/packages/patches/mit-krb5-init-fix.patch \
|
||||||
gnu/packages/patches/mpc123-initialize-ao.patch \
|
gnu/packages/patches/mpc123-initialize-ao.patch \
|
||||||
gnu/packages/patches/module-init-tools-moduledir.patch \
|
gnu/packages/patches/module-init-tools-moduledir.patch \
|
||||||
|
|
|
@ -638,7 +638,7 @@ for common mesh file formats, and collision detection.")
|
||||||
(define minetest-data
|
(define minetest-data
|
||||||
(package
|
(package
|
||||||
(name "minetest-data")
|
(name "minetest-data")
|
||||||
(version "0.4.10")
|
(version "0.4.11")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
|
@ -646,7 +646,7 @@ for common mesh file formats, and collision detection.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"09mr71kl7mf4ihszqz1vnwk814p7fvqknad150iic2340a7qzf0i"))))
|
"0hzb27srv6f2j84dpxx2p0p0aaq9vdp5jvbrfpklb5q5ssdjxvc6"))))
|
||||||
(build-system trivial-build-system)
|
(build-system trivial-build-system)
|
||||||
(native-inputs
|
(native-inputs
|
||||||
`(("source" ,source)
|
`(("source" ,source)
|
||||||
|
@ -678,7 +678,7 @@ for common mesh file formats, and collision detection.")
|
||||||
(define-public minetest
|
(define-public minetest
|
||||||
(package
|
(package
|
||||||
(name "minetest")
|
(name "minetest")
|
||||||
(version "0.4.10")
|
(version "0.4.11")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append
|
(uri (string-append
|
||||||
|
@ -686,10 +686,7 @@ for common mesh file formats, and collision detection.")
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"1xxv0g83iqszjgwnbdcbsprqg76cb6jnbsh5qhm7lcwx4wy2y2k2"))
|
"0h223svzkvp63b77nqfxy7k8whw4543gahs3kxd3x4myi5ax5z5f"))))
|
||||||
;; This patch will be included in future upstream releases.
|
|
||||||
;; See: https://github.com/minetest/minetest/commit/fd5eaae2babb322f8a3e2acab55a12e218814c8e
|
|
||||||
(patches (list (search-patch "minetest-subgame-env-var.patch")))))
|
|
||||||
(build-system cmake-build-system)
|
(build-system cmake-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:modules ((guix build utils)
|
'(#:modules ((guix build utils)
|
||||||
|
|
|
@ -1,92 +0,0 @@
|
||||||
From fd5eaae2babb322f8a3e2acab55a12e218814c8e Mon Sep 17 00:00:00 2001
|
|
||||||
From: David Thompson <dthompson2@worcester.edu>
|
|
||||||
Date: Sat, 6 Sep 2014 13:21:46 -0400
|
|
||||||
Subject: [PATCH] Search for subgames using $MINETEST_SUBGAME_PATH.
|
|
||||||
|
|
||||||
---
|
|
||||||
doc/minetest.6 | 6 ++++++
|
|
||||||
src/subgame.cpp | 30 ++++++++++++++++++++++++++++++
|
|
||||||
2 files changed, 36 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/doc/minetest.6 b/doc/minetest.6
|
|
||||||
index d94c12c..ff54520 100644
|
|
||||||
--- a/doc/minetest.6
|
|
||||||
+++ b/doc/minetest.6
|
|
||||||
@@ -83,6 +83,12 @@ Set world path
|
|
||||||
Migrate from current map backend to another. Possible values are sqlite3
|
|
||||||
and leveldb. Only works when using --server.
|
|
||||||
|
|
||||||
+.SH ENVIRONMENT VARIABLES
|
|
||||||
+
|
|
||||||
+.TP
|
|
||||||
+MINETEST_SUBGAME_PATH
|
|
||||||
+Colon delimited list of directories to search for subgames.
|
|
||||||
+
|
|
||||||
.SH BUGS
|
|
||||||
Please report all bugs to Perttu Ahola <celeron55@gmail.com>.
|
|
||||||
|
|
||||||
diff --git a/src/subgame.cpp b/src/subgame.cpp
|
|
||||||
index f2465c9..e86655b 100644
|
|
||||||
--- a/src/subgame.cpp
|
|
||||||
+++ b/src/subgame.cpp
|
|
||||||
@@ -22,6 +22,7 @@ with this program; if not, write to the Free Software Foundation, Inc.,
|
|
||||||
#include "filesys.h"
|
|
||||||
#include "settings.h"
|
|
||||||
#include "log.h"
|
|
||||||
+#include "strfnd.h"
|
|
||||||
#ifndef SERVER
|
|
||||||
#include "tile.h" // getImagePath
|
|
||||||
#endif
|
|
||||||
@@ -59,6 +60,17 @@ struct GameFindPath
|
|
||||||
{}
|
|
||||||
};
|
|
||||||
|
|
||||||
+Strfnd getSubgamePathEnv() {
|
|
||||||
+ std::string sp;
|
|
||||||
+ char *subgame_path = getenv("MINETEST_SUBGAME_PATH");
|
|
||||||
+
|
|
||||||
+ if(subgame_path) {
|
|
||||||
+ sp = std::string(subgame_path);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return Strfnd(sp);
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
SubgameSpec findSubgame(const std::string &id)
|
|
||||||
{
|
|
||||||
if(id == "")
|
|
||||||
@@ -66,6 +78,17 @@ SubgameSpec findSubgame(const std::string &id)
|
|
||||||
std::string share = porting::path_share;
|
|
||||||
std::string user = porting::path_user;
|
|
||||||
std::vector<GameFindPath> find_paths;
|
|
||||||
+
|
|
||||||
+ Strfnd search_paths = getSubgamePathEnv();
|
|
||||||
+
|
|
||||||
+ while(!search_paths.atend()) {
|
|
||||||
+ std::string path = search_paths.next(":");
|
|
||||||
+ find_paths.push_back(GameFindPath(
|
|
||||||
+ path + DIR_DELIM + id, false));
|
|
||||||
+ find_paths.push_back(GameFindPath(
|
|
||||||
+ path + DIR_DELIM + id + "_game", false));
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
find_paths.push_back(GameFindPath(
|
|
||||||
user + DIR_DELIM + "games" + DIR_DELIM + id + "_game", true));
|
|
||||||
find_paths.push_back(GameFindPath(
|
|
||||||
@@ -129,6 +152,13 @@ std::set<std::string> getAvailableGameIds()
|
|
||||||
std::set<std::string> gamespaths;
|
|
||||||
gamespaths.insert(porting::path_share + DIR_DELIM + "games");
|
|
||||||
gamespaths.insert(porting::path_user + DIR_DELIM + "games");
|
|
||||||
+
|
|
||||||
+ Strfnd search_paths = getSubgamePathEnv();
|
|
||||||
+
|
|
||||||
+ while(!search_paths.atend()) {
|
|
||||||
+ gamespaths.insert(search_paths.next(":"));
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
for(std::set<std::string>::const_iterator i = gamespaths.begin();
|
|
||||||
i != gamespaths.end(); i++){
|
|
||||||
std::vector<fs::DirListNode> dirlist = fs::GetDirListing(*i);
|
|
||||||
--
|
|
||||||
2.1.1
|
|
||||||
|
|
Loading…
Reference in New Issue