gnu: python: Disable ssl test that fails with openssl-1.0.2b.

* gnu/packages/patches/python-disable-ssl-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/python.scm (python): Add patch.
master
Mark H Weaver 2015-06-12 03:24:12 -04:00
parent 8c01b9d05a
commit 4c50e5ab3a
3 changed files with 16 additions and 1 deletions

View File

@ -526,6 +526,7 @@ dist_patch_DATA = \
gnu/packages/patches/pybugz-encode-error.patch \
gnu/packages/patches/pybugz-stty.patch \
gnu/packages/patches/pyqt-configure.patch \
gnu/packages/patches/python-disable-ssl-test.patch \
gnu/packages/patches/python-fix-tests.patch \
gnu/packages/patches/python-libffi-mips-n32-fix.patch \
gnu/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \

View File

@ -0,0 +1,12 @@
Disable a test that fails with openssl-1.0.2b.
--- Lib/test/test_ssl.py.orig 2015-02-25 06:27:45.000000000 -0500
+++ Lib/test/test_ssl.py 2015-06-12 03:14:09.395212502 -0400
@@ -2718,6 +2718,7 @@
chatty=True, connectionchatty=True)
self.assertIs(stats['compression'], None)
+ @unittest.skipIf(True, "openssl 1.0.2b complains: dh key too small")
def test_dh_params(self):
# Check we can get a connection with ephemeral Diffie-Hellman
context = ssl.SSLContext(ssl.PROTOCOL_TLSv1)

View File

@ -207,7 +207,9 @@ data types.")
(method url-fetch)
(uri (string-append "https://www.python.org/ftp/python/"
version "/Python-" version ".tar.xz"))
(patches (list (search-patch "python-fix-tests.patch")))
(patches (list (search-patch "python-fix-tests.patch")
;; XXX Try removing this patch for python > 3.4.3
(search-patch "python-disable-ssl-test.patch")))
(patch-flags '("-p0"))
(sha256
(base32