gnu: perl: Update to 5.22.0.
* gnu/packages/perl.scm (perl)[source]: Update to 5.22.0. Remove "perl-module-pluggable-search.patch" since Module::Pluggable appears to be gone. [arguments] <configure-phase>: Adjust Cwd.pm file name. Replace -std=c89 with -std=gnu89. * gnu/packages/commencement.scm (perl-boot0): Add 'disable-pthreads' phase. * gnu/packages/patches/perl-no-sys-dirs.patch: Update. * gnu/packages/patches/perl-module-pluggable-search.patch: Remove. * gnu-system.am (dist_patch_DATA): Adjust accordingly.
This commit is contained in:
parent
4165fda29d
commit
4de3507483
|
@ -617,7 +617,6 @@ dist_patch_DATA = \
|
||||||
gnu/packages/patches/perl-autosplit-default-time.patch \
|
gnu/packages/patches/perl-autosplit-default-time.patch \
|
||||||
gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
gnu/packages/patches/perl-finance-quote-unuse-mozilla-ca.patch \
|
||||||
gnu/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
|
gnu/packages/patches/perl-gd-options-passthrough-and-fontconfig.patch \
|
||||||
gnu/packages/patches/perl-module-pluggable-search.patch \
|
|
||||||
gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch \
|
||||||
gnu/packages/patches/perl-net-ssleay-disable-ede-test.patch \
|
gnu/packages/patches/perl-net-ssleay-disable-ede-test.patch \
|
||||||
gnu/packages/patches/perl-no-sys-dirs.patch \
|
gnu/packages/patches/perl-no-sys-dirs.patch \
|
||||||
|
|
|
@ -260,11 +260,24 @@
|
||||||
(package-native-inputs gcc))))))
|
(package-native-inputs gcc))))))
|
||||||
|
|
||||||
(define perl-boot0
|
(define perl-boot0
|
||||||
|
(let ((perl (package
|
||||||
|
(inherit perl)
|
||||||
|
(arguments
|
||||||
|
(substitute-keyword-arguments (package-arguments perl)
|
||||||
|
((#:phases phases)
|
||||||
|
`(modify-phases ,phases
|
||||||
|
;; Pthread support is missing in the bootstrap compiler
|
||||||
|
;; (broken spec file), so disable it.
|
||||||
|
(add-before 'configure 'disable-pthreads
|
||||||
|
(lambda _
|
||||||
|
(substitute* "Configure"
|
||||||
|
(("^libswanted=(.*)pthread" _ before)
|
||||||
|
(string-append "libswanted=" before))))))))))))
|
||||||
(package-with-bootstrap-guile
|
(package-with-bootstrap-guile
|
||||||
(package-with-explicit-inputs perl
|
(package-with-explicit-inputs perl
|
||||||
%boot0-inputs
|
%boot0-inputs
|
||||||
(current-source-location)
|
(current-source-location)
|
||||||
#:guile %bootstrap-guile)))
|
#:guile %bootstrap-guile))))
|
||||||
|
|
||||||
(define (linux-libre-headers-boot0)
|
(define (linux-libre-headers-boot0)
|
||||||
"Return Linux-Libre header files for the bootstrap environment."
|
"Return Linux-Libre header files for the bootstrap environment."
|
||||||
|
|
|
@ -1,25 +0,0 @@
|
||||||
Fix core Perl module Module::Pluggable such that it can find plugins that live
|
|
||||||
in symlinked directories.
|
|
||||||
|
|
||||||
Patch borrowed/adapted from Nixpkgs.
|
|
||||||
|
|
||||||
--- perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:28:48.120164135 -0500
|
|
||||||
+++ perl-5.16.1/cpan/Module-Pluggable/lib/Module/Pluggable/Object.pm 2015-04-08 23:30:27.032166704 -0500
|
|
||||||
@@ -164,7 +164,7 @@
|
|
||||||
my $sp = catdir($dir, (split /::/, $searchpath));
|
|
||||||
|
|
||||||
# if it doesn't exist or it's not a dir then skip it
|
|
||||||
- next unless ( -e $sp && -d _ ); # Use the cached stat the second time
|
|
||||||
+ next unless ( -e $sp );
|
|
||||||
|
|
||||||
my @files = $self->find_files($sp);
|
|
||||||
|
|
||||||
@@ -279,7 +279,7 @@
|
|
||||||
(my $path = $File::Find::name) =~ s#^\\./##;
|
|
||||||
push @files, $path;
|
|
||||||
}
|
|
||||||
- }, $search_path );
|
|
||||||
+ }, "$search_path/." );
|
|
||||||
}
|
|
||||||
#chdir $cwd;
|
|
||||||
return @files;
|
|
|
@ -1,10 +1,10 @@
|
||||||
Don't long for headers and libraries in "traditional" locations.
|
Don't look for headers and libraries in "traditional" locations.
|
||||||
|
|
||||||
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
|
Patch from Nixpkgs by Eelco Dolstra <eelco.dolstra@logicblox.com>.
|
||||||
|
|
||||||
diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/Configure perl-5.20.0/Configure
|
||||||
--- perl-5.14.2-orig/Configure 2011-09-26 11:44:34.000000000 +0200
|
--- perl-5.20.0-orig/Configure 2014-05-26 15:34:18.000000000 +0200
|
||||||
+++ perl-5.14.2/Configure 2012-01-20 17:05:23.089223129 +0100
|
+++ perl-5.20.0/Configure 2014-06-25 10:43:35.368285986 +0200
|
||||||
@@ -106,15 +106,7 @@
|
@@ -106,15 +106,7 @@
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
@ -22,7 +22,7 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
|
|
||||||
for p in $paths
|
for p in $paths
|
||||||
do
|
do
|
||||||
@@ -1311,8 +1303,7 @@
|
@@ -1337,8 +1329,7 @@
|
||||||
archname=''
|
archname=''
|
||||||
: Possible local include directories to search.
|
: Possible local include directories to search.
|
||||||
: Set locincpth to "" in a hint file to defeat local include searches.
|
: Set locincpth to "" in a hint file to defeat local include searches.
|
||||||
|
@ -32,8 +32,8 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
:
|
:
|
||||||
: no include file wanted by default
|
: no include file wanted by default
|
||||||
inclwanted=''
|
inclwanted=''
|
||||||
@@ -1328,17 +1319,12 @@
|
@@ -1349,17 +1340,12 @@
|
||||||
archobjs=''
|
|
||||||
libnames=''
|
libnames=''
|
||||||
: change the next line if compiling for Xenix/286 on Xenix/386
|
: change the next line if compiling for Xenix/286 on Xenix/386
|
||||||
-xlibpth='/usr/lib/386 /lib/386'
|
-xlibpth='/usr/lib/386 /lib/386'
|
||||||
|
@ -53,7 +53,7 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
|
|
||||||
: Private path used by Configure to find libraries. Its value
|
: Private path used by Configure to find libraries. Its value
|
||||||
: is prepended to libpth. This variable takes care of special
|
: is prepended to libpth. This variable takes care of special
|
||||||
@@ -1371,8 +1357,6 @@
|
@@ -1391,8 +1377,6 @@
|
||||||
libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
|
libswanted="$libswanted m crypt sec util c cposix posix ucb bsd BSD"
|
||||||
: We probably want to search /usr/shlib before most other libraries.
|
: We probably want to search /usr/shlib before most other libraries.
|
||||||
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
: This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
|
||||||
|
@ -62,24 +62,24 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
: Do not use vfork unless overridden by a hint file.
|
: Do not use vfork unless overridden by a hint file.
|
||||||
usevfork=false
|
usevfork=false
|
||||||
|
|
||||||
@@ -2380,7 +2364,6 @@
|
@@ -2446,7 +2430,6 @@
|
||||||
zip
|
zip
|
||||||
"
|
"
|
||||||
pth=`echo $PATH | sed -e "s/$p_/ /g"`
|
pth=`echo $PATH | sed -e "s/$p_/ /g"`
|
||||||
-pth="$pth /lib /usr/lib"
|
-pth="$pth $sysroot/lib $sysroot/usr/lib"
|
||||||
for file in $loclist; do
|
for file in $loclist; do
|
||||||
eval xxx=\$$file
|
eval xxx=\$$file
|
||||||
case "$xxx" in
|
case "$xxx" in
|
||||||
@@ -4785,7 +4768,7 @@
|
@@ -4936,7 +4919,7 @@
|
||||||
: Set private lib path
|
: Set private lib path
|
||||||
case "$plibpth" in
|
case "$plibpth" in
|
||||||
'') if ./mips; then
|
'') if ./mips; then
|
||||||
- plibpth="$incpath/usr/lib /usr/local/lib /usr/ccs/lib"
|
- plibpth="$incpath/usr/lib $sysroot/usr/local/lib $sysroot/usr/ccs/lib"
|
||||||
+ plibpth="$incpath/usr/lib"
|
+ plibpth="$incpath/usr/lib"
|
||||||
fi;;
|
fi;;
|
||||||
esac
|
esac
|
||||||
case "$libpth" in
|
case "$libpth" in
|
||||||
@@ -8390,13 +8373,8 @@
|
@@ -8600,13 +8583,8 @@
|
||||||
echo " "
|
echo " "
|
||||||
case "$sysman" in
|
case "$sysman" in
|
||||||
'')
|
'')
|
||||||
|
@ -95,7 +95,7 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
;;
|
;;
|
||||||
esac
|
esac
|
||||||
if $test -d "$sysman"; then
|
if $test -d "$sysman"; then
|
||||||
@@ -19721,9 +19699,10 @@
|
@@ -19900,9 +19878,10 @@
|
||||||
case "$full_ar" in
|
case "$full_ar" in
|
||||||
'') full_ar=$ar ;;
|
'') full_ar=$ar ;;
|
||||||
esac
|
esac
|
||||||
|
@ -107,10 +107,11 @@ diff -ru -x '*~' perl-5.14.2-orig/Configure perl-5.14.2/Configure
|
||||||
|
|
||||||
: see what type gids are declared as in the kernel
|
: see what type gids are declared as in the kernel
|
||||||
echo " "
|
echo " "
|
||||||
diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Errno_pm.PL
|
Only in perl-5.20.0/: Configure.orig
|
||||||
--- perl-5.14.2-orig/ext/Errno/Errno_pm.PL 2011-09-26 11:44:34.000000000 +0200
|
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/ext/Errno/Errno_pm.PL perl-5.20.0/ext/Errno/Errno_pm.PL
|
||||||
+++ perl-5.14.2/ext/Errno/Errno_pm.PL 2012-01-20 17:02:07.938138311 +0100
|
--- perl-5.20.0-orig/ext/Errno/Errno_pm.PL 2014-05-26 15:34:20.000000000 +0200
|
||||||
@@ -137,11 +137,7 @@
|
+++ perl-5.20.0/ext/Errno/Errno_pm.PL 2014-06-25 10:31:24.317970047 +0200
|
||||||
|
@@ -126,11 +126,7 @@
|
||||||
if ($dep =~ /(\S+errno\.h)/) {
|
if ($dep =~ /(\S+errno\.h)/) {
|
||||||
$file{$1} = 1;
|
$file{$1} = 1;
|
||||||
}
|
}
|
||||||
|
@ -120,13 +121,14 @@ diff -ru -x '*~' perl-5.14.2-orig/ext/Errno/Errno_pm.PL perl-5.14.2/ext/Errno/Er
|
||||||
- # might be using, say, Intel's icc
|
- # might be using, say, Intel's icc
|
||||||
- ) {
|
- ) {
|
||||||
+ } elsif (0) {
|
+ } elsif (0) {
|
||||||
|
# When cross-compiling we may store a path for gcc's "sysroot" option:
|
||||||
|
my $sysroot = $Config{sysroot} || '';
|
||||||
# Some Linuxes have weird errno.hs which generate
|
# Some Linuxes have weird errno.hs which generate
|
||||||
# no #file or #line directives
|
Only in perl-5.20.0/ext/Errno: Errno_pm.PL.orig
|
||||||
my $linux_errno_h = -e '/usr/include/errno.h' ?
|
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/hints/freebsd.sh perl-5.20.0/hints/freebsd.sh
|
||||||
diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
|
--- perl-5.20.0-orig/hints/freebsd.sh 2014-01-31 22:55:51.000000000 +0100
|
||||||
--- perl-5.14.2-orig/hints/freebsd.sh 2011-09-19 15:18:22.000000000 +0200
|
+++ perl-5.20.0/hints/freebsd.sh 2014-06-25 10:25:53.263964680 +0200
|
||||||
+++ perl-5.14.2/hints/freebsd.sh 2012-01-20 17:10:37.267924044 +0100
|
@@ -119,21 +119,21 @@
|
||||||
@@ -118,21 +118,21 @@
|
|
||||||
objformat=`/usr/bin/objformat`
|
objformat=`/usr/bin/objformat`
|
||||||
if [ x$objformat = xaout ]; then
|
if [ x$objformat = xaout ]; then
|
||||||
if [ -e /usr/lib/aout ]; then
|
if [ -e /usr/lib/aout ]; then
|
||||||
|
@ -154,3 +156,99 @@ diff -ru -x '*~' perl-5.14.2-orig/hints/freebsd.sh perl-5.14.2/hints/freebsd.sh
|
||||||
ldflags="-Wl,-E "
|
ldflags="-Wl,-E "
|
||||||
lddlflags="-shared "
|
lddlflags="-shared "
|
||||||
cccdlflags='-DPIC -fPIC'
|
cccdlflags='-DPIC -fPIC'
|
||||||
|
diff -ru -x '*~' -x '*.rej' perl-5.20.0-orig/hints/linux.sh perl-5.20.0/hints/linux.sh
|
||||||
|
--- perl-5.20.0-orig/hints/linux.sh 2014-05-26 15:34:20.000000000 +0200
|
||||||
|
+++ perl-5.20.0/hints/linux.sh 2014-06-25 10:33:47.354883843 +0200
|
||||||
|
@@ -150,25 +150,6 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
-# Ubuntu 11.04 (and later, presumably) doesn't keep most libraries
|
||||||
|
-# (such as -lm) in /lib or /usr/lib. So we have to ask gcc to tell us
|
||||||
|
-# where to look. We don't want gcc's own libraries, however, so we
|
||||||
|
-# filter those out.
|
||||||
|
-# This could be conditional on Unbuntu, but other distributions may
|
||||||
|
-# follow suit, and this scheme seems to work even on rather old gcc's.
|
||||||
|
-# This unconditionally uses gcc because even if the user is using another
|
||||||
|
-# compiler, we still need to find the math library and friends, and I don't
|
||||||
|
-# know how other compilers will cope with that situation.
|
||||||
|
-# Morever, if the user has their own gcc earlier in $PATH than the system gcc,
|
||||||
|
-# we don't want its libraries. So we try to prefer the system gcc
|
||||||
|
-# Still, as an escape hatch, allow Configure command line overrides to
|
||||||
|
-# plibpth to bypass this check.
|
||||||
|
-if [ -x /usr/bin/gcc ] ; then
|
||||||
|
- gcc=/usr/bin/gcc
|
||||||
|
-else
|
||||||
|
- gcc=gcc
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
case "$plibpth" in
|
||||||
|
'') plibpth=`LANG=C LC_ALL=C $gcc $ccflags $ldflags -print-search-dirs | grep libraries |
|
||||||
|
cut -f2- -d= | tr ':' $trnl | grep -v 'gcc' | sed -e 's:/$::'`
|
||||||
|
@@ -178,32 +159,6 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
-case "$libc" in
|
||||||
|
-'')
|
||||||
|
-# If you have glibc, then report the version for ./myconfig bug reporting.
|
||||||
|
-# (Configure doesn't need to know the specific version since it just uses
|
||||||
|
-# gcc to load the library for all tests.)
|
||||||
|
-# We don't use __GLIBC__ and __GLIBC_MINOR__ because they
|
||||||
|
-# are insufficiently precise to distinguish things like
|
||||||
|
-# libc-2.0.6 and libc-2.0.7.
|
||||||
|
- for p in $plibpth
|
||||||
|
- do
|
||||||
|
- for trylib in libc.so.6 libc.so
|
||||||
|
- do
|
||||||
|
- if $test -e $p/$trylib; then
|
||||||
|
- libc=`ls -l $p/$trylib | awk '{print $NF}'`
|
||||||
|
- if $test "X$libc" != X; then
|
||||||
|
- break
|
||||||
|
- fi
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
- if $test "X$libc" != X; then
|
||||||
|
- break
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
- ;;
|
||||||
|
-esac
|
||||||
|
-
|
||||||
|
# Are we using ELF? Thanks to Kenneth Albanowski <kjahds@kjahds.com>
|
||||||
|
# for this test.
|
||||||
|
cat >try.c <<'EOM'
|
||||||
|
@@ -367,33 +322,6 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
-# SuSE8.2 has /usr/lib/libndbm* which are ld scripts rather than
|
||||||
|
-# true libraries. The scripts cause binding against static
|
||||||
|
-# version of -lgdbm which is a bad idea. So if we have 'nm'
|
||||||
|
-# make sure it can read the file
|
||||||
|
-# NI-S 2003/08/07
|
||||||
|
-case "$nm" in
|
||||||
|
- '') ;;
|
||||||
|
- *)
|
||||||
|
- for p in $plibpth
|
||||||
|
- do
|
||||||
|
- if $test -r $p/libndbm.so; then
|
||||||
|
- if $nm $p/libndbm.so >/dev/null 2>&1 ; then
|
||||||
|
- echo 'Your shared -lndbm seems to be a real library.'
|
||||||
|
- _libndbm_real=1
|
||||||
|
- break
|
||||||
|
- fi
|
||||||
|
- fi
|
||||||
|
- done
|
||||||
|
- if $test "X$_libndbm_real" = X; then
|
||||||
|
- echo 'Your shared -lndbm is not a real library.'
|
||||||
|
- set `echo X "$libswanted "| sed -e 's/ ndbm / /'`
|
||||||
|
- shift
|
||||||
|
- libswanted="$*"
|
||||||
|
- fi
|
||||||
|
- ;;
|
||||||
|
-esac
|
||||||
|
-
|
||||||
|
# Linux on Synology.
|
||||||
|
if [ -f /etc/synoinfo.conf -a -d /usr/syno ]; then
|
||||||
|
# Tested on Synology DS213 and DS413
|
||||||
|
|
|
@ -1,5 +1,5 @@
|
||||||
;;; GNU Guix --- Functional package management for GNU
|
;;; GNU Guix --- Functional package management for GNU
|
||||||
;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
|
;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
|
||||||
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
||||||
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
|
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
|
||||||
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
|
;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
|
||||||
|
@ -37,18 +37,17 @@
|
||||||
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
|
;; Yeah, Perl... It is required early in the bootstrap process by Linux.
|
||||||
(package
|
(package
|
||||||
(name "perl")
|
(name "perl")
|
||||||
(version "5.16.1")
|
(version "5.22.0")
|
||||||
(source (origin
|
(source (origin
|
||||||
(method url-fetch)
|
(method url-fetch)
|
||||||
(uri (string-append "http://www.cpan.org/src/5.0/perl-"
|
(uri (string-append "http://www.cpan.org/src/5.0/perl-"
|
||||||
version ".tar.gz"))
|
version ".tar.gz"))
|
||||||
(sha256
|
(sha256
|
||||||
(base32
|
(base32
|
||||||
"15qxzba3a50c9nik5ydgyfp62x7h9vxxn12yd1jgl93hb1wj96km"))
|
"0g5bl8sdpzx9gx2g5jq3py4bj07z2ylk7s1qn0fvsss2yl3hhs8c"))
|
||||||
(patches (map search-patch
|
(patches (map search-patch
|
||||||
'("perl-no-sys-dirs.patch"
|
'("perl-no-sys-dirs.patch"
|
||||||
"perl-autosplit-default-time.patch"
|
"perl-autosplit-default-time.patch")))))
|
||||||
"perl-module-pluggable-search.patch")))))
|
|
||||||
(build-system gnu-build-system)
|
(build-system gnu-build-system)
|
||||||
(arguments
|
(arguments
|
||||||
'(#:tests? #f
|
'(#:tests? #f
|
||||||
|
@ -60,10 +59,16 @@
|
||||||
(let ((out (assoc-ref outputs "out"))
|
(let ((out (assoc-ref outputs "out"))
|
||||||
(libc (assoc-ref inputs "libc")))
|
(libc (assoc-ref inputs "libc")))
|
||||||
;; Use the right path for `pwd'.
|
;; Use the right path for `pwd'.
|
||||||
(substitute* "dist/Cwd/Cwd.pm"
|
(substitute* "dist/PathTools/Cwd.pm"
|
||||||
(("/bin/pwd")
|
(("/bin/pwd")
|
||||||
(which "pwd")))
|
(which "pwd")))
|
||||||
|
|
||||||
|
;; Build in GNU89 mode to tolerate C++-style comment in libc's
|
||||||
|
;; <bits/string3.h>.
|
||||||
|
(substitute* "cflags.SH"
|
||||||
|
(("-std=c89")
|
||||||
|
"-std=gnu89"))
|
||||||
|
|
||||||
(zero?
|
(zero?
|
||||||
(system* "./Configure"
|
(system* "./Configure"
|
||||||
(string-append "-Dprefix=" out)
|
(string-append "-Dprefix=" out)
|
||||||
|
|
Loading…
Reference in New Issue