gnu: icu4c: Update to 60.1.
* gnu/packages/icu4c.scm (icu4c): Update to 60.1. [source]: Remove patches. * gnu/packages/patches/icu4c-CVE-2017-14952.patch, gnu/packages/patches/icu4c-CVE-2017-7867-CVE-2017-7868.patch, icu4c-reset-keyword-list-iterator.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
This commit is contained in:
parent
e5e33f90bc
commit
4e080fbb0b
|
@ -732,9 +732,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/hurd-fix-eth-multiplexer-dependency.patch \
|
||||
%D%/packages/patches/hydra-disable-darcs-test.patch \
|
||||
%D%/packages/patches/icecat-avoid-bundled-libraries.patch \
|
||||
%D%/packages/patches/icu4c-CVE-2017-7867-CVE-2017-7868.patch \
|
||||
%D%/packages/patches/icu4c-CVE-2017-14952.patch \
|
||||
%D%/packages/patches/icu4c-reset-keyword-list-iterator.patch \
|
||||
%D%/packages/patches/id3lib-CVE-2007-4460.patch \
|
||||
%D%/packages/patches/ilmbase-fix-tests.patch \
|
||||
%D%/packages/patches/intltool-perl-compatibility.patch \
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
;;; GNU Guix --- Functional package management for GNU
|
||||
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
|
||||
;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
|
||||
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
|
||||
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
|
||||
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
|
||||
;;;
|
||||
|
@ -32,7 +32,7 @@
|
|||
(define-public icu4c
|
||||
(package
|
||||
(name "icu4c")
|
||||
(version "58.2")
|
||||
(version "60.1")
|
||||
(source (origin
|
||||
(method url-fetch)
|
||||
(uri (string-append
|
||||
|
@ -41,12 +41,8 @@
|
|||
"/icu4c-"
|
||||
(string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
|
||||
"-src.tgz"))
|
||||
(patches
|
||||
(search-patches "icu4c-CVE-2017-7867-CVE-2017-7868.patch"
|
||||
"icu4c-CVE-2017-14952.patch"
|
||||
"icu4c-reset-keyword-list-iterator.patch"))
|
||||
(sha256
|
||||
(base32 "036shcb3f8bm1lynhlsb4kpjm9s9c2vdiir01vg216rs2l8482ib"))))
|
||||
(base32 "09g2bvmmww8qs9p8p47avzazbibx8yqvswkr8rd02b7kzg4adxgq"))))
|
||||
(build-system gnu-build-system)
|
||||
(inputs
|
||||
`(("perl" ,perl)))
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
Fix CVE-2017-14952:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-14952
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
http://bugs.icu-project.org/trac/changeset/40324/trunk/icu4c/source/i18n/zonemeta.cpp#file0
|
||||
|
||||
Index: trunk/icu4c/source/i18n/zonemeta.cpp
|
||||
===================================================================
|
||||
--- icu/source/i18n/zonemeta.cpp (revision 40283)
|
||||
+++ icu/source/i18n/zonemeta.cpp (revision 40324)
|
||||
@@ -691,5 +691,4 @@
|
||||
if (U_FAILURE(status)) {
|
||||
delete mzMappings;
|
||||
- deleteOlsonToMetaMappingEntry(entry);
|
||||
uprv_free(entry);
|
||||
break;
|
|
@ -1,164 +0,0 @@
|
|||
Fix CVE-2017-7867 and CVE-2017-7868:
|
||||
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7867
|
||||
https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-7868
|
||||
|
||||
Patch copied from upstream source repository:
|
||||
|
||||
http://bugs.icu-project.org/trac/changeset/39671
|
||||
|
||||
Index: icu/source/common/utext.cpp
|
||||
===================================================================
|
||||
--- icu/source/common/utext.cpp (revision 39670)
|
||||
+++ icu/source/common/utext.cpp (revision 39671)
|
||||
@@ -848,7 +848,13 @@
|
||||
|
||||
// Chunk size.
|
||||
-// Must be less than 85, because of byte mapping from UChar indexes to native indexes.
|
||||
-// Worst case is three native bytes to one UChar. (Supplemenaries are 4 native bytes
|
||||
-// to two UChars.)
|
||||
+// Must be less than 42 (256/6), because of byte mapping from UChar indexes to native indexes.
|
||||
+// Worst case there are six UTF-8 bytes per UChar.
|
||||
+// obsolete 6 byte form fd + 5 trails maps to fffd
|
||||
+// obsolete 5 byte form fc + 4 trails maps to fffd
|
||||
+// non-shortest 4 byte forms maps to fffd
|
||||
+// normal supplementaries map to a pair of utf-16, two utf8 bytes per utf-16 unit
|
||||
+// mapToUChars array size must allow for the worst case, 6.
|
||||
+// This could be brought down to 4, by treating fd and fc as pure illegal,
|
||||
+// rather than obsolete lead bytes. But that is not compatible with the utf-8 access macros.
|
||||
//
|
||||
enum { UTF8_TEXT_CHUNK_SIZE=32 };
|
||||
@@ -890,5 +896,5 @@
|
||||
// one for a supplementary starting in the last normal position,
|
||||
// and one for an entry for the buffer limit position.
|
||||
- uint8_t mapToUChars[UTF8_TEXT_CHUNK_SIZE*3+6]; // Map native offset from bufNativeStart to
|
||||
+ uint8_t mapToUChars[UTF8_TEXT_CHUNK_SIZE*6+6]; // Map native offset from bufNativeStart to
|
||||
// correspoding offset in filled part of buf.
|
||||
int32_t align;
|
||||
@@ -1033,4 +1039,5 @@
|
||||
u8b = (UTF8Buf *)ut->p; // the current buffer
|
||||
mapIndex = ix - u8b->toUCharsMapStart;
|
||||
+ U_ASSERT(mapIndex < (int32_t)sizeof(UTF8Buf::mapToUChars));
|
||||
ut->chunkOffset = u8b->mapToUChars[mapIndex] - u8b->bufStartIdx;
|
||||
return TRUE;
|
||||
@@ -1299,4 +1306,8 @@
|
||||
// If index is at the end, there is no character there to look at.
|
||||
if (ix != ut->b) {
|
||||
+ // Note: this function will only move the index back if it is on a trail byte
|
||||
+ // and there is a preceding lead byte and the sequence from the lead
|
||||
+ // through this trail could be part of a valid UTF-8 sequence
|
||||
+ // Otherwise the index remains unchanged.
|
||||
U8_SET_CP_START(s8, 0, ix);
|
||||
}
|
||||
@@ -1312,5 +1323,8 @@
|
||||
uint8_t *mapToNative = u8b->mapToNative;
|
||||
uint8_t *mapToUChars = u8b->mapToUChars;
|
||||
- int32_t toUCharsMapStart = ix - (UTF8_TEXT_CHUNK_SIZE*3 + 1);
|
||||
+ int32_t toUCharsMapStart = ix - sizeof(UTF8Buf::mapToUChars) + 1;
|
||||
+ // Note that toUCharsMapStart can be negative. Happens when the remaining
|
||||
+ // text from current position to the beginning is less than the buffer size.
|
||||
+ // + 1 because mapToUChars must have a slot at the end for the bufNativeLimit entry.
|
||||
int32_t destIx = UTF8_TEXT_CHUNK_SIZE+2; // Start in the overflow region
|
||||
// at end of buffer to leave room
|
||||
@@ -1339,4 +1353,5 @@
|
||||
// Special case ASCII range for speed.
|
||||
buf[destIx] = (UChar)c;
|
||||
+ U_ASSERT(toUCharsMapStart <= srcIx);
|
||||
mapToUChars[srcIx - toUCharsMapStart] = (uint8_t)destIx;
|
||||
mapToNative[destIx] = (uint8_t)(srcIx - toUCharsMapStart);
|
||||
@@ -1368,4 +1383,5 @@
|
||||
mapToUChars[sIx-- - toUCharsMapStart] = (uint8_t)destIx;
|
||||
} while (sIx >= srcIx);
|
||||
+ U_ASSERT(toUCharsMapStart <= (srcIx+1));
|
||||
|
||||
// Set native indexing limit to be the current position.
|
||||
@@ -1542,4 +1558,5 @@
|
||||
U_ASSERT(index<=ut->chunkNativeLimit);
|
||||
int32_t mapIndex = index - u8b->toUCharsMapStart;
|
||||
+ U_ASSERT(mapIndex < (int32_t)sizeof(UTF8Buf::mapToUChars));
|
||||
int32_t offset = u8b->mapToUChars[mapIndex] - u8b->bufStartIdx;
|
||||
U_ASSERT(offset>=0 && offset<=ut->chunkLength);
|
||||
Index: icu/source/test/intltest/utxttest.cpp
|
||||
===================================================================
|
||||
--- icu/source/test/intltest/utxttest.cpp (revision 39670)
|
||||
+++ icu/source/test/intltest/utxttest.cpp (revision 39671)
|
||||
@@ -68,4 +68,6 @@
|
||||
case 7: name = "Ticket12130";
|
||||
if (exec) Ticket12130(); break;
|
||||
+ case 8: name = "Ticket12888";
|
||||
+ if (exec) Ticket12888(); break;
|
||||
default: name = ""; break;
|
||||
}
|
||||
@@ -1584,2 +1586,62 @@
|
||||
utext_close(&ut);
|
||||
}
|
||||
+
|
||||
+// Ticket 12888: bad handling of illegal utf-8 containing many instances of the archaic, now illegal,
|
||||
+// six byte utf-8 forms. Original implementation had an assumption that
|
||||
+// there would be at most three utf-8 bytes per UTF-16 code unit.
|
||||
+// The five and six byte sequences map to a single replacement character.
|
||||
+
|
||||
+void UTextTest::Ticket12888() {
|
||||
+ const char *badString =
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80"
|
||||
+ "\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80\xfd\x80\x80\x80\x80\x80";
|
||||
+
|
||||
+ UErrorCode status = U_ZERO_ERROR;
|
||||
+ LocalUTextPointer ut(utext_openUTF8(NULL, badString, -1, &status));
|
||||
+ TEST_SUCCESS(status);
|
||||
+ for (;;) {
|
||||
+ UChar32 c = utext_next32(ut.getAlias());
|
||||
+ if (c == U_SENTINEL) {
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+ int32_t endIdx = utext_getNativeIndex(ut.getAlias());
|
||||
+ if (endIdx != (int32_t)strlen(badString)) {
|
||||
+ errln("%s:%d expected=%d, actual=%d", __FILE__, __LINE__, strlen(badString), endIdx);
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ for (int32_t prevIndex = endIdx; prevIndex>0;) {
|
||||
+ UChar32 c = utext_previous32(ut.getAlias());
|
||||
+ int32_t currentIndex = utext_getNativeIndex(ut.getAlias());
|
||||
+ if (c != 0xfffd) {
|
||||
+ errln("%s:%d (expected, actual, index) = (%d, %d, %d)\n",
|
||||
+ __FILE__, __LINE__, 0xfffd, c, currentIndex);
|
||||
+ break;
|
||||
+ }
|
||||
+ if (currentIndex != prevIndex - 6) {
|
||||
+ errln("%s:%d: wrong index. Expected, actual = %d, %d",
|
||||
+ __FILE__, __LINE__, prevIndex - 6, currentIndex);
|
||||
+ break;
|
||||
+ }
|
||||
+ prevIndex = currentIndex;
|
||||
+ }
|
||||
+}
|
||||
Index: icu/source/test/intltest/utxttest.h
|
||||
===================================================================
|
||||
--- icu/source/test/intltest/utxttest.h (revision 39670)
|
||||
+++ icu/source/test/intltest/utxttest.h (revision 39671)
|
||||
@@ -39,4 +39,5 @@
|
||||
void Ticket10983();
|
||||
void Ticket12130();
|
||||
+ void Ticket12888();
|
||||
|
||||
private:
|
|
@ -1,130 +0,0 @@
|
|||
Copied from upstream: http://bugs.icu-project.org/trac/changeset/39484/.
|
||||
|
||||
Fixes <http://bugs.gnu.org/26462> (crashes).
|
||||
|
||||
Paths and line endings have been adapted.
|
||||
|
||||
Index: icu/source/common/ulist.c
|
||||
===================================================================
|
||||
--- icu/source/common/ulist.c (revision 39483)
|
||||
+++ icu/source/common/ulist.c (revision 39484)
|
||||
@@ -30,5 +30,4 @@
|
||||
|
||||
int32_t size;
|
||||
- int32_t currentIndex;
|
||||
};
|
||||
|
||||
@@ -52,5 +51,4 @@
|
||||
newList->tail = NULL;
|
||||
newList->size = 0;
|
||||
- newList->currentIndex = -1;
|
||||
|
||||
return newList;
|
||||
@@ -81,6 +79,7 @@
|
||||
p->next->previous = p->previous;
|
||||
}
|
||||
- list->curr = NULL;
|
||||
- list->currentIndex = 0;
|
||||
+ if (p == list->curr) {
|
||||
+ list->curr = p->next;
|
||||
+ }
|
||||
--list->size;
|
||||
if (p->forceDelete) {
|
||||
@@ -151,5 +150,4 @@
|
||||
list->head->previous = newItem;
|
||||
list->head = newItem;
|
||||
- list->currentIndex++;
|
||||
}
|
||||
|
||||
@@ -194,5 +192,4 @@
|
||||
curr = list->curr;
|
||||
list->curr = curr->next;
|
||||
- list->currentIndex++;
|
||||
|
||||
return curr->data;
|
||||
@@ -210,5 +207,4 @@
|
||||
if (list != NULL) {
|
||||
list->curr = list->head;
|
||||
- list->currentIndex = 0;
|
||||
}
|
||||
}
|
||||
@@ -273,3 +269,2 @@
|
||||
return (UList *)(en->context);
|
||||
}
|
||||
-
|
||||
Index: icu/source/i18n/ucol_res.cpp
|
||||
===================================================================
|
||||
--- icu/source/i18n/ucol_res.cpp (revision 39483)
|
||||
+++ icu/source/i18n/ucol_res.cpp (revision 39484)
|
||||
@@ -681,4 +681,5 @@
|
||||
}
|
||||
memcpy(en, &defaultKeywordValues, sizeof(UEnumeration));
|
||||
+ ulist_resetList(sink.values); // Initialize the iterator.
|
||||
en->context = sink.values;
|
||||
sink.values = NULL; // Avoid deletion in the sink destructor.
|
||||
Index: icu/source/test/intltest/apicoll.cpp
|
||||
===================================================================
|
||||
--- icu/source/test/intltest/apicoll.cpp (revision 39483)
|
||||
+++ icu/source/test/intltest/apicoll.cpp (revision 39484)
|
||||
@@ -82,14 +82,7 @@
|
||||
col = Collator::createInstance(Locale::getEnglish(), success);
|
||||
if (U_FAILURE(success)){
|
||||
- errcheckln(success, "Default Collator creation failed. - %s", u_errorName(success));
|
||||
- return;
|
||||
- }
|
||||
-
|
||||
- StringEnumeration* kwEnum = col->getKeywordValuesForLocale("", Locale::getEnglish(),true,success);
|
||||
- if (U_FAILURE(success)){
|
||||
- errcheckln(success, "Get Keyword Values for Locale failed. - %s", u_errorName(success));
|
||||
- return;
|
||||
- }
|
||||
- delete kwEnum;
|
||||
+ errcheckln(success, "English Collator creation failed. - %s", u_errorName(success));
|
||||
+ return;
|
||||
+ }
|
||||
|
||||
col->getVersion(versionArray);
|
||||
@@ -230,4 +223,27 @@
|
||||
delete aFrCol;
|
||||
delete junk;
|
||||
+}
|
||||
+
|
||||
+void CollationAPITest::TestKeywordValues() {
|
||||
+ IcuTestErrorCode errorCode(*this, "TestKeywordValues");
|
||||
+ LocalPointer<Collator> col(Collator::createInstance(Locale::getEnglish(), errorCode));
|
||||
+ if (errorCode.logIfFailureAndReset("English Collator creation failed")) {
|
||||
+ return;
|
||||
+ }
|
||||
+
|
||||
+ LocalPointer<StringEnumeration> kwEnum(
|
||||
+ col->getKeywordValuesForLocale("collation", Locale::getEnglish(), TRUE, errorCode));
|
||||
+ if (errorCode.logIfFailureAndReset("Get Keyword Values for English Collator failed")) {
|
||||
+ return;
|
||||
+ }
|
||||
+ assertTrue("expect at least one collation tailoring for English", kwEnum->count(errorCode) > 0);
|
||||
+ const char *kw;
|
||||
+ UBool hasStandard = FALSE;
|
||||
+ while ((kw = kwEnum->next(NULL, errorCode)) != NULL) {
|
||||
+ if (strcmp(kw, "standard") == 0) {
|
||||
+ hasStandard = TRUE;
|
||||
+ }
|
||||
+ }
|
||||
+ assertTrue("expect at least the 'standard' collation tailoring for English", hasStandard);
|
||||
}
|
||||
|
||||
@@ -2467,4 +2483,5 @@
|
||||
TESTCASE_AUTO_BEGIN;
|
||||
TESTCASE_AUTO(TestProperty);
|
||||
+ TESTCASE_AUTO(TestKeywordValues);
|
||||
TESTCASE_AUTO(TestOperators);
|
||||
TESTCASE_AUTO(TestDuplicate);
|
||||
Index: icu/source/test/intltest/apicoll.h
|
||||
===================================================================
|
||||
--- icu/source/test/intltest/apicoll.h (revision 39483)
|
||||
+++ icu/source/test/intltest/apicoll.h (revision 39484)
|
||||
@@ -36,4 +36,5 @@
|
||||
*/
|
||||
void TestProperty(/* char* par */);
|
||||
+ void TestKeywordValues();
|
||||
|
||||
/**
|
Loading…
Reference in New Issue