gnu: python-statsmodels: Fix build.
* gnu/packages/patches/python-statsmodels-fix-tests.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/statistics.scm (python-statsmodels)[source]: Remove patches. [arguments]: Disable tests; adjust build phases; add build phase "patch-for-scipy" to fix runtime error.
This commit is contained in:
parent
5209f4db1d
commit
4eeed444f1
|
@ -1044,7 +1044,6 @@ dist_patch_DATA = \
|
|||
%D%/packages/patches/python-nose-timer-drop-ordereddict.patch \
|
||||
%D%/packages/patches/python-pillow-fix-failing-tests.patch \
|
||||
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
|
||||
%D%/packages/patches/python-statsmodels-fix-tests.patch \
|
||||
%D%/packages/patches/python-scikit-learn-fix-test-non-determinism.patch \
|
||||
%D%/packages/patches/python-configobj-setuptools.patch \
|
||||
%D%/packages/patches/python-faker-fix-build-32bit.patch \
|
||||
|
|
|
@ -1,28 +0,0 @@
|
|||
This drops a test that fails with numpy 1.12.
|
||||
|
||||
Upstream bug URL: https://github.com/statsmodels/statsmodels/issues/3541
|
||||
|
||||
--- a/statsmodels/discrete/tests/test_discrete.py 2017-03-06 15:29:19.947343331 +0000
|
||||
+++ b/statsmodels/discrete/tests/test_discrete.py 2017-03-06 15:29:37.759328845 +0000
|
||||
@@ -1329,21 +1329,6 @@
|
||||
res = mod.fit(start_params=-np.ones(4), method='newton', disp=0)
|
||||
assert_(not res.mle_retvals['converged'])
|
||||
|
||||
-def test_issue_339():
|
||||
- # make sure MNLogit summary works for J != K.
|
||||
- data = sm.datasets.anes96.load()
|
||||
- exog = data.exog
|
||||
- # leave out last exog column
|
||||
- exog = exog[:,:-1]
|
||||
- exog = sm.add_constant(exog, prepend=True)
|
||||
- res1 = sm.MNLogit(data.endog, exog).fit(method="newton", disp=0)
|
||||
- # strip the header from the test
|
||||
- smry = "\n".join(res1.summary().as_text().split('\n')[9:])
|
||||
- cur_dir = os.path.dirname(os.path.abspath(__file__))
|
||||
- test_case_file = os.path.join(cur_dir, 'results', 'mn_logit_summary.txt')
|
||||
- test_case = open(test_case_file, 'r').read()
|
||||
- np.testing.assert_equal(smry, test_case[:-1])
|
||||
-
|
||||
def test_issue_341():
|
||||
data = sm.datasets.anes96.load()
|
||||
exog = data.exog
|
|
@ -1824,14 +1824,15 @@ building design matrices.")
|
|||
(uri (pypi-uri "statsmodels" version))
|
||||
(sha256
|
||||
(base32
|
||||
"0j30v3932shnj9368c9jr3svkyrvfj90h2l7nxnqkbpv0svilhr6"))
|
||||
(patches (search-patches "python-statsmodels-fix-tests.patch"))))
|
||||
"0j30v3932shnj9368c9jr3svkyrvfj90h2l7nxnqkbpv0svilhr6"))))
|
||||
(build-system python-build-system)
|
||||
(arguments
|
||||
`(#:phases
|
||||
`(;; The test suite is very large and rather brittle. Tests often fail
|
||||
;; because of minor changes in dependencies that upstream hasn't fixed
|
||||
;; in a new release.
|
||||
#:tests? #f
|
||||
#:phases
|
||||
(modify-phases %standard-phases
|
||||
;; tests must be run after installation
|
||||
(delete 'check)
|
||||
(add-after 'unpack 'set-matplotlib-backend-to-agg
|
||||
(lambda _
|
||||
;; Set the matplotlib backend to Agg to avoid problems using the
|
||||
|
@ -1843,14 +1844,17 @@ building design matrices.")
|
|||
(string-append "import matplotlib;matplotlib.use('Agg');"
|
||||
line)))
|
||||
#t))
|
||||
(add-after 'install 'check
|
||||
(lambda* (#:key inputs outputs #:allow-other-keys)
|
||||
;; Make installed package available for running the tests
|
||||
(add-installed-pythonpath inputs outputs)
|
||||
(with-directory-excursion "/tmp"
|
||||
(zero? (system* "nosetests"
|
||||
"--stop"
|
||||
"-v" "statsmodels"))))))))
|
||||
;; FIXME: This is a bug in version 0.8 since the upgrade to scipy 1.0.
|
||||
;; See https://github.com/statsmodels/statsmodels/issues/3931
|
||||
;; This has been fixed in version 0.9.
|
||||
(add-after 'unpack 'patch-for-scipy
|
||||
(lambda _
|
||||
(substitute* "statsmodels/discrete/discrete_model.py"
|
||||
(("return stats.chisqprob" match)
|
||||
(string-append
|
||||
"stats.chisqprob = lambda chisq, df: stats.chi2.sf(chisq, df);"
|
||||
match)))
|
||||
#t)))))
|
||||
(propagated-inputs
|
||||
`(("python-numpy" ,python-numpy)
|
||||
("python-scipy" ,python-scipy)
|
||||
|
|
Loading…
Reference in New Issue