gnu: Add orpheus.

* gnu/packages/orpheus.scm: New file.
* gnu/packages/patches/orpheus-cast-errors-and-includes.patch: New patch.
* gnu-system.am (GNU_SYSTEM_MODULES): Add file.
  (dist_patch_DATA): Add patch.
master
Eric Bavier 2014-07-24 23:40:44 -05:00
parent 4a3e602c72
commit 51152cd125
3 changed files with 149 additions and 0 deletions

View File

@ -185,6 +185,7 @@ GNU_SYSTEM_MODULES = \
gnu/packages/onc-rpc.scm \
gnu/packages/openldap.scm \
gnu/packages/openssl.scm \
gnu/packages/orpheus.scm \
gnu/packages/package-management.scm \
gnu/packages/parallel.scm \
gnu/packages/patchutils.scm \
@ -349,6 +350,7 @@ dist_patch_DATA = \
gnu/packages/patches/mit-krb5-init-fix.patch \
gnu/packages/patches/mpc123-initialize-ao.patch \
gnu/packages/patches/module-init-tools-moduledir.patch \
gnu/packages/patches/orpheus-cast-errors-and-includes.patch \
gnu/packages/patches/patchelf-page-size.patch \
gnu/packages/patches/patchutils-xfail-gendiff-tests.patch \
gnu/packages/patches/perl-no-sys-dirs.patch \

96
gnu/packages/orpheus.scm Normal file
View File

@ -0,0 +1,96 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
;;; GNU Guix is free software; you can redistribute it and/or modify it
;;; under the terms of the GNU General Public License as published by
;;; the Free Software Foundation; either version 3 of the License, or (at
;;; your option) any later version.
;;;
;;; GNU Guix is distributed in the hope that it will be useful, but
;;; WITHOUT ANY WARRANTY; without even the implied warranty of
;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
;;; GNU General Public License for more details.
;;;
;;; You should have received a copy of the GNU General Public License
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages orpheus)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages mp3)
#:use-module (gnu packages which)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml))
(define-public orpheus
(package
(name "orpheus")
(version "1.6")
(source
(origin
(method url-fetch)
(uri (string-append "http://thekonst.net/download/orpheus-"
version ".tar.gz"))
(sha256
(base32
"1xbgxq8fybwhm51nw9hvvrgi873qzkc2qvmy15d2m2hw2yqa99hq"))
(patches (list (search-patch "orpheus-cast-errors-and-includes.patch")))))
(build-system gnu-build-system)
(inputs
`(("ncurses" ,ncurses)
("libvorbis" ,libvorbis)
("vorbis-tools" ,vorbis-tools)
("mpg321" ,mpg321)
;; TODO: add ghttp
("libxml2" ,libxml2)
("which" ,which)))
(arguments
`(#:phases
(alist-replace
'configure
(lambda* (#:key outputs #:allow-other-keys)
;; This old `configure' script does not support variables passed as
;; arguments.
(let ((out (assoc-ref outputs "out")))
(setenv "CONFIG_SHELL" (which "bash"))
(setenv "SHELL" (which "bash"))
(setenv "LIBS" "-logg") ;doesn't declare its use of libogg
(zero?
(system* "./configure" (string-append "--prefix=" out)))))
(alist-cons-after
'configure 'configure-players
(lambda* (#:key inputs #:allow-other-keys)
;; To avoid propagating the mpg321 and vorbis-tools inputs, we can
;; make the orpheus application execute the needed players from the
;; store.
(let ((ogg123 (string-append (assoc-ref inputs "vorbis-tools")
"/bin/ogg123"))
(mpg321 (string-append (assoc-ref inputs "mpg321")
"/bin/mpg321"))
(which (string-append (assoc-ref inputs "which")
"/bin/which")))
(substitute* "src/orpheusconf.cc"
(("ogg123") ogg123)
(("which") which)
(("mpg321") mpg321))))
(alist-cons-before
'build 'patch-shells
(lambda _
(substitute* '("src/mp3track.cc"
"src/streamtrack.cc"
"src/oggtrack.cc")
(("/bin/sh") (which "bash"))))
%standard-phases)))))
(home-page "http://thekonst.net/en/orpheus")
(synopsis "Text-mode audio player")
(description
"Orpheus is a light-weight text mode menu- and window-driven audio player
application for CDs, internet stream broadcasts, and files in MP3 and Vorbis
OGG format.")
(license gpl2+)))

View File

@ -0,0 +1,51 @@
The 'intcompare' definition was causing a "cast from 'void*' to 'int' loses
precision [-fpermissive]" error. It isn't used anywhere, so simply remove it.
Same with 'findint' in texteditor.cc.
Fix other "cast from void* to int loses precision" errors.
--- a/kkstrtext-0.1/kkstrtext.cc 2005-01-31 18:13:24.000000000 -0600
+++ b/kkstrtext-0.1/kkstrtext.cc 2014-07-24 00:25:07.149305476 -0500
@@ -430,10 +430,6 @@
}
}
-int intcompare(void *s1, void *s2) {
- return (int) s1 != (int) s2;
-}
-
string i2str(int i) {
char buf[64];
sprintf(buf, "%d", i);
@@ -885,7 +881,7 @@
#ifdef HAVE_ICONV
iconv_t cd = iconv_open(tocs.c_str(), fromcs.c_str());
- if(((int) cd) != -1) {
+ if(cd != (iconv_t) -1) {
string r, text(atext);
size_t inleft, outleft, soutleft;
char *inbuf, *outbuf, *sinbuf, *soutbuf;
--- a/kkconsui-0.1/src/texteditor.cc 2003-09-09 16:51:33.000000000 -0500
+++ b/kkconsui-0.1/src/texteditor.cc 2014-07-24 00:33:20.093279060 -0500
@@ -1939,10 +1939,6 @@
if(ur) delete ur;
}
-int texteditor::findint(void *p1, void *p2) {
- return *(int *) p1 != (int) p2;
-}
-
int texteditor::findhighline(void *p1, void *p2) {
return *(int *) p1 != ((highline *) p2)->line;
}
--- a/src/streamtrack.cc 2006-05-11 12:45:20.000000000 -0500
+++ b/src/streamtrack.cc 2014-07-24 00:38:10.797263482 -0500
@@ -34,6 +34,7 @@
#include <sys/wait.h>
#include <sys/stat.h>
#include <signal.h>
+#include <unistd.h>
#include <algorithm>